summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-02-22 21:55:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-02-22 21:55:45 +0000
commit0329ed1c1feab36f40501b7af1600391cdc69bc4 (patch)
treecb641252c49e0b91eb3e0503e9120d3d90501e46 /games-emulation/fbzx
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-0329ed1c1feab36f40501b7af1600391cdc69bc4.tar.gz
gentoo-2-0329ed1c1feab36f40501b7af1600391cdc69bc4.tar.bz2
gentoo-2-0329ed1c1feab36f40501b7af1600391cdc69bc4.zip
version bump
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'games-emulation/fbzx')
-rw-r--r--games-emulation/fbzx/ChangeLog10
-rw-r--r--games-emulation/fbzx/fbzx-2.4.0.ebuild40
-rw-r--r--games-emulation/fbzx/files/fbzx-2.4.0-build.patch87
3 files changed, 135 insertions, 2 deletions
diff --git a/games-emulation/fbzx/ChangeLog b/games-emulation/fbzx/ChangeLog
index f3a680ad10e3..a58855440064 100644
--- a/games-emulation/fbzx/ChangeLog
+++ b/games-emulation/fbzx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/fbzx
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/ChangeLog,v 1.20 2009/11/21 19:19:34 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/ChangeLog,v 1.21 2010/02/22 21:55:44 mr_bones_ Exp $
+
+*fbzx-2.4.0 (22 Feb 2010)
+
+ 22 Feb 2010; Michael Sterrett <mr_bones_@gentoo.org> +fbzx-2.4.0.ebuild,
+ +files/fbzx-2.4.0-build.patch:
+ version bump
21 Nov 2009; Markus Meier <maekke@gentoo.org> fbzx-2.1b.ebuild:
x86 stable, bug #289011
diff --git a/games-emulation/fbzx/fbzx-2.4.0.ebuild b/games-emulation/fbzx/fbzx-2.4.0.ebuild
new file mode 100644
index 000000000000..5361d33c6601
--- /dev/null
+++ b/games-emulation/fbzx/fbzx-2.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/fbzx-2.4.0.ebuild,v 1.1 2010/02/22 21:55:44 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="A Sinclair Spectrum emulator, designed to work at full screen using the FrameBuffer"
+HOMEPAGE="http://www.rastersoft.com/fbzx.html"
+SRC_URI="http://www.rastersoft.com/descargas/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[video]
+ media-sound/pulseaudio
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e "s|/usr/share/|${GAMES_DATADIR}/${PN}/|g" \
+ emulator.c \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-build.patch
+ rm -f fbzx_fs fbzx *.o # clean out accidentally packaged .o files
+}
+
+src_install() {
+ dogamesbin fbzx || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r keymap.bmp spectrum-roms || die "doins failed"
+ dodoc AMSTRAD CAPABILITIES FAQ PORTING README* TODO VERSIONS
+ doicon fbzx.svg
+ make_desktop_entry fbzx FBZX
+ prepgamesdirs
+}
diff --git a/games-emulation/fbzx/files/fbzx-2.4.0-build.patch b/games-emulation/fbzx/files/fbzx-2.4.0-build.patch
new file mode 100644
index 000000000000..3002cdac6bda
--- /dev/null
+++ b/games-emulation/fbzx/files/fbzx-2.4.0-build.patch
@@ -0,0 +1,87 @@
+diff -ru fbzx-2.4.0.orig/Makefile fbzx-2.4.0/Makefile
+--- fbzx-2.4.0.orig/Makefile 2009-12-25 19:40:21.000000000 -0500
++++ fbzx-2.4.0/Makefile 2010-02-22 16:38:32.382511097 -0500
+@@ -1,9 +1,9 @@
+-CC = gcc -O2 -Wall -Wno-pointer-sign `pkg-config --cflags sdl libpulse-simple alsa` -D D_SOUND_PULSE -D D_SOUND_ALSA -D D_SOUND_OSS
+-CCo = gcc `pkg-config --libs sdl libpulse-simple alsa`
++CFLAGS += `pkg-config --cflags sdl libpulse-simple alsa` -D D_SOUND_PULSE -D D_SOUND_ALSA -D D_SOUND_OSS
++LDFLAGS += `pkg-config --libs sdl libpulse-simple alsa`
+
+ fbzx: computer.o Z80free.o Z80free_codes.o Z80free_codesCB.o Z80free_codesED.o Z80free_codesDD.o Z80free_codesFD.o Z80free_codesDDCB.o Z80free_codesFDCB.o emulator.o cargador.o characters.o menus.o sound.o tape.o spk_ay.o microdrive.o
+
+- $(CCo) -o fbzx computer.o Z80free.o Z80free_codes.o Z80free_codesCB.o Z80free_codesED.o Z80free_codesDD.o Z80free_codesFD.o Z80free_codesDDCB.o Z80free_codesFDCB.o emulator.o cargador.o characters.o menus.o sound.o tape.o spk_ay.o microdrive.o
++ $(CC) -o fbzx computer.o Z80free.o Z80free_codes.o Z80free_codesCB.o Z80free_codesED.o Z80free_codesDD.o Z80free_codesFD.o Z80free_codesDDCB.o Z80free_codesFDCB.o emulator.o cargador.o characters.o menus.o sound.o tape.o spk_ay.o microdrive.o $(LDFLAGS)
+
+ clean:
+ rm fbzx *.o *~
+@@ -31,53 +31,53 @@
+ rm -rf /usr/local/share/spectrum-roms
+
+ spk_ay.o: spk_ay.c spk_ay.h emulator.h sound.h computer.h z80free/Z80free.h
+- $(CC) -c -o spk_ay.o spk_ay.c
++ $(CC) $(CFLAGS) -c -o spk_ay.o spk_ay.c
+
+ microdrive.o: microdrive.c microdrive.h z80free/Z80free.h computer.h emulator.h z80free/Z80free.h
+- $(CC) -c -o microdrive.o microdrive.c
++ $(CC) $(CFLAGS) -c -o microdrive.o microdrive.c
+
+ sound.o: sound.c sound.h computer.h emulator.h z80free/Z80free.h
+- $(CC) -c -o sound.o sound.c
++ $(CC) $(CFLAGS) -c -o sound.o sound.c
+
+ emulator.o: emulator.c z80free/Z80free.h computer.h emulator.h characters.h menus.h cargador.h sound.h tape.h microdrive.h
+- $(CC) -c -o emulator.o emulator.c
++ $(CC) $(CFLAGS) -c -o emulator.o emulator.c
+
+ computer.o: computer.c z80free/Z80free.h computer.h emulator.h characters.h menus.h cargador.h sound.h tape.h spk_ay.h microdrive.h
+- $(CC) -c -o computer.o computer.c
++ $(CC) $(CFLAGS) -c -o computer.o computer.c
+
+ tape.o: tape.c z80free/Z80free.h computer.h emulator.h menus.h tape.h computer.h
+- $(CC) -c -o tape.o tape.c
++ $(CC) $(CFLAGS) -c -o tape.o tape.c
+
+ cargador.o: cargador.c cargador.h computer.h emulator.h z80free/Z80free.h characters.h menus.h computer.h
+- $(CC) -c -o cargador.o cargador.c
++ $(CC) $(CFLAGS) -c -o cargador.o cargador.c
+
+ characters.o: characters.c characters.h emulator.h computer.h
+- $(CC) -c -o characters.o characters.c
++ $(CC) $(CFLAGS) -c -o characters.o characters.c
+
+ menus.o: menus.c menus.h characters.h computer.h emulator.h z80free/Z80free.h cargador.h tape.h
+- $(CC) -c -o menus.o menus.c
++ $(CC) $(CFLAGS) -c -o menus.o menus.c
+
+ Z80free.o: z80free/Z80free.c z80free/Z80free.h
+- $(CC) -c -o Z80free.o z80free/Z80free.c
++ $(CC) $(CFLAGS) -c -o Z80free.o z80free/Z80free.c
+
+ Z80free_codes.o: z80free/Z80free_codes.c z80free/Z80free.h
+- $(CC) -c -o Z80free_codes.o z80free/Z80free_codes.c
++ $(CC) $(CFLAGS) -c -o Z80free_codes.o z80free/Z80free_codes.c
+
+ Z80free_codesCB.o: z80free/Z80free_codesCB.c z80free/Z80free.h
+- $(CC) -c -o Z80free_codesCB.o z80free/Z80free_codesCB.c
++ $(CC) $(CFLAGS) -c -o Z80free_codesCB.o z80free/Z80free_codesCB.c
+
+ Z80free_codesED.o: z80free/Z80free_codesED.c z80free/Z80free.h
+- $(CC) -c -o Z80free_codesED.o z80free/Z80free_codesED.c
++ $(CC) $(CFLAGS) -c -o Z80free_codesED.o z80free/Z80free_codesED.c
+
+ Z80free_codesDD.o: z80free/Z80free_codesDD.c z80free/Z80free.h
+- $(CC) -c -o Z80free_codesDD.o z80free/Z80free_codesDD.c
++ $(CC) $(CFLAGS) -c -o Z80free_codesDD.o z80free/Z80free_codesDD.c
+
+ Z80free_codesFD.o: z80free/Z80free_codesFD.c z80free/Z80free.h
+- $(CC) -c -o Z80free_codesFD.o z80free/Z80free_codesFD.c
++ $(CC) $(CFLAGS) -c -o Z80free_codesFD.o z80free/Z80free_codesFD.c
+
+ Z80free_codesDDCB.o: z80free/Z80free_codesDDCB.c z80free/Z80free.h
+- $(CC) -c -o Z80free_codesDDCB.o z80free/Z80free_codesDDCB.c
++ $(CC) $(CFLAGS) -c -o Z80free_codesDDCB.o z80free/Z80free_codesDDCB.c
+
+ Z80free_codesFDCB.o: z80free/Z80free_codesFDCB.c z80free/Z80free.h
+- $(CC) -c -o Z80free_codesFDCB.o z80free/Z80free_codesFDCB.c
++ $(CC) $(CFLAGS) -c -o Z80free_codesFDCB.o z80free/Z80free_codesFDCB.c
+