summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-03-20 04:39:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-03-20 04:39:46 +0000
commit08a4edea0b524a271dc0500847ac04530c30e67a (patch)
tree1b79244976ef315a1618d4ee919e5a4b79249e07 /games-emulation/dosbox
parentRegistered jars per bug #171496. Copy one bin dir instead of two. Replace cop... (diff)
downloadgentoo-2-08a4edea0b524a271dc0500847ac04530c30e67a.tar.gz
gentoo-2-08a4edea0b524a271dc0500847ac04530c30e67a.tar.bz2
gentoo-2-08a4edea0b524a271dc0500847ac04530c30e67a.zip
add USE=debug support with patch from ebfe (bug #121372)
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-emulation/dosbox')
-rw-r--r--games-emulation/dosbox/ChangeLog5
-rw-r--r--games-emulation/dosbox/dosbox-0.70.ebuild14
2 files changed, 13 insertions, 6 deletions
diff --git a/games-emulation/dosbox/ChangeLog b/games-emulation/dosbox/ChangeLog
index fee8acac83db..ee945a667a64 100644
--- a/games-emulation/dosbox/ChangeLog
+++ b/games-emulation/dosbox/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/dosbox
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.29 2007/03/04 02:18:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.30 2007/03/20 04:39:46 mr_bones_ Exp $
+
+ 20 Mar 2007; Michael Sterrett <mr_bones_@gentoo.org> dosbox-0.70.ebuild:
+ add USE=debug support with patch from ebfe (bug #121372)
04 Mar 2007; Michael Sterrett <mr_bones_@gentoo.org> dosbox-0.65.ebuild,
dosbox-0.70.ebuild:
diff --git a/games-emulation/dosbox/dosbox-0.70.ebuild b/games-emulation/dosbox/dosbox-0.70.ebuild
index b57a9677565e..60e36896e1a6 100644
--- a/games-emulation/dosbox/dosbox-0.70.ebuild
+++ b/games-emulation/dosbox/dosbox-0.70.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.70.ebuild,v 1.3 2007/03/15 12:00:33 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.70.ebuild,v 1.4 2007/03/20 04:39:46 mr_bones_ Exp $
inherit eutils games
@@ -11,14 +11,15 @@ SRC_URI="mirror://sourceforge/dosbox/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86"
-IUSE="alsa hardened opengl"
+IUSE="alsa debug hardened opengl sdl png"
DEPEND="alsa? ( media-libs/alsa-lib )
opengl? ( virtual/opengl )
- media-libs/libpng
+ png? ( media-libs/libpng )
+ debug? ( sys-libs/ncurses )
media-libs/libsdl
- media-libs/sdl-net
- media-libs/sdl-sound"
+ sdl? ( media-libs/sdl-net
+ media-libs/sdl-sound )"
pkg_setup() {
if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
@@ -39,6 +40,9 @@ src_compile() {
if use hardened ; then
myconf="${myconf} --disable-dynamic-x86"
fi
+ if use debug ; then
+ myconf="${myconf} --enable-debug"
+ fi
egamesconf \
--disable-dependency-tracking \
${myconf} \