summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-13 06:24:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-13 06:24:43 +0000
commit14c918e47667bf26b4a69a8c25bc609f89383c5f (patch)
tree721b1c9970e46d6dbe2da6ed12a01fcb2a816c00 /games-emulation/dgen-sdl
parentrevbump, conversion -> distutils-r1, rm prior revbump (diff)
downloadgentoo-2-14c918e47667bf26b4a69a8c25bc609f89383c5f.tar.gz
gentoo-2-14c918e47667bf26b4a69a8c25bc609f89383c5f.tar.bz2
gentoo-2-14c918e47667bf26b4a69a8c25bc609f89383c5f.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation/dgen-sdl')
-rw-r--r--games-emulation/dgen-sdl/ChangeLog10
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.32.ebuild4
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild38
3 files changed, 48 insertions, 4 deletions
diff --git a/games-emulation/dgen-sdl/ChangeLog b/games-emulation/dgen-sdl/ChangeLog
index 06449cba9228..776c22e7736a 100644
--- a/games-emulation/dgen-sdl/ChangeLog
+++ b/games-emulation/dgen-sdl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/dgen-sdl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/ChangeLog,v 1.22 2014/08/25 20:54:17 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/ChangeLog,v 1.23 2015/02/13 06:24:43 mr_bones_ Exp $
+
+*dgen-sdl-1.33 (13 Feb 2015)
+
+ 13 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> +dgen-sdl-1.33.ebuild,
+ dgen-sdl-1.32.ebuild:
+ version bump
25 Aug 2014; Michael Sterrett <mr_bones_@gentoo.org> -dgen-sdl-1.31.ebuild:
old
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.32.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.32.ebuild
index 366d1c1bd29c..6af97722160a 100644
--- a/games-emulation/dgen-sdl/dgen-sdl-1.32.ebuild
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.32.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.32.ebuild,v 1.1 2013/06/24 17:13:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.32.ebuild,v 1.2 2015/02/13 06:24:43 mr_bones_ Exp $
EAPI=5
inherit games
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild
new file mode 100644
index 000000000000..f71ebff66ca1
--- /dev/null
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild,v 1.1 2015/02/13 06:24:43 mr_bones_ Exp $
+
+EAPI=5
+inherit games
+
+DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
+HOMEPAGE="http://dgen.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dgen/files/${P}.tar.gz"
+
+LICENSE="dgen-sdl BSD BSD-2 free-noncomm LGPL-2.1+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="joystick opengl"
+
+RDEPEND="media-libs/libsdl[joystick?,opengl?]
+ app-arch/libarchive
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+src_configure() {
+ egamesconf \
+ $(use_enable x86 asm) \
+ $(use_enable joystick) \
+ $(use_enable opengl)
+}
+
+src_compile() {
+ emake -C musa m68kops.h
+ emake
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README sample.dgenrc" default
+ prepgamesdirs
+}