summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-07-24 17:30:46 +0000
committerHanno Böck <hanno@gentoo.org>2009-07-24 17:30:46 +0000
commit11287713e2f72f8b7c666a4f46cf7b70482a1051 (patch)
tree2e11c53ce03cb56072959a2eb1f2b699db8ac0db /games-emulation/desmume/desmume-0.9.4.ebuild
parentFix building with GCC 4.4 wrt #269258, thanks to Martin Väth. (diff)
downloadgentoo-2-11287713e2f72f8b7c666a4f46cf7b70482a1051.tar.gz
gentoo-2-11287713e2f72f8b7c666a4f46cf7b70482a1051.tar.bz2
gentoo-2-11287713e2f72f8b7c666a4f46cf7b70482a1051.zip
desmume gcc44 patch
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/desmume/desmume-0.9.4.ebuild')
-rw-r--r--games-emulation/desmume/desmume-0.9.4.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/games-emulation/desmume/desmume-0.9.4.ebuild b/games-emulation/desmume/desmume-0.9.4.ebuild
index afcf66e0f99d..49de72d7d184 100644
--- a/games-emulation/desmume/desmume-0.9.4.ebuild
+++ b/games-emulation/desmume/desmume-0.9.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/desmume/desmume-0.9.4.ebuild,v 1.1 2009/07/10 22:33:43 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/desmume/desmume-0.9.4.ebuild,v 1.2 2009/07/24 17:30:46 hanno Exp $
EAPI="2"
-inherit games
+inherit games eutils
DESCRIPTION="Emulator for Nintendo DS."
HOMEPAGE="http://desmume.org/"
@@ -26,6 +26,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${P}"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc44.patch"
+}
+
src_compile() {
egamesconf --datadir=/usr/share || die "egamesconf failed"
emake || die "emake failed"