summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2008-12-09 10:17:30 +0000
committerChristian Birchinger <joker@gentoo.org>2008-12-09 10:17:30 +0000
commitb78ceb5b2c782def7351885ee4927df81fc416b2 (patch)
treec7781e6a84df551ec65ae57e2dcab95cb8675b7e /games-emulation/daphne/daphne-1.0.ebuild
parentUse a more useful sysconf dir, for OpenILS/Evergreen to pick up. (diff)
downloadgentoo-2-b78ceb5b2c782def7351885ee4927df81fc416b2.tar.gz
gentoo-2-b78ceb5b2c782def7351885ee4927df81fc416b2.tar.bz2
gentoo-2-b78ceb5b2c782def7351885ee4927df81fc416b2.zip
Changed MMX defines and exports for x86
(Portage version: 2.1.4.5)
Diffstat (limited to 'games-emulation/daphne/daphne-1.0.ebuild')
-rw-r--r--games-emulation/daphne/daphne-1.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/games-emulation/daphne/daphne-1.0.ebuild b/games-emulation/daphne/daphne-1.0.ebuild
index 42d64bc56d23..e462a36531b6 100644
--- a/games-emulation/daphne/daphne-1.0.ebuild
+++ b/games-emulation/daphne/daphne-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-1.0.ebuild,v 1.1 2008/09/19 14:54:20 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-1.0.ebuild,v 1.2 2008/12/09 10:17:30 joker Exp $
inherit eutils toolchain-funcs games
@@ -56,7 +56,8 @@ src_compile() {
local archflags
if use x86; then
- archflags="-DNATIVE_CPU_X86 -DMMX_RGB2YUV USE_MMX=1"
+ archflags="-DNATIVE_CPU_X86 -DMMX_RGB2YUV -DUSE_MMX"
+ export USE_MMX=1
else
# -fPIC is needed on amd64 but fails on x86.
archflags="-fPIC"