summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-25 11:56:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-25 11:56:15 +0000
commit3bb03d187f2f8858ac2f20787b8630d25f5ce731 (patch)
treeb0a34a974f217f22fbc0fb58756296cc7d83bbba /games-emulation/advancemame
parentdoesnt really need X (diff)
downloadgentoo-2-3bb03d187f2f8858ac2f20787b8630d25f5ce731.tar.gz
gentoo-2-3bb03d187f2f8858ac2f20787b8630d25f5ce731.tar.bz2
gentoo-2-3bb03d187f2f8858ac2f20787b8630d25f5ce731.zip
ver bump
Diffstat (limited to 'games-emulation/advancemame')
-rw-r--r--games-emulation/advancemame/ChangeLog7
-rw-r--r--games-emulation/advancemame/advancemame-0.76.0.ebuild67
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.76.02
-rw-r--r--games-emulation/advancemame/metadata.xml18
4 files changed, 93 insertions, 1 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 9ad119bb4da8..a5cd9e1f3604 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.2 2003/09/10 16:03:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.3 2003/10/25 11:56:15 vapier Exp $
+
+*advancemame-0.76.0 (25 Oct 2003)
+
+ 25 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bumpage + clean up + games.eclass.
*advancemame-0.70.0 (13 Jul 2003)
diff --git a/games-emulation/advancemame/advancemame-0.76.0.ebuild b/games-emulation/advancemame/advancemame-0.76.0.ebuild
new file mode 100644
index 000000000000..9e29dc8ecba8
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.76.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.76.0.ebuild,v 1.1 2003/10/25 11:56:15 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 xmame"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND="virtual/glibc
+ app-arch/unzip
+ x86? ( >=dev-lang/nasm-0.98 )
+ media-libs/libsdl
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ sed -i \
+ 's:slang/slang\.h:slang.h:' \
+ advance/linux/{os,vslang}.c
+}
+
+src_compile() {
+ export PATH="${PATH}:${T}"
+ ln -s `which nasm` ${T}/${CHOST}-nasm >& /dev/null
+ egamesconf \
+ --host="" \
+ `use_enable debug` \
+ `use_enable static` \
+ `use_enable x86 asm` \
+ `use_enable svga svgalib` \
+ `use_enable fbconf fb` \
+ `use_enable alsa` \
+ `use_enable oss` \
+ `use_enable slang` \
+ `use_enable sdl` \
+ --with-system=sdl \
+ --enable-pthread \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die
+}
+
+src_install() {
+ dogamesbin adv*
+
+ dodir ${GAMES_DATADIR}/advance/{artwork,diff,image,rom,sample,snap}
+ insinto ${GAMES_DATADIR}/advance
+ doins support/event.dat
+
+ dodoc HISTORY README RELEASE obj/doc/*.txt
+ dohtml obj/doc/*.html
+ for m in obj/doc/*.1 ; do
+ newman ${m} ${m/.1/.6}
+ done
+}
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.76.0 b/games-emulation/advancemame/files/digest-advancemame-0.76.0
new file mode 100644
index 000000000000..7a22878780ee
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.76.0
@@ -0,0 +1,2 @@
+MD5 a1171a694daae75aea427180be1ade60 advancemame-0.76.0.tar.gz 9988910
+MD5 22cc67451dd90c68bddd67157e5728d3 advancemenu-2.2.13.tar.gz 1207317
diff --git a/games-emulation/advancemame/metadata.xml b/games-emulation/advancemame/metadata.xml
new file mode 100644
index 000000000000..16d0b6420e80
--- /dev/null
+++ b/games-emulation/advancemame/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+AdvanceMAME and AdvanceMESS are unofficial MAME and MESS versions with an advanced video support for
+helping the use with TVs, Arcade Monitors, Fixed Frequencies Monitors and also for PC Monitors.
+
+They run in GNU/Linux, Mac OS X, DOS, Windows and in all the other platforms supported by the SDL library.
+
+The main difference compared with the official emulators is that the Advance versions program directly the
+video board to always get a video mode with the correct size and frequency.
+
+Generally the Advance emulators are able to use a video mode which doesn't require any stretching or other
+unneeded effects to match the original arcade display. When the stretching is required by hardware
+limitations you can anyway choice from different types of stretch.
+</longdescription>
+</pkgmetadata>