summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-27 09:33:04 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-27 09:33:04 +0000
commitff5ed7e645815036446d3493bbfe5e0b1aae1b88 (patch)
tree220558244914cacdf1bc02d8cda57edd485c0a02 /games-board
parentVersion bump subvertpy to 0.7.5. (diff)
downloadgentoo-2-ff5ed7e645815036446d3493bbfe5e0b1aae1b88.tar.gz
gentoo-2-ff5ed7e645815036446d3493bbfe5e0b1aae1b88.tar.bz2
gentoo-2-ff5ed7e645815036446d3493bbfe5e0b1aae1b88.zip
Fix overflow. Bug #340901
(Portage version: 2.1.9.22/cvs/Linux i686)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnushogi/ChangeLog6
-rw-r--r--games-board/gnushogi/files/gnushogi-1.3-ovflfix.patch11
-rw-r--r--games-board/gnushogi/gnushogi-1.3.ebuild5
3 files changed, 19 insertions, 3 deletions
diff --git a/games-board/gnushogi/ChangeLog b/games-board/gnushogi/ChangeLog
index 1181951e7c10..8eabfd6da7b0 100644
--- a/games-board/gnushogi/ChangeLog
+++ b/games-board/gnushogi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/gnushogi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/ChangeLog,v 1.16 2010/08/31 20:07:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/ChangeLog,v 1.17 2010/10/27 09:33:04 tupone Exp $
+
+ 27 Oct 2010; Tupone Alfredo <tupone@gentoo.org> gnushogi-1.3.ebuild,
+ +files/gnushogi-1.3-ovflfix.patch:
+ Fix overflow. Bug #340901 by flameeyes@gentoo.org
31 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org> gnushogi-1.3.ebuild:
respect LDFLAGS bug #335444
diff --git a/games-board/gnushogi/files/gnushogi-1.3-ovflfix.patch b/games-board/gnushogi/files/gnushogi-1.3-ovflfix.patch
new file mode 100644
index 000000000000..78ab7759d1bf
--- /dev/null
+++ b/games-board/gnushogi/files/gnushogi-1.3-ovflfix.patch
@@ -0,0 +1,11 @@
+--- gnushogi/commondsp.c.old 2010-10-27 11:26:21.000000000 +0200
++++ gnushogi/commondsp.c 2010-10-27 11:27:59.000000000 +0200
+@@ -1737,7 +1737,7 @@
+ s[0] = sx[0] = '\0';
+
+ while(!sx[0])
+- (void)fgets(sx, 256, stdin);
++ (void)fgets(sx, 80, stdin);
+ }
+ else
+ {
diff --git a/games-board/gnushogi/gnushogi-1.3.ebuild b/games-board/gnushogi/gnushogi-1.3.ebuild
index 567a9aff4390..430a53d42516 100644
--- a/games-board/gnushogi/gnushogi-1.3.ebuild
+++ b/games-board/gnushogi/gnushogi-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/gnushogi-1.3.ebuild,v 1.18 2010/08/31 20:07:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/gnushogi-1.3.ebuild,v 1.19 2010/10/27 09:33:04 tupone Exp $
EAPI=2
inherit eutils games
@@ -32,7 +32,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PV}-errno.patch \
"${FILESDIR}"/${P}-gcc4.patch \
- "${FILESDIR}"/${P}-parallel.patch
+ "${FILESDIR}"/${P}-parallel.patch \
+ "${FILESDIR}"/${P}-ovflfix.patch
# respect LDFLAGS bug #335444
sed -i \
-e '/^LDFLAGS/s/=/+=/' \