summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-01-22 06:35:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-01-22 06:35:46 +0000
commitf9f93cfc1b1444c8c2bb9aab54ff3b940b4ceeb4 (patch)
tree1019bdfdc3838b7521af0b2f371c7ff11aef67c8 /games-board
parentVersion bump (bug #498796). Update to EAPI 5, add subslot version, and fix ha... (diff)
downloadgentoo-2-f9f93cfc1b1444c8c2bb9aab54ff3b940b4ceeb4.tar.gz
gentoo-2-f9f93cfc1b1444c8c2bb9aab54ff3b940b4ceeb4.tar.bz2
gentoo-2-f9f93cfc1b1444c8c2bb9aab54ff3b940b4ceeb4.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/ChangeLog10
-rw-r--r--games-board/pokerth/files/pokerth-1.1.1-underlinking.patch20
-rw-r--r--games-board/pokerth/pokerth-1.1.1.ebuild70
3 files changed, 98 insertions, 2 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index 16f6d4f24b35..330c45d02a10 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/pokerth
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.59 2013/11/07 17:01:02 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.60 2014/01/22 06:35:45 mr_bones_ Exp $
+
+*pokerth-1.1.1 (22 Jan 2014)
+
+ 22 Jan 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/pokerth-1.1.1-underlinking.patch, +pokerth-1.1.1.ebuild:
+ version bump
07 Nov 2013; Julian Ospald <hasufell@gentoo.org> -pokerth-1.0.ebuild,
+pokerth-1.0.1.ebuild:
diff --git a/games-board/pokerth/files/pokerth-1.1.1-underlinking.patch b/games-board/pokerth/files/pokerth-1.1.1-underlinking.patch
new file mode 100644
index 000000000000..397fb7d6c1bc
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-1.1.1-underlinking.patch
@@ -0,0 +1,20 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Aug 16 22:25:12 UTC 2012
+Subject: build system
+
+fix compilation for linkers that don't permit underlinking
+reorder linker line to fix issues with as-needed
+
+--- pokerth_server.pro
++++ pokerth_server.pro
+@@ -114,8 +114,8 @@
+ LIBS += -lpokerth_lib \
+ -lpokerth_db \
+ -lpokerth_protocol \
+- -lcurl \
+- -lircclient
++ -lircclient \
++ $$system(pkg-config --libs --static libcurl)
+
+ win32 {
+ DEFINES += CURL_STATICLIB
diff --git a/games-board/pokerth/pokerth-1.1.1.ebuild b/games-board/pokerth/pokerth-1.1.1.ebuild
new file mode 100644
index 000000000000..fa00087a1049
--- /dev/null
+++ b/games-board/pokerth/pokerth-1.1.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-1.1.1.ebuild,v 1.1 2014/01/22 06:35:45 mr_bones_ Exp $
+
+EAPI=5
+inherit flag-o-matic eutils qt4-r2 games
+
+MY_P="PokerTH-${PV}-src"
+DESCRIPTION="Texas Hold'em poker game"
+HOMEPAGE="http://www.pokerth.net/"
+SRC_URI="mirror://sourceforge/pokerth/${MY_P}.tar.bz2"
+
+LICENSE="AGPL-3 GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/boost[threads(+)]
+ dev-libs/protobuf
+ dev-libs/libgcrypt
+ dev-libs/tinyxml[stl]
+ amd64? ( net-libs/libircclient )
+ ppc? ( >=net-libs/libircclient-1.6-r2 )
+ x86? ( net-libs/libircclient )
+ >=net-misc/curl-7.16
+ dev-qt/qtcore:4
+ virtual/gsasl
+ !dedicated? (
+ media-libs/libsdl:0
+ media-libs/sdl-mixer[mod,vorbis]
+ dev-qt/qtgui:4
+ )"
+DEPEND="${RDEPEND}
+ !dedicated? ( dev-qt/qtsql:4 )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if use dedicated ; then
+ sed -i \
+ -e 's/pokerth_game.pro//' \
+ pokerth.pro || die
+ fi
+
+ sed -i \
+ -e '/no_dead_strip_inits_and_terms/d' \
+ *pro || die
+
+ #epatch "${FILESDIR}"/${P}-underlinking.patch
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ dogamesbin bin/pokerth_server
+ if ! use dedicated ; then
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data
+ domenu ${PN}.desktop
+ doicon ${PN}.png
+ fi
+ doman docs/pokerth.1
+ dodoc ChangeLog TODO docs/{gui_styling,server_setup}_howto.txt
+ prepgamesdirs
+}