summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-04-23 04:33:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-04-23 04:33:17 +0000
commitf27ea24414766797fde33e54d74db7995e4a1638 (patch)
tree71633460652b1aca78702c23c3eb7aea6f70556e /games-board
parentmake metadata.xml match DTD (diff)
downloadgentoo-2-f27ea24414766797fde33e54d74db7995e4a1638.tar.gz
gentoo-2-f27ea24414766797fde33e54d74db7995e4a1638.tar.bz2
gentoo-2-f27ea24414766797fde33e54d74db7995e4a1638.zip
version bump (bug #218922)
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/crafty/ChangeLog7
-rw-r--r--games-board/crafty/crafty-22.1.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index 95648257bf45..3e814616d1a1 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/crafty
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.26 2008/04/11 15:41:11 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.27 2008/04/23 04:33:17 mr_bones_ Exp $
+
+*crafty-22.1 (23 Apr 2008)
+
+ 23 Apr 2008; Michael Sterrett <mr_bones_@gentoo.org> +crafty-22.1.ebuild:
+ version bump (bug #218922)
11 Apr 2008; Chris Gianelloni <wolf31o2@gentoo.org> crafty-20.13.ebuild,
-crafty-21.6-r1.ebuild, crafty-22.0.ebuild:
diff --git a/games-board/crafty/crafty-22.1.ebuild b/games-board/crafty/crafty-22.1.ebuild
new file mode 100644
index 000000000000..8e0bae631740
--- /dev/null
+++ b/games-board/crafty/crafty-22.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-22.1.ebuild,v 1.1 2008/04/23 04:33:17 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="Bob Hyatt's strong chess engine"
+HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
+SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.zip
+ ftp://ftp.cis.uab.edu/pub/hyatt/documentation/${PN}.doc.ascii"
+
+LICENSE="crafty"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="no-opts"
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/-o crafty/s/CC/CXX/' \
+ -e 's:CXFLAGS:CXXFLAGS:g' \
+ Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ local makeopts="target=LINUX"
+
+ if ! use no-opts ; then
+ if [[ $(tc-getCC) = icc ]] ; then
+ makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
+ append-flags -D_REENTRANT -tpp6 \
+ -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
+ -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -O2 -fno-alias -fforce-mem \
+ -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
+ else
+ if [[ "${CHOST}" == "i686-pc-linux-gnu" ]] \
+ || [[ "${CHOST}" == "i586-pc-linux-gnu" ]] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fno-gcse \
+ -fomit-frame-pointer -mpreferred-stack-boundary=2
+ makeopts="${makeopts} CC=gcc CXX=g++"
+ elif [[ "${CHOST}" == "x86_64-pc-linux-gnu" ]] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fomit-frame-pointer
+ makeopts="${makeopts} CC=gcc CXX=g++"
+ else
+ : # everything else :)
+ fi
+ fi
+ fi
+ append-flags -DPOSIX
+ emake ${makeopts} crafty-make LDFLAGS="${LDFLAGS} -lpthread" || die "build failed"
+}
+
+src_install() {
+ dogamesbin crafty || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins crafty.hlp || die "doins failed"
+ dodoc "${DISTDIR}"/crafty.doc.ascii
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog
+ elog "Note: No books or tablebases have been installed. If you want them, just"
+ elog " download them from ${HOMEPAGE}."
+ elog " You will find documentation there too. In most cases you take now "
+ elog " your xboard compatible application, (xboard, eboard, knights) and "
+ elog " just play chess against computer opponent. Have fun."
+ elog
+}