summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-01-19 01:53:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-01-19 01:53:47 +0000
commitf18627d801aac781336d65cb69fce78acdeccd11 (patch)
tree7adc7cac74b71aefbfc2ec5eedfae318236d25d7 /games-board
parentStable for HPPA (bug #147751). (diff)
downloadgentoo-2-f18627d801aac781336d65cb69fce78acdeccd11.tar.gz
gentoo-2-f18627d801aac781336d65cb69fce78acdeccd11.tar.bz2
gentoo-2-f18627d801aac781336d65cb69fce78acdeccd11.zip
version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/jrisk/ChangeLog10
-rw-r--r--games-board/jrisk/files/digest-jrisk-1.0.8.93
-rw-r--r--games-board/jrisk/jrisk-1.0.8.9.ebuild51
3 files changed, 62 insertions, 2 deletions
diff --git a/games-board/jrisk/ChangeLog b/games-board/jrisk/ChangeLog
index e107c2327ad3..a98623f0c56e 100644
--- a/games-board/jrisk/ChangeLog
+++ b/games-board/jrisk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/jrisk
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/jrisk/ChangeLog,v 1.11 2006/10/02 20:55:19 mr_bones_ Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/jrisk/ChangeLog,v 1.12 2007/01/19 01:53:47 mr_bones_ Exp $
+
+*jrisk-1.0.8.9 (19 Jan 2007)
+
+ 19 Jan 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +jrisk-1.0.8.9.ebuild:
+ version bump
*jrisk-1.0.8.8 (02 Oct 2006)
diff --git a/games-board/jrisk/files/digest-jrisk-1.0.8.9 b/games-board/jrisk/files/digest-jrisk-1.0.8.9
new file mode 100644
index 000000000000..9a91b30c7d8c
--- /dev/null
+++ b/games-board/jrisk/files/digest-jrisk-1.0.8.9
@@ -0,0 +1,3 @@
+MD5 f10ff6328cb0de53414f76cba7cdd7bd backup_of_Risk_1.0.8.9.zip 10134145
+RMD160 4d3d7ee8458fc5b18fd3f7c7cd1d4d4a7d32e881 backup_of_Risk_1.0.8.9.zip 10134145
+SHA256 bf12e6d40e30de2d85b64a0828fde7cd01a88e207ad14d097789fdeadb9c31e1 backup_of_Risk_1.0.8.9.zip 10134145
diff --git a/games-board/jrisk/jrisk-1.0.8.9.ebuild b/games-board/jrisk/jrisk-1.0.8.9.ebuild
new file mode 100644
index 000000000000..c892af8ad177
--- /dev/null
+++ b/games-board/jrisk/jrisk-1.0.8.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/jrisk/jrisk-1.0.8.9.ebuild,v 1.1 2007/01/19 01:53:47 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="The well-known board game, written in java"
+HOMEPAGE="http://jrisk.sourceforge.net"
+SRC_URI="mirror://sourceforge/jrisk/backup_of_Risk_${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86 ~x86-fbsd"
+IUSE="jikes"
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ >=dev-java/ant-core-1.4.1
+ jikes? ( >=dev-java/jikes-1.17 )"
+
+S=${WORKDIR}/Risk
+
+src_compile() {
+ local antflags="game"
+
+ if use jikes; then
+ antflags="${antflags} -Dbuild.compiler=jikes"
+ fi
+ ant ${antflags} || die "failed to build"
+ # change the cd directory of the executable
+ # has to be done after the ant compilation
+ sed \
+ -e "/dirname/ s:.*:cd \"${GAMES_DATADIR}/${PN}\":" \
+ "${S}"/build/game/FlashGUI.sh \
+ > "${T}"/jrisk \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin "${T}"/jrisk || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r build/game/* || die "doins failed"
+ rm -f "${D}${GAMES_DATADIR}"/${PN}/*.cmd
+
+ newicon build/game/resources/risk.png ${PN}.png
+ make_desktop_entry ${PN} "Risk"
+
+ prepgamesdirs
+}