summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-05-16 01:06:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-05-16 01:06:38 +0000
commitebf1c9a56e088ab1847d4397dcbf289685e53eb6 (patch)
treed05e41fa743c386bb2bb3b75c03a59c15a00b9aa /games-board
parentFix configuration sed script. (diff)
downloadgentoo-2-ebf1c9a56e088ab1847d4397dcbf289685e53eb6.tar.gz
gentoo-2-ebf1c9a56e088ab1847d4397dcbf289685e53eb6.tar.bz2
gentoo-2-ebf1c9a56e088ab1847d4397dcbf289685e53eb6.zip
EAPI=5; tidy; dirty -lm fix
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/mah-jong/ChangeLog7
-rw-r--r--games-board/mah-jong/mah-jong-1.12.1.ebuild19
2 files changed, 13 insertions, 13 deletions
diff --git a/games-board/mah-jong/ChangeLog b/games-board/mah-jong/ChangeLog
index 6c2ba943ad71..50cf1d322bea 100644
--- a/games-board/mah-jong/ChangeLog
+++ b/games-board/mah-jong/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-board/mah-jong
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/ChangeLog,v 1.22 2013/01/24 19:32:25 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/ChangeLog,v 1.23 2014/05/16 01:06:38 mr_bones_ Exp $
+
+ 16 May 2014; Michael Sterrett <mr_bones_@gentoo.org> mah-jong-1.12.1.ebuild:
+ EAPI=5; tidy; dirty -lm fix
24 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -mah-jong-1.10.ebuild:
old
diff --git a/games-board/mah-jong/mah-jong-1.12.1.ebuild b/games-board/mah-jong/mah-jong-1.12.1.ebuild
index dae49c8d9aad..dbcc047bca7a 100644
--- a/games-board/mah-jong/mah-jong-1.12.1.ebuild
+++ b/games-board/mah-jong/mah-jong-1.12.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.12.1.ebuild,v 1.4 2012/10/17 02:58:23 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.12.1.ebuild,v 1.5 2014/05/16 01:06:38 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils toolchain-funcs games
MY_P="mj-${PV}-src"
@@ -22,9 +22,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
src_prepare() {
- sed -i \
- -e '/^.TH/ s/1/6/' xmj.man \
- || die "sed failed"
+ sed -i -e '/^.TH/ s/1/6/' xmj.man || die
sed -i \
-e "/^DESTDIR =/ s:=.*:= ${D}:" \
-e "/^BINDIR =/ s:=.*:= ${GAMES_BINDIR}:" \
@@ -32,17 +30,16 @@ src_prepare() {
-e '/^MANSUFFIX =/ s:1:6:' \
-e "/^CC =/ s:gcc:$(tc-getCC):" \
-e "/^CFLAGS =/ s:=:= ${CFLAGS}:" \
- -e "/^LDLIBS =/ s:$:${LDFLAGS}:" \
+ -e "/^LDLIBS =/ s:$:${LDFLAGS} -lm:" \
-e '/^INSTPGMFLAGS =/ s:-s::' \
-e '/^CDEBUGFLAGS =/d' \
- -e "/^TILESETPATH=/ s:NULL:\"${GAMES_DATADIR}/${PN}/\":" Makefile \
- || die "sed failed"
+ -e "/^TILESETPATH=/ s:NULL:\"${GAMES_DATADIR}/${PN}/\":" Makefile || die
}
src_install() {
- emake install install.man || die "emake install failed"
+ emake install install.man
insinto "${GAMES_DATADIR}/${PN}"
- doins -r fallbacktiles/ tiles-numbered/ tiles-small/ || die "doins failed"
+ doins -r fallbacktiles/ tiles-numbered/ tiles-small/
newicon tiles-v1/tongE.xpm ${PN}.xpm
make_desktop_entry xmj Mah-Jong ${PN}
dodoc CHANGES ChangeLog *.txt