summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-05-04 05:33:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-05-04 05:33:36 +0000
commitdab016570fbb180abaa835d80b29a8493afae39f (patch)
treec9fc4c1ce5bf5bc72744f6a86a7a005f672bbb7a /games-board
parentForce python2 fixing bug #312231 (diff)
downloadgentoo-2-dab016570fbb180abaa835d80b29a8493afae39f.tar.gz
gentoo-2-dab016570fbb180abaa835d80b29a8493afae39f.tar.bz2
gentoo-2-dab016570fbb180abaa835d80b29a8493afae39f.zip
Allow newer boost and steal boost-related code from wesnoth ebuild
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/ChangeLog5
-rw-r--r--games-board/pokerth/pokerth-0.7.1.ebuild15
2 files changed, 15 insertions, 5 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index 21690ee14fb8..5b0eaa380ca8 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-board/pokerth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.11 2010/04/02 15:43:56 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.12 2010/05/04 05:33:36 mr_bones_ Exp $
+
+ 04 May 2010; Michael Sterrett <mr_bones_@gentoo.org> pokerth-0.7.1.ebuild:
+ Allow newer boost and steal boost-related code from wesnoth ebuild
02 Apr 2010; Markus Meier <maekke@gentoo.org> pokerth-0.7.1.ebuild:
amd64 stable
diff --git a/games-board/pokerth/pokerth-0.7.1.ebuild b/games-board/pokerth/pokerth-0.7.1.ebuild
index adac4852bf3f..a5c4bec3982c 100644
--- a/games-board/pokerth/pokerth-0.7.1.ebuild
+++ b/games-board/pokerth/pokerth-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.7.1.ebuild,v 1.5 2010/04/02 15:43:56 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.7.1.ebuild,v 1.6 2010/05/04 05:33:36 mr_bones_ Exp $
EAPI=2
inherit multilib flag-o-matic eutils qt4 games
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="dedicated"
-DEPEND="|| ( dev-libs/boost:1.41 dev-libs/boost:1.39 )
+DEPEND=">=dev-libs/boost-1.39
>=net-libs/gnutls-2.2.2
>=net-misc/curl-7.16
x11-libs/qt-core:4
@@ -41,12 +41,19 @@ src_prepare() {
-e '/no_dead_strip_inits_and_terms/d' \
*pro \
|| die 'sed failed'
- has_version dev-libs/boost:1.39 && boost_ver=1_39
- has_version dev-libs/boost:1.41 && boost_ver=1_41
+ local boost_ver=$(best_version ">=dev-libs/boost-1.39")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
append-cxxflags \
-I/usr/include/boost-${boost_ver}
append-ldflags \
-L/usr/$(get_libdir)/boost-${boost_ver}
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
}
src_configure() {