summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-07-21 03:00:04 +0000
committerDon Seiler <rizzo@gentoo.org>2005-07-21 03:00:04 +0000
commit9a67f44f76962da6efe27be5d96296fc374dbdcf (patch)
tree338a8aedb4041699f7a797e564e5acbc7985ce92 /games-board
parentMarked ppc stable for bug #96782. (diff)
downloadgentoo-2-9a67f44f76962da6efe27be5d96296fc374dbdcf.tar.gz
gentoo-2-9a67f44f76962da6efe27be5d96296fc374dbdcf.tar.bz2
gentoo-2-9a67f44f76962da6efe27be5d96296fc374dbdcf.zip
Initial addition. This package is the re-incarnation of gnocatan.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pio/ChangeLog10
-rw-r--r--games-board/pio/Manifest3
-rw-r--r--games-board/pio/files/digest-pio-0.9.191
-rw-r--r--games-board/pio/metadata.xml11
-rw-r--r--games-board/pio/pio-0.9.19.ebuild50
5 files changed, 75 insertions, 0 deletions
diff --git a/games-board/pio/ChangeLog b/games-board/pio/ChangeLog
new file mode 100644
index 000000000000..2aef49c219d2
--- /dev/null
+++ b/games-board/pio/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-board/pio
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pio/ChangeLog,v 1.1 2005/07/21 03:00:04 rizzo Exp $
+
+*pio-0.9.19 (21 Jul 2005)
+
+ 21 Jul 2005; Don Seiler <rizzo@gentoo.org> +metadata.xml,
+ +pio-0.9.19.ebuild:
+ Initial addition. This package is the re-incarnation of gnocatan.
+
diff --git a/games-board/pio/Manifest b/games-board/pio/Manifest
new file mode 100644
index 000000000000..ff2158454231
--- /dev/null
+++ b/games-board/pio/Manifest
@@ -0,0 +1,3 @@
+MD5 a465af903d255faba337334fbc2f1a15 pio-0.9.19.ebuild 1122
+MD5 7035b4db1ed5ed0e55ee3dd6524e5b2b metadata.xml 321
+MD5 a270a5b020f0b2c049fe47b0396bafd9 files/digest-pio-0.9.19 68
diff --git a/games-board/pio/files/digest-pio-0.9.19 b/games-board/pio/files/digest-pio-0.9.19
new file mode 100644
index 000000000000..ce7fd834d30a
--- /dev/null
+++ b/games-board/pio/files/digest-pio-0.9.19
@@ -0,0 +1 @@
+MD5 949a138cd9660b1308f4a701d315d5d6 pioneers-0.9.19.tar.gz 2073049
diff --git a/games-board/pio/metadata.xml b/games-board/pio/metadata.xml
new file mode 100644
index 000000000000..9c6a4d70c04f
--- /dev/null
+++ b/games-board/pio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>rizzo@gentoo.org</email>
+</maintainer>
+<longdescription>
+Pio (Pioneers) is a clone of the board game The Settlers of Catan.
+</longdescription>
+</pkgmetadata>
diff --git a/games-board/pio/pio-0.9.19.ebuild b/games-board/pio/pio-0.9.19.ebuild
new file mode 100644
index 000000000000..72c4a5cd21b9
--- /dev/null
+++ b/games-board/pio/pio-0.9.19.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pio/pio-0.9.19.ebuild,v 1.1 2005/07/21 03:00:04 rizzo Exp $
+
+inherit eutils gnome2 debug
+
+MY_P="pioneers-${PV}"
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://pio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pio/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="nls debug X"
+
+RDEPEND=">=dev-libs/glib-2.0
+ X? ( >=gnome-base/libgnomeui-2.6.1.1
+ >=app-text/scrollkeeper-0.3 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ export G2CONF="${G2CONF} `use_enable nls`"
+ export G2CONF="${G2CONF} `use_enable debug`"
+
+ if use X ; then
+ gnome2_src_compile
+ else
+ einfo
+ einfo "Only building console server"
+ einfo
+
+ econf ${G2CONF} || die "./configure failure"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README TODO NEWS"
+ if use X ; then
+ gnome2_src_install
+ else
+ make DESTDIR=${D} install
+ dodoc ${DOCS}
+ fi
+}