summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-10-01 21:20:10 +0000
committerDon Seiler <rizzo@gentoo.org>2004-10-01 21:20:10 +0000
commit88e007d0081f027232674c29caab66a8413318c7 (patch)
tree8b7957f3b4f92a3a2ab2df2b03750ee9697a9a77 /games-board
parentVersion bump, closes #65381. (Manifest recommit) (diff)
downloadgentoo-2-88e007d0081f027232674c29caab66a8413318c7.tar.gz
gentoo-2-88e007d0081f027232674c29caab66a8413318c7.tar.bz2
gentoo-2-88e007d0081f027232674c29caab66a8413318c7.zip
Version bump, now allows for console-server-only builds. Closes Bug #59935
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnocatan/ChangeLog7
-rw-r--r--games-board/gnocatan/Manifest4
-rw-r--r--games-board/gnocatan/files/digest-gnocatan-0.8.1.371
-rw-r--r--games-board/gnocatan/gnocatan-0.8.1.37.ebuild45
4 files changed, 55 insertions, 2 deletions
diff --git a/games-board/gnocatan/ChangeLog b/games-board/gnocatan/ChangeLog
index 9ffa751b47d7..e250faa274fd 100644
--- a/games-board/gnocatan/ChangeLog
+++ b/games-board/gnocatan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/gnocatan
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/ChangeLog,v 1.17 2004/09/27 01:10:07 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/ChangeLog,v 1.18 2004/10/01 21:20:10 rizzo Exp $
+
+*gnocatan-0.8.1.37 (01 Oct 2004)
+
+ 01 Oct 2004; Don Seiler <rizzo@gentoo.org> +gnocatan-0.8.1.37.ebuild:
+ Version bump, now allows for console-server-only builds. Closes Bug #59935
*gnocatan-0.8.1.36 (26 Sep 2004)
diff --git a/games-board/gnocatan/Manifest b/games-board/gnocatan/Manifest
index 5da8c85c3d53..eda5df8dd6e1 100644
--- a/games-board/gnocatan/Manifest
+++ b/games-board/gnocatan/Manifest
@@ -1,6 +1,8 @@
MD5 eec97551613efa0cbfad91b65ffe614a ChangeLog 3383
+MD5 992e2e8efe5d2c40ec47b9039059ac67 gnocatan-0.8.1.37.ebuild 1193
MD5 cfd29f58e6f9fb057c83c8eb26c1a101 metadata.xml 315
-MD5 e6b59733bfbfab6b72e0d87d486261f8 gnocatan-0.8.1.36.ebuild 796
MD5 a56a7859d968f27bdc5eeadddd5868d2 gnocatan-0.8.1.34.ebuild 810
+MD5 e6b59733bfbfab6b72e0d87d486261f8 gnocatan-0.8.1.36.ebuild 796
MD5 010dc25ad3ed3f9e0ec6c21e5e0db450 files/digest-gnocatan-0.8.1.34 70
MD5 ec79cf5aad9383a08f198502cb1a61d5 files/digest-gnocatan-0.8.1.36 70
+MD5 d8ee072ea1a133e6f7e2192ecbf1e956 files/digest-gnocatan-0.8.1.37 70
diff --git a/games-board/gnocatan/files/digest-gnocatan-0.8.1.37 b/games-board/gnocatan/files/digest-gnocatan-0.8.1.37
new file mode 100644
index 000000000000..8b3f191d7494
--- /dev/null
+++ b/games-board/gnocatan/files/digest-gnocatan-0.8.1.37
@@ -0,0 +1 @@
+MD5 f8bc3c47e88b091c279c595666d04cda gnocatan-0.8.1.37.tar.gz 2046059
diff --git a/games-board/gnocatan/gnocatan-0.8.1.37.ebuild b/games-board/gnocatan/gnocatan-0.8.1.37.ebuild
new file mode 100644
index 000000000000..7fd6d41b6792
--- /dev/null
+++ b/games-board/gnocatan/gnocatan-0.8.1.37.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/gnocatan-0.8.1.37.ebuild,v 1.1 2004/10/01 21:20:10 rizzo Exp $
+
+inherit eutils gnome2 debug
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://gnocatan.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnocatan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="nls debug X"
+
+RDEPEND="dev-libs/glib
+ dev-util/pkgconfig
+ X? ( >=gnome-base/libgnomeui-2.6.1.1
+ >=app-text/scrollkeeper-0.3* )"
+
+src_compile() {
+ export G2CONF="${G2CONF} `use_enable nls`"
+ export G2CONF="${G2CONF} `use_enable debug`"
+
+ if use X ; then
+ gnome2_src_compile
+ else
+ einfo
+ einfo "Only building console server"
+ einfo
+
+ econf ${G2CONF} || die "./configure failure"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README COPYING INSTALL TODO NEWS"
+ if use X ; then
+ gnome2_src_install
+ else
+ make DESTDIR=${D} install
+ dodoc ${DOCS}
+ fi
+}