summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-11-19 21:43:50 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-11-19 21:43:50 +0000
commit7f8453d4fcdf32758526277a58f6a89c933e612a (patch)
tree4dabf2365f5a05739f10b508d21698f08ed4b68f /games-board
parentVersion bump. (diff)
downloadgentoo-2-7f8453d4fcdf32758526277a58f6a89c933e612a.tar.gz
gentoo-2-7f8453d4fcdf32758526277a58f6a89c933e612a.tar.bz2
gentoo-2-7f8453d4fcdf32758526277a58f6a89c933e612a.zip
Use wxwidgets eclass and install desktop entry
(Portage version: 2.1.2_rc2)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/blokish/ChangeLog5
-rw-r--r--games-board/blokish/blokish-0.9.3.ebuild15
2 files changed, 16 insertions, 4 deletions
diff --git a/games-board/blokish/ChangeLog b/games-board/blokish/ChangeLog
index 5a476b466639..52c271acdbff 100644
--- a/games-board/blokish/ChangeLog
+++ b/games-board/blokish/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-board/blokish
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/ChangeLog,v 1.2 2006/11/05 18:46:43 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/ChangeLog,v 1.3 2006/11/19 21:43:50 nyhm Exp $
+
+ 19 Nov 2006; Tristan Heaven <nyhm@gentoo.org> blokish-0.9.3.ebuild:
+ Use wxwidgets eclass and install desktop entry
05 Nov 2006; Piotr Jaroszyński <peper@gentoo.org> blokish-0.9.3.ebuild:
Add ~amd64 wrt bug #154033.
diff --git a/games-board/blokish/blokish-0.9.3.ebuild b/games-board/blokish/blokish-0.9.3.ebuild
index c6670d1873a5..36cab20e7657 100644
--- a/games-board/blokish/blokish-0.9.3.ebuild
+++ b/games-board/blokish/blokish-0.9.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/blokish-0.9.3.ebuild,v 1.2 2006/11/05 18:46:43 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/blokish-0.9.3.ebuild,v 1.3 2006/11/19 21:43:50 nyhm Exp $
-inherit eutils games
+inherit eutils wxwidgets games
MY_P="${PN}_src_v${PV}"
DESCRIPTION="Open source clone of the four-player board game Blokus"
@@ -19,18 +19,27 @@ DEPEND="=x11-libs/wxGTK-2.6*
S=${WORKDIR}/${PN}
+pkg_setup() {
+ WX_GTK_VER=2.6 need-wxwidgets unicode
+ games_pkg_setup
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
sed -i \
- -e "s:wx-config:wx-config-2.6:" \
+ -e "s:wx-config:${WX_CONFIG}:" \
configure makefile.in \
|| die "sed failed"
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon src/${PN}.xpm
+ make_desktop_entry ${PN} Blokish ${PN}.xpm
+
dodoc AUTHORS ChangeLog README
dohtml docs/*
prepgamesdirs