summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-06-12 20:03:25 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-06-12 20:03:25 +0000
commit7d63fe76e3a70de4f9db73810b1995a39ce21d7b (patch)
treea1dc263edd5eaaea0e339621612e647188edd3ed /games-board
parentVersion bump. (diff)
downloadgentoo-2-7d63fe76e3a70de4f9db73810b1995a39ce21d7b.tar.gz
gentoo-2-7d63fe76e3a70de4f9db73810b1995a39ce21d7b.tar.bz2
gentoo-2-7d63fe76e3a70de4f9db73810b1995a39ce21d7b.zip
add dedicated USE flag wrt #513060
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pioneers/ChangeLog7
-rw-r--r--games-board/pioneers/pioneers-15.1-r1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/games-board/pioneers/ChangeLog b/games-board/pioneers/ChangeLog
index bc405c5b67da..fbeca01255a4 100644
--- a/games-board/pioneers/ChangeLog
+++ b/games-board/pioneers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/pioneers
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/ChangeLog,v 1.34 2014/04/08 10:03:26 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/ChangeLog,v 1.35 2014/06/12 20:03:25 hasufell Exp $
+
+*pioneers-15.1-r1 (12 Jun 2014)
+
+ 12 Jun 2014; Julian Ospald <hasufell@gentoo.org> +pioneers-15.1-r1.ebuild:
+ add dedicated USE flag wrt #513060
08 Apr 2014; Chema Alonso <nimiux@gentoo.org> pioneers-15.1.ebuild:
Stable for amd64 wrt bug #505208
diff --git a/games-board/pioneers/pioneers-15.1-r1.ebuild b/games-board/pioneers/pioneers-15.1-r1.ebuild
new file mode 100644
index 000000000000..ab969f7492c4
--- /dev/null
+++ b/games-board/pioneers/pioneers-15.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/pioneers-15.1-r1.ebuild,v 1.1 2014/06/12 20:03:25 hasufell Exp $
+
+# NOTE: "QA Notice: Unrecognized configure options --with-gtk" is a false-positive
+
+EAPI=5
+inherit autotools eutils gnome-games
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://pio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pio/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated help nls"
+
+# dev-util/gob only for autoreconf
+RDEPEND=">=dev-libs/glib-2.6:2
+ !dedicated? (
+ >=x11-libs/gtk+-2.6:2
+ x11-libs/libnotify
+ help? (
+ >=app-text/scrollkeeper-0.3.8
+ >=gnome-base/libgnome-2.10
+ )
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/gob:2
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome-games_src_configure \
+ $(use_enable nls) \
+ --enable-minimal-flags \
+ $(use_with help) \
+ --includedir=/usr/include \
+ $(use_with !dedicated gtk)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README TODO NEWS" \
+ gnome2_src_install scrollkeeper_localstate_dir="${ED%/}"/var/lib/scrollkeeper/
+ prepgamesdirs
+}