summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-04-21 16:30:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-04-21 16:30:32 +0000
commit7c3aaf9fb193715613e49d12b06b190fceb25052 (patch)
tree8d52b3bde2a91684eecdee5da5a94261943b5afb /games-board
parentapp-admin/testdisk: Add qt4 USE flag to build GUI. (diff)
downloadgentoo-2-7c3aaf9fb193715613e49d12b06b190fceb25052.tar.gz
gentoo-2-7c3aaf9fb193715613e49d12b06b190fceb25052.tar.bz2
gentoo-2-7c3aaf9fb193715613e49d12b06b190fceb25052.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/chessx/ChangeLog8
-rw-r--r--games-board/chessx/chessx-1.3.0.ebuild41
-rw-r--r--games-board/chessx/files/chessx-1.3.0-zlib.patch35
3 files changed, 83 insertions, 1 deletions
diff --git a/games-board/chessx/ChangeLog b/games-board/chessx/ChangeLog
index 36df6ccacb37..0d4cd55a5dbe 100644
--- a/games-board/chessx/ChangeLog
+++ b/games-board/chessx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/chessx
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/chessx/ChangeLog,v 1.1 2015/04/13 20:53:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/chessx/ChangeLog,v 1.2 2015/04/21 16:30:32 mr_bones_ Exp $
+
+*chessx-1.3.0 (21 Apr 2015)
+
+ 21 Apr 2015; Michael Sterrett <mr_bones_@gentoo.org> +chessx-1.3.0.ebuild,
+ +files/chessx-1.3.0-zlib.patch:
+ version bump
*chessx-1.2.2 (13 Apr 2015)
diff --git a/games-board/chessx/chessx-1.3.0.ebuild b/games-board/chessx/chessx-1.3.0.ebuild
new file mode 100644
index 000000000000..9153572bd63a
--- /dev/null
+++ b/games-board/chessx/chessx-1.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/chessx/chessx-1.3.0.ebuild,v 1.1 2015/04/21 16:30:32 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils qmake-utils games
+
+DESCRIPTION="Qt5-based Chess Database Utility"
+HOMEPAGE="http://chessx.sourceforge.net/"
+SRC_URI="http://sourceforge.net/projects/chessx/files/chessx/${PV}/${P}.tgz"
+
+LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+ ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtxml:5
+ sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-zlib.patch
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dogamesbin release/${PN}
+ dodoc ChangeLog TODO
+ doicon data/images/${PN}.png
+ domenu unix/chessx.desktop
+ prepgamesdirs
+}
diff --git a/games-board/chessx/files/chessx-1.3.0-zlib.patch b/games-board/chessx/files/chessx-1.3.0-zlib.patch
new file mode 100644
index 000000000000..36d685d9cba9
--- /dev/null
+++ b/games-board/chessx/files/chessx-1.3.0-zlib.patch
@@ -0,0 +1,35 @@
+--- chessx-1.2.2/src/quazip/ioapi.h
++++ chessx-1.2.2-patched/src/quazip/ioapi.h
+@@ -1,3 +1,4 @@
++#define OF(x) x
+ /* ioapi.h -- IO base function header for compress/uncompress .zip
+ files using zlib + zip or unzip API
+
+--- chessx-1.2.2/src/quazip/unzip.c
++++ chessx-1.2.2-patched/src/quazip/unzip.c
+@@ -1,3 +1,4 @@
++#define OF(x) x
+ /* unzip.c -- IO for uncompress .zip files using zlib
+ Version 1.01e, February 12th, 2005
+
+--- chessx-1.2.2/src/quazip/unzip.h
++++ chessx-1.2.2-patched/src/quazip/unzip.h
+@@ -1,3 +1,4 @@
++#define OF(x) x
+ /* unzip.h -- IO for uncompress .zip files using zlib
+ Version 1.01e, February 12th, 2005
+
+--- chessx-1.2.2/src/quazip/zip.c
++++ chessx-1.2.2-patched/src/quazip/zip.c
+@@ -1,3 +1,4 @@
++#define OF(x) x
+ /* zip.c -- IO on .zip files using zlib
+ Version 1.01e, February 12th, 2005
+
+--- chessx-1.2.2/src/quazip/zip.h
++++ chessx-1.2.2-patched/src/quazip/zip.h
+@@ -1,3 +1,4 @@
++#define OF(x) x
+ /* zip.h -- IO for compress .zip files using zlib
+ Version 1.01e, February 12th, 2005
+