summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2012-07-07 23:10:25 +0000
committerTristan Heaven <tristan@gentoo.org>2012-07-07 23:10:25 +0000
commit77faa3ff2a901618a0ce13a18ccbf7001a560baf (patch)
tree5741f2752b3ac206b50bb087fa61572f497a0d05 /games-board
parentAdd additional fix for bug 424231. (diff)
downloadgentoo-2-77faa3ff2a901618a0ce13a18ccbf7001a560baf.tar.gz
gentoo-2-77faa3ff2a901618a0ce13a18ccbf7001a560baf.tar.bz2
gentoo-2-77faa3ff2a901618a0ce13a18ccbf7001a560baf.zip
Patch to fix building with gcc-4.7 from Daniel Johnson, bug #423465
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/hexxagon/ChangeLog6
-rw-r--r--games-board/hexxagon/files/hexxagon-1.0.1-gcc47.patch43
-rw-r--r--games-board/hexxagon/hexxagon-1.0.1.ebuild10
3 files changed, 54 insertions, 5 deletions
diff --git a/games-board/hexxagon/ChangeLog b/games-board/hexxagon/ChangeLog
index 47de8aca7bb5..b4da9c8bc81f 100644
--- a/games-board/hexxagon/ChangeLog
+++ b/games-board/hexxagon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/hexxagon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/ChangeLog,v 1.32 2012/05/04 04:30:09 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/ChangeLog,v 1.33 2012/07/07 23:10:25 tristan Exp $
+
+ 07 Jul 2012; Tristan Heaven <tristan@gentoo.org> hexxagon-1.0.1.ebuild,
+ +files/hexxagon-1.0.1-gcc47.patch:
+ Patch to fix building with gcc-4.7 from Daniel Johnson, bug #423465
04 May 2012; Jeff Horelick <jdhore@gentoo.org> hexxagon-1.0.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/games-board/hexxagon/files/hexxagon-1.0.1-gcc47.patch b/games-board/hexxagon/files/hexxagon-1.0.1-gcc47.patch
new file mode 100644
index 000000000000..c3836cc5d5b2
--- /dev/null
+++ b/games-board/hexxagon/files/hexxagon-1.0.1-gcc47.patch
@@ -0,0 +1,43 @@
+--- src/gui/gtkhexxagonboard.cpp
++++ src/gui/gtkhexxagonboard.cpp
+@@ -120,8 +120,8 @@
+ posx += width * offset / 2;
+ posy += height * offset / 2;
+
+- int x = (int) round(posx) + xoff;
+- int y = (int) round(posy) + yoff;
++ int displayx = (int) round(posx) + xoff;
++ int displayy = (int) round(posy) + yoff;
+
+ int type;
+ LookUp lookup(bbMask);
+@@ -155,10 +155,10 @@
+
+ Glib::RefPtr<Gdk::GC> gc = Gdk::GC::create(back);
+ gc->set_clip_mask(mask[type]);
+- gc->set_clip_origin(x, y);
++ gc->set_clip_origin(displayx, displayy);
+
+ if(back && map_board[type])
+- back->draw_drawable(gc, map_board[type], 0, 0, x, y, -1, -1);
++ back->draw_drawable(gc, map_board[type], 0, 0, displayx, displayy, -1, -1);
+
+ cellNo++;
+ }
+@@ -205,12 +205,12 @@
+ posx += width * offset / 2;
+ posy += height * offset / 2;
+
+- int x = (int) round(posx + w / 2) + xoff;
+- int y = (int) round(posy + h / 2) + yoff;
++ int displayx = (int) round(posx + w / 2) + xoff;
++ int displayy = (int) round(posy + h / 2) + yoff;
+
+ // Now we got the place for cell cellNo
+- double dx = inx - x;
+- double dy = iny - y;
++ double dx = inx - displayx;
++ double dy = iny - displayy;
+ double a = (w/2)*(w/2);
+ double b = (h/2)*(h/2);
+
diff --git a/games-board/hexxagon/hexxagon-1.0.1.ebuild b/games-board/hexxagon/hexxagon-1.0.1.ebuild
index 07d42cccfa10..8649abfd00cf 100644
--- a/games-board/hexxagon/hexxagon-1.0.1.ebuild
+++ b/games-board/hexxagon/hexxagon-1.0.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/hexxagon-1.0.1.ebuild,v 1.7 2012/05/04 04:30:09 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/hexxagon-1.0.1.ebuild,v 1.8 2012/07/07 23:10:25 tristan Exp $
EAPI=2
inherit eutils games
-DESCRIPTION="clone of the original DOS game"
+DESCRIPTION="Clone of the original DOS game"
HOMEPAGE="http://www.nesqi.se/"
SRC_URI="http://www.nesqi.se/download/${P}.tar.bz2"
@@ -14,12 +14,14 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-RDEPEND=">=dev-cpp/glibmm-2.4:2
- >=dev-cpp/gtkmm-2.4:2.4
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
x11-libs/gtk+:2"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/${P}-gcc47.patch )
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
newicon images/board_N_2.xpm ${PN}.xpm