summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-21 10:33:28 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-21 10:33:28 +0000
commit6b65ba3a7f44924958dfb0cadb7b62e35fa88af5 (patch)
tree962c7c956ca403561b53805baca7bd479623907d /games-board
parentStable for amd64, wrt bug #438750 (diff)
downloadgentoo-2-6b65ba3a7f44924958dfb0cadb7b62e35fa88af5.tar.gz
gentoo-2-6b65ba3a7f44924958dfb0cadb7b62e35fa88af5.tar.bz2
gentoo-2-6b65ba3a7f44924958dfb0cadb7b62e35fa88af5.zip
Let it compile with glib-2.32, bug #438418 by Flameeyes.
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnono/ChangeLog8
-rw-r--r--games-board/gnono/files/gnono-1.9.1-glib-single-include.patch151
-rw-r--r--games-board/gnono/gnono-1.9.1.ebuild10
3 files changed, 162 insertions, 7 deletions
diff --git a/games-board/gnono/ChangeLog b/games-board/gnono/ChangeLog
index 87184f3dc7ba..62770dbeadc8 100644
--- a/games-board/gnono/ChangeLog
+++ b/games-board/gnono/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/gnono
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnono/ChangeLog,v 1.14 2009/11/23 14:32:31 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnono/ChangeLog,v 1.15 2012/10/21 10:33:28 pacho Exp $
+
+ 21 Oct 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/gnono-1.9.1-glib-single-include.patch, gnono-1.9.1.ebuild:
+ Let it compile with glib-2.32, bug #438418 by Flameeyes.
23 Nov 2009; Markus Meier <maekke@gentoo.org> gnono-1.9.1.ebuild:
amd64/x86 stable, bug #294145
diff --git a/games-board/gnono/files/gnono-1.9.1-glib-single-include.patch b/games-board/gnono/files/gnono-1.9.1-glib-single-include.patch
new file mode 100644
index 000000000000..edf5238c1475
--- /dev/null
+++ b/games-board/gnono/files/gnono-1.9.1-glib-single-include.patch
@@ -0,0 +1,151 @@
+Index: gnono-1.9.1/src/ai.c
+===================================================================
+--- gnono-1.9.1.orig/src/ai.c
++++ gnono-1.9.1/src/ai.c
+@@ -24,9 +24,7 @@
+ #include <config.h>
+ #endif
+
+-#include <glib/garray.h>
+-#include <glib/gmessages.h>
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ #include "cards.h"
+ #include "game.h"
+Index: gnono-1.9.1/src/ai.h
+===================================================================
+--- gnono-1.9.1.orig/src/ai.h
++++ gnono-1.9.1/src/ai.h
+@@ -23,7 +23,7 @@
+ #ifndef __GN_AI_H__
+ #define __GN_AI_H__
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ void computer_play (gboolean pickup);
+
+Index: gnono-1.9.1/src/cards.c
+===================================================================
+--- gnono-1.9.1.orig/src/cards.c
++++ gnono-1.9.1/src/cards.c
+@@ -25,9 +25,7 @@
+ #endif
+
+ #include <stdlib.h> /* for rand() */
+-#include <glib/garray.h>
+-#include <glib/gmem.h>
+-#include <glib/gtypes.h>
++#include <glib.h>
+ #include <gdk-pixbuf/gdk-pixbuf-core.h>
+
+ #include "cards.h"
+Index: gnono-1.9.1/src/cards.h
+===================================================================
+--- gnono-1.9.1.orig/src/cards.h
++++ gnono-1.9.1/src/cards.h
+@@ -23,7 +23,7 @@
+ #ifndef __GN_CARDS_H__
+ #define __GN_CARDS_H__
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+ #include <gdk-pixbuf/gdk-pixbuf-core.h>
+
+ static const gdouble GN_CARD_HEIGHT = 98.0;
+Index: gnono-1.9.1/src/game.c
+===================================================================
+--- gnono-1.9.1.orig/src/game.c
++++ gnono-1.9.1/src/game.c
+@@ -24,9 +24,7 @@
+ #include <config.h>
+ #endif
+
+-#include <glib/garray.h>
+-#include <glib/gmessages.h>
+-#include <glib/gtypes.h>
++#include <glib.h>
+ #include <gtk/gtkmain.h>
+ #include <libgnome/gnome-config.h>
+
+Index: gnono-1.9.1/src/game.h
+===================================================================
+--- gnono-1.9.1.orig/src/game.h
++++ gnono-1.9.1/src/game.h
+@@ -23,7 +23,7 @@
+ #ifndef __GN_GAME_H__
+ #define __GN_GAME_H__
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ /*#define GN_DEBUG*/
+
+Index: gnono-1.9.1/src/interface.h
+===================================================================
+--- gnono-1.9.1.orig/src/interface.h
++++ gnono-1.9.1/src/interface.h
+@@ -23,7 +23,7 @@
+ #ifndef __GN_INTERFACE_H__
+ #define __GN_INTERFACE_H__
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+ #include <gtk/gtkwidget.h>
+ #include <gtk/gtkwindow.h>
+
+Index: gnono-1.9.1/src/main.c
+===================================================================
+--- gnono-1.9.1.orig/src/main.c
++++ gnono-1.9.1/src/main.c
+@@ -26,7 +26,7 @@
+
+ #include <unistd.h>
+ #include <glib/gi18n.h>
+-#include <glib/gmain.h>
++#include <glib.h>
+ #include <gtk/gtkmain.h>
+
+ #include "interface.h"
+Index: gnono-1.9.1/src/players.c
+===================================================================
+--- gnono-1.9.1.orig/src/players.c
++++ gnono-1.9.1/src/players.c
+@@ -24,8 +24,7 @@
+ #include <config.h>
+ #endif
+
+-#include <glib/garray.h>
+-#include <glib/gtypes.h>
++#include <glib.h>
+ #include <glib/gi18n.h>
+ #include <gtk/gtklabel.h>
+ #include <gtk/gtkwidget.h>
+Index: gnono-1.9.1/src/players.h
+===================================================================
+--- gnono-1.9.1.orig/src/players.h
++++ gnono-1.9.1/src/players.h
+@@ -23,8 +23,7 @@
+ #ifndef __GN_PLAYERS_H__
+ #define __GN_PLAYERS_H__
+
+-#include <glib/garray.h>
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ #include "cards.h"
+
+Index: gnono-1.9.1/src/preferences.h
+===================================================================
+--- gnono-1.9.1.orig/src/preferences.h
++++ gnono-1.9.1/src/preferences.h
+@@ -23,7 +23,7 @@
+ #ifndef __GN_PREFERENCES_H__
+ #define __GN_PREFERENCES_H__
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+ #include <gtk/gtkwidget.h>
+
+ void dlg_preferences (GtkWidget *caller, gpointer data);
diff --git a/games-board/gnono/gnono-1.9.1.ebuild b/games-board/gnono/gnono-1.9.1.ebuild
index 76aa948f5af8..475fd159b478 100644
--- a/games-board/gnono/gnono-1.9.1.ebuild
+++ b/games-board/gnono/gnono-1.9.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnono/gnono-1.9.1.ebuild,v 1.5 2009/11/23 14:32:31 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnono/gnono-1.9.1.ebuild,v 1.6 2012/10/21 10:33:28 pacho Exp $
-EAPI=2
+EAPI=4
inherit autotools eutils gnome2-utils games
DESCRIPTION="A rewrite for GNOME of the Windows card game WUNO"
@@ -21,12 +21,12 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-glib-single-include.patch
eautoreconf
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
+ default
prepgamesdirs
}