summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-06-02 22:25:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-06-02 22:25:54 +0000
commit5c80112c09c242c8c04d411aba07cce761bf191f (patch)
treeca8edbad6586fb5c8c5349164afc37681b487811 /games-board
parentConsolidate the code for cleaning out old profiles. (diff)
downloadgentoo-2-5c80112c09c242c8c04d411aba07cce761bf191f.tar.gz
gentoo-2-5c80112c09c242c8c04d411aba07cce761bf191f.tar.bz2
gentoo-2-5c80112c09c242c8c04d411aba07cce761bf191f.zip
version bump (bug #135224)
(Portage version: 2.1_rc3-r4)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/crafty/ChangeLog9
-rw-r--r--games-board/crafty/crafty-20.11.ebuild77
-rw-r--r--games-board/crafty/files/digest-crafty-20.113
3 files changed, 87 insertions, 2 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index 672f437eef1c..562708d9c42c 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/crafty
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.16 2005/09/26 17:43:45 wolf31o2 Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.17 2006/06/02 22:25:54 mr_bones_ Exp $
+
+*crafty-20.11 (02 Jun 2006)
+
+ 02 Jun 2006; Michael Sterrett <mr_bones_@gentoo.org> +crafty-20.11.ebuild:
+ version bump (bug #135224)
26 Sep 2005; Chris Gianelloni <wolf31o2@gentoo.org> crafty-19.8.ebuild:
Making games last on inherit line.
diff --git a/games-board/crafty/crafty-20.11.ebuild b/games-board/crafty/crafty-20.11.ebuild
new file mode 100644
index 000000000000..8d85c8beaf07
--- /dev/null
+++ b/games-board/crafty/crafty-20.11.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-20.11.ebuild,v 1.1 2006/06/02 22:25:54 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="Bob Hyatt's strong chess engine"
+HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
+SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/src/${P}.zip"
+
+LICENSE="crafty"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="icc no-opts"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ icc? ( >=dev-lang/icc-5.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/-o crafty/s/CC/CXX/' Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ local makeopts="target=LINUX"
+
+ if ! use no-opts ; then
+ if use icc ; then
+ makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
+ append-flags -D_REENTRANT -tpp6 \
+ -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
+ -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -O2 -fno-alias -fforce-mem \
+ -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
+ else
+ if [ "${CHOST}" == "i686-pc-linux-gnu" ] || [ "${CHOST}" == "i586-pc-linux-gnu" ] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fforce-mem -fno-gcse \
+ -fomit-frame-pointer -mpreferred-stack-boundary=2
+ makeopts="${makeopts} CC=gcc CXX=g++ asm=X86.o"
+ else
+ : # everything else :)
+ fi
+ fi
+ fi
+ append-flags -DPOSIX
+ emake ${makeopts} crafty-make LDFLAGS="-lpthread" || die "build failed"
+}
+
+src_install() {
+ dogamesbin crafty || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins crafty.hlp || die "doins failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo
+ einfo "Note: No books or tablebases have been installed. If you want them, just"
+ einfo " download them from ${HOMEPAGE}."
+ einfo " You will find documentation there too. In most cases you take now "
+ einfo " your xboard compatible application, (xboard, eboard, knights) and "
+ einfo " just play chess against computer opponent. Have fun."
+ einfo
+}
diff --git a/games-board/crafty/files/digest-crafty-20.11 b/games-board/crafty/files/digest-crafty-20.11
new file mode 100644
index 000000000000..ec70cf6811ad
--- /dev/null
+++ b/games-board/crafty/files/digest-crafty-20.11
@@ -0,0 +1,3 @@
+MD5 a6340c017d5b856fe2ae07c311e8dca8 crafty-20.11.zip 422310
+RMD160 a5b3fac95b3ccf37cd5dd7cb94965c6cecbf6fb6 crafty-20.11.zip 422310
+SHA256 136e2b60d5040a63a61103b22d514aaf35220a19408df7aa1adfbc0c8c8fb985 crafty-20.11.zip 422310