summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-10 16:56:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-10 16:56:30 +0000
commit571eac5b4906b78e74ae0dcf2e8a6c3a02f65ff6 (patch)
tree187fec253797d9f6d4f4af83e8a3b7e0bef06fc9 /games-board
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-571eac5b4906b78e74ae0dcf2e8a6c3a02f65ff6.tar.gz
gentoo-2-571eac5b4906b78e74ae0dcf2e8a6c3a02f65ff6.tar.bz2
gentoo-2-571eac5b4906b78e74ae0dcf2e8a6c3a02f65ff6.zip
Extend GCC 4.3+ patch to include test suite wrt #273531.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/six/ChangeLog8
-rw-r--r--games-board/six/files/six-0.5.3-gcc43.patch40
-rw-r--r--games-board/six/six-0.5.3.ebuild4
3 files changed, 39 insertions, 13 deletions
diff --git a/games-board/six/ChangeLog b/games-board/six/ChangeLog
index 61f1c4bc72f5..fda4f2d29557 100644
--- a/games-board/six/ChangeLog
+++ b/games-board/six/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/six
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/six/ChangeLog,v 1.14 2009/02/17 09:17:57 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/six/ChangeLog,v 1.15 2009/08/10 16:56:29 ssuominen Exp $
+
+ 10 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> six-0.5.3.ebuild,
+ files/six-0.5.3-gcc43.patch:
+ Extend GCC 4.3+ patch to include test suite wrt #273531.
17 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org> six-0.5.3.ebuild:
fix desktop entry as reported by Pacho Ramos in bug #160251
diff --git a/games-board/six/files/six-0.5.3-gcc43.patch b/games-board/six/files/six-0.5.3-gcc43.patch
index d3e066686125..c9a964e28907 100644
--- a/games-board/six/files/six-0.5.3-gcc43.patch
+++ b/games-board/six/files/six-0.5.3-gcc43.patch
@@ -1,6 +1,6 @@
-diff -u -ur a/six/carrier.h b/six/carrier.h
---- a/six/carrier.h 2004-07-19 10:30:51.000000000 +0200
-+++ b/six/carrier.h 2008-06-15 13:09:35.000000000 +0200
+diff -ur six-0.5.3.orig/six/carrier.h six-0.5.3/six/carrier.h
+--- six-0.5.3.orig/six/carrier.h 2004-07-19 11:30:51.000000000 +0300
++++ six-0.5.3/six/carrier.h 2009-08-10 19:43:07.000000000 +0300
@@ -4,6 +4,7 @@
#include <iostream>
@@ -9,9 +9,9 @@ diff -u -ur a/six/carrier.h b/six/carrier.h
using std::vector;
using std::istream;
-diff -u -ur a/six/hexgame.cpp b/six/hexgame.cpp
---- a/six/hexgame.cpp 2004-07-19 10:30:51.000000000 +0200
-+++ b/six/hexgame.cpp 2008-06-15 13:10:26.000000000 +0200
+diff -ur six-0.5.3.orig/six/hexgame.cpp six-0.5.3/six/hexgame.cpp
+--- six-0.5.3.orig/six/hexgame.cpp 2004-07-19 11:30:51.000000000 +0300
++++ six-0.5.3/six/hexgame.cpp 2009-08-10 19:43:07.000000000 +0300
@@ -3,7 +3,7 @@
#include <cassert>
#include <cctype>
@@ -21,9 +21,9 @@ diff -u -ur a/six/hexgame.cpp b/six/hexgame.cpp
#include <string>
using std::endl;
-diff -u -ur a/six/main.cpp b/six/main.cpp
---- a/six/main.cpp 2004-07-19 10:30:51.000000000 +0200
-+++ b/six/main.cpp 2008-06-15 13:08:59.000000000 +0200
+diff -ur six-0.5.3.orig/six/main.cpp six-0.5.3/six/main.cpp
+--- six-0.5.3.orig/six/main.cpp 2004-07-19 11:30:51.000000000 +0300
++++ six-0.5.3/six/main.cpp 2009-08-10 19:43:07.000000000 +0300
@@ -11,6 +11,7 @@
#include <klocale.h>
#include <kmessagebox.h>
@@ -32,3 +32,25 @@ diff -u -ur a/six/main.cpp b/six/main.cpp
using std::cin;
+diff -ur six-0.5.3.orig/tests/connectortest.cpp six-0.5.3/tests/connectortest.cpp
+--- six-0.5.3.orig/tests/connectortest.cpp 2004-07-19 11:30:57.000000000 +0300
++++ six-0.5.3/tests/connectortest.cpp 2009-08-10 19:56:04.000000000 +0300
+@@ -6,6 +6,7 @@
+
+ #include "testutil.h"
+
++#include <algorithm>
+ #include <cassert>
+ #include <cmath>
+
+diff -ur six-0.5.3.orig/tests/testutil.cpp six-0.5.3/tests/testutil.cpp
+--- six-0.5.3.orig/tests/testutil.cpp 2004-07-19 11:30:57.000000000 +0300
++++ six-0.5.3/tests/testutil.cpp 2009-08-10 19:42:33.000000000 +0300
+@@ -1,5 +1,7 @@
+ #include "testutil.h"
+
++#include <stdlib.h>
++#include <string.h>
+ #include <ctype.h>
+
+ vector<HexMove> parseMoves(const HexBoard &b, const char *s)
diff --git a/games-board/six/six-0.5.3.ebuild b/games-board/six/six-0.5.3.ebuild
index 61e553f6af2a..ad498cca6b65 100644
--- a/games-board/six/six-0.5.3.ebuild
+++ b/games-board/six/six-0.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/six/six-0.5.3.ebuild,v 1.3 2009/02/17 09:17:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/six/six-0.5.3.ebuild,v 1.4 2009/08/10 16:56:29 ssuominen Exp $
ARTS_REQUIRED="yes"
inherit kde
@@ -11,7 +11,7 @@ SRC_URI="http://six.retes.hu/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="ppc ~sparc x86"
+KEYWORDS="~amd64 ppc ~sparc x86"
IUSE=""
PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )