summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-30 22:50:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-30 22:50:58 +0000
commit4cc0835a2b1d2ebde6fd9a65e3320dd660c6af90 (patch)
treee20a8c55ead564b81a0421524f0a60016df3ac33 /games-board
parentold (diff)
downloadgentoo-2-4cc0835a2b1d2ebde6fd9a65e3320dd660c6af90.tar.gz
gentoo-2-4cc0835a2b1d2ebde6fd9a65e3320dd660c6af90.tar.bz2
gentoo-2-4cc0835a2b1d2ebde6fd9a65e3320dd660c6af90.zip
old
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/ace/ChangeLog7
-rw-r--r--games-board/ace/ace-1.3.ebuild49
-rw-r--r--games-board/ace/files/ace-1.3-implicit-pointer.patch14
-rw-r--r--games-board/ace/files/ace-1.3-libpng15.patch29
-rw-r--r--games-board/ace/files/ace-1.3-no-xpm.patch24
5 files changed, 6 insertions, 117 deletions
diff --git a/games-board/ace/ChangeLog b/games-board/ace/ChangeLog
index 639618ad5f5d..93b3bd12ae44 100644
--- a/games-board/ace/ChangeLog
+++ b/games-board/ace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/ace
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ChangeLog,v 1.30 2013/01/06 21:29:48 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ChangeLog,v 1.31 2013/01/30 22:50:58 mr_bones_ Exp $
+
+ 30 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -ace-1.3.ebuild,
+ -files/ace-1.3-implicit-pointer.patch, -files/ace-1.3-libpng15.patch,
+ -files/ace-1.3-no-xpm.patch:
+ old
06 Jan 2013; <jd@gentoo.org> ace-1.4.ebuild:
marked x86 per bug 450060
diff --git a/games-board/ace/ace-1.3.ebuild b/games-board/ace/ace-1.3.ebuild
deleted file mode 100644
index 41ecee16443c..000000000000
--- a/games-board/ace/ace-1.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ace-1.3.ebuild,v 1.5 2011/09/15 07:23:31 ssuominen Exp $
-
-EAPI=2
-inherit eutils games
-
-DESCRIPTION="DJ Delorie's Ace of Penguins solitaire games"
-HOMEPAGE="http://www.delorie.com/store/ace/"
-SRC_URI="http://www.delorie.com/store/ace/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~sparc x86"
-IUSE=""
-
-RDEPEND="x11-libs/libX11
- media-libs/libpng"
-DEPEND="${RDEPEND}
- x11-proto/xproto"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-no-xpm.patch \
- "${FILESDIR}"/${P}-implicit-pointer.patch \
- "${FILESDIR}"/${P}-libpng15.patch
-}
-
-src_configure() {
- egamesconf \
- --disable-dependency-tracking \
- --disable-static \
- --program-prefix=ace-
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
- dohtml docs/*
- newicon docs/as.gif ${PN}.gif
- cd "${D}${GAMES_BINDIR}" && {
- local p
- for p in *
- do
- make_desktop_entry $p "Ace ${p/ace-/}" /usr/share/pixmaps/${PN}.gif
- done
- }
- prepgamesdirs
-}
diff --git a/games-board/ace/files/ace-1.3-implicit-pointer.patch b/games-board/ace/files/ace-1.3-implicit-pointer.patch
deleted file mode 100644
index 6a5ea42b705a..000000000000
--- a/games-board/ace/files/ace-1.3-implicit-pointer.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: ace-1.3/games/spider.c
-===================================================================
---- ace-1.3.orig/games/spider.c
-+++ ace-1.3/games/spider.c
-@@ -20,8 +20,8 @@
- #include <string.h>
- #include <time.h>
-
-+#include "imagelib.h"
- #include "cards.h"
--//#include "imagelib.h"
-
- #define W CARD_WIDTH
- #define H CARD_HEIGHT
diff --git a/games-board/ace/files/ace-1.3-libpng15.patch b/games-board/ace/files/ace-1.3-libpng15.patch
deleted file mode 100644
index f0ec4e9f6359..000000000000
--- a/games-board/ace/files/ace-1.3-libpng15.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- lib/make-imglib.c
-+++ lib/make-imglib.c
-@@ -86,7 +86,7 @@
- png_ptr = png_create_read_struct (PNG_LIBPNG_VER_STRING, 0, 0, 0);
- info_ptr = png_create_info_struct (png_ptr);
-
-- if (setjmp (png_ptr->jmpbuf)) {
-+ if (setjmp (png_jmpbuf(png_ptr))) {
- fclose (f);
- continue;
- }
---- lib/xwin.c
-+++ lib/xwin.c
-@@ -824,13 +824,13 @@
- png_ptr = png_create_read_struct (PNG_LIBPNG_VER_STRING, 0, 0, 0);
- info_ptr = png_create_info_struct (png_ptr);
-
-- if (setjmp (png_ptr->jmpbuf)) {
-+ if (setjmp (png_jmpbuf(png_ptr))) {
- fprintf(stderr, "Invalid PNG image!\n");
- return;
- }
-
- file_bytes = src->file_data;
-- png_set_read_fn (png_ptr, (voidp)&file_bytes, (png_rw_ptr)png_reader);
-+ png_set_read_fn (png_ptr, (png_voidp)&file_bytes, (png_rw_ptr)png_reader);
-
- png_read_info (png_ptr, info_ptr);
-
diff --git a/games-board/ace/files/ace-1.3-no-xpm.patch b/games-board/ace/files/ace-1.3-no-xpm.patch
deleted file mode 100644
index 25b06754be42..000000000000
--- a/games-board/ace/files/ace-1.3-no-xpm.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- lib/table.c.orig 2008-01-15 15:05:27.000000000 -0500
-+++ lib/table.c 2010-09-29 17:34:40.925310980 -0400
-@@ -23,7 +23,6 @@
- #include <X11/Xutil.h>
- #include <X11/keysym.h>
- #include <X11/Xatom.h>
--#include <X11/xpm.h>
-
- #define CD printf("%d: %d %d %d %d\n", __LINE__, ex, ey, ew, eh)
- #undef CD
-@@ -165,13 +164,6 @@
- xwin_create (width, height);
- }
-
--typedef struct PicRec {
-- Pixmap pixmap;
-- Pixmap mask;
-- char **xpm_data;
-- int image_table_index;
--} PicRec;
--
- int get_picture_default_width = CARD_WIDTH;
- int get_picture_default_height = CARD_HEIGHT;
-