summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-04-11 15:41:11 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-04-11 15:41:11 +0000
commit34c0f356665205815cc96d5a027b4b72ea288c5b (patch)
tree035d8c0f538c5d7ff7682cb21050f70b2db39db1 /games-board
parentSync no-multilib/package.mask from default-linux. (diff)
downloadgentoo-2-34c0f356665205815cc96d5a027b4b72ea288c5b.tar.gz
gentoo-2-34c0f356665205815cc96d5a027b4b72ea288c5b.tar.bz2
gentoo-2-34c0f356665205815cc96d5a027b4b72ea288c5b.zip
Removed icc USE flag use for bug #216511.
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/crafty/ChangeLog6
-rw-r--r--games-board/crafty/crafty-20.13.ebuild13
-rw-r--r--games-board/crafty/crafty-21.6-r1.ebuild89
-rw-r--r--games-board/crafty/crafty-22.0.ebuild9
4 files changed, 15 insertions, 102 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index b918d75413f2..95648257bf45 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/crafty
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.25 2008/02/29 23:41:34 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.26 2008/04/11 15:41:11 wolf31o2 Exp $
+
+ 11 Apr 2008; Chris Gianelloni <wolf31o2@gentoo.org> crafty-20.13.ebuild,
+ -crafty-21.6-r1.ebuild, crafty-22.0.ebuild:
+ Removed icc USE flag use for bug #216511.
*crafty-22.0 (29 Feb 2008)
diff --git a/games-board/crafty/crafty-20.13.ebuild b/games-board/crafty/crafty-20.13.ebuild
index d21da7f0cdef..f32cd8299447 100644
--- a/games-board/crafty/crafty-20.13.ebuild
+++ b/games-board/crafty/crafty-20.13.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-20.13.ebuild,v 1.3 2007/03/12 13:44:57 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-20.13.ebuild,v 1.4 2008/04/11 15:41:11 wolf31o2 Exp $
-inherit flag-o-matic games
+inherit flag-o-matic toolchain-funcs games
DESCRIPTION="Bob Hyatt's strong chess engine"
HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
@@ -11,12 +11,11 @@ SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.zip"
LICENSE="crafty"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-IUSE="icc no-opts"
+IUSE="no-opts"
RDEPEND=""
DEPEND="${RDEPEND}
- app-arch/unzip
- icc? ( >=dev-lang/icc-5.0 )"
+ app-arch/unzip"
src_unpack() {
unpack ${A}
@@ -33,7 +32,7 @@ src_compile() {
local makeopts="target=LINUX"
if ! use no-opts ; then
- if use icc ; then
+ if [[ $(tc-getCC) = icc ]] ; then
makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
append-flags -D_REENTRANT -tpp6 \
-DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
diff --git a/games-board/crafty/crafty-21.6-r1.ebuild b/games-board/crafty/crafty-21.6-r1.ebuild
deleted file mode 100644
index 887b8fd3131b..000000000000
--- a/games-board/crafty/crafty-21.6-r1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-21.6-r1.ebuild,v 1.1 2007/12/26 11:12:04 tupone Exp $
-
-inherit flag-o-matic games
-
-DESCRIPTION="Bob Hyatt's strong chess engine"
-HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
-SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.zip
- ftp://ftp.cis.uab.edu/pub/hyatt/documentation/${PN}.doc.ascii"
-
-LICENSE="crafty"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="icc no-opts"
-RESTRICT="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-arch/unzip
- icc? ( >=dev-lang/icc-5.0 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/-o crafty/s/CC/CXX/' \
- -e 's:CXFLAGS:CXXFLAGS:g' \
- Makefile \
- || die "sed failed"
- sed -i \
- -e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
- || die "sed failed"
-}
-
-src_compile() {
- local makeopts="target=LINUX"
-
- if ! use no-opts ; then
- if use icc ; then
- makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
- append-flags -D_REENTRANT -tpp6 \
- -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
- -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
- -DSMP -DCPUS=4 -DCLONE -DDGT
- append-flags -O2 -fno-alias -fforce-mem \
- -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
- else
- if [[ "${CHOST}" == "i686-pc-linux-gnu" ]] \
- || [[ "${CHOST}" == "i586-pc-linux-gnu" ]] ; then
- append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
- -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
- -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
- append-flags -fno-gcse \
- -fomit-frame-pointer -mpreferred-stack-boundary=2
- makeopts="${makeopts} CC=gcc CXX=g++"
- elif [[ "${CHOST}" == "x86_64-pc-linux-gnu" ]] ; then
- append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
- -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
- -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
- append-flags -fomit-frame-pointer
- makeopts="${makeopts} CC=gcc CXX=g++"
- else
- : # everything else :)
- fi
- fi
- fi
- append-flags -DPOSIX
- emake ${makeopts} crafty-make LDFLAGS="${LDFLAGS} -lpthread" || die "build failed"
-}
-
-src_install() {
- dogamesbin crafty || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}/${PN}"
- doins crafty.hlp || die "doins failed"
- dodoc "${DISTDIR}"/crafty.doc.ascii
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- elog
- elog "Note: No books or tablebases have been installed. If you want them, just"
- elog " download them from ${HOMEPAGE}."
- elog " You will find documentation there too. In most cases you take now "
- elog " your xboard compatible application, (xboard, eboard, knights) and "
- elog " just play chess against computer opponent. Have fun."
- elog
-}
diff --git a/games-board/crafty/crafty-22.0.ebuild b/games-board/crafty/crafty-22.0.ebuild
index f76d3ba5dd8c..14eaef03be02 100644
--- a/games-board/crafty/crafty-22.0.ebuild
+++ b/games-board/crafty/crafty-22.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-22.0.ebuild,v 1.1 2008/02/29 23:41:34 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-22.0.ebuild,v 1.2 2008/04/11 15:41:11 wolf31o2 Exp $
inherit flag-o-matic games
@@ -12,13 +12,12 @@ SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.zip
LICENSE="crafty"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="icc no-opts"
+IUSE="no-opts"
RESTRICT="test"
RDEPEND=""
DEPEND="${RDEPEND}
- app-arch/unzip
- icc? ( >=dev-lang/icc-5.0 )"
+ app-arch/unzip"
src_unpack() {
unpack ${A}
@@ -37,7 +36,7 @@ src_compile() {
local makeopts="target=LINUX"
if ! use no-opts ; then
- if use icc ; then
+ if [[ $(tc-getCC) = icc ]] ; then
makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
append-flags -D_REENTRANT -tpp6 \
-DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \