summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-05-28 09:22:40 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-05-28 09:22:40 +0000
commit32ac9edc58f0a455e64610b4620b6c33ccb3304c (patch)
treebb260376a7e0574523d9c2849f6cdb5d50bd4c7e /games-board
parentFix logoff issue per bug #268129. (diff)
downloadgentoo-2-32ac9edc58f0a455e64610b4620b6c33ccb3304c.tar.gz
gentoo-2-32ac9edc58f0a455e64610b4620b6c33ccb3304c.tar.bz2
gentoo-2-32ac9edc58f0a455e64610b4620b6c33ccb3304c.zip
Fix build with glibc-2.10.1 Bug #271224
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnuchess/ChangeLog6
-rw-r--r--games-board/gnuchess/files/gnuchess-glibc210.patch39
-rw-r--r--games-board/gnuchess/gnuchess-5.07.ebuild6
3 files changed, 48 insertions, 3 deletions
diff --git a/games-board/gnuchess/ChangeLog b/games-board/gnuchess/ChangeLog
index 152c66886a08..9e233c529616 100644
--- a/games-board/gnuchess/ChangeLog
+++ b/games-board/gnuchess/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/gnuchess
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnuchess/ChangeLog,v 1.16 2009/04/06 17:35:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnuchess/ChangeLog,v 1.17 2009/05/28 09:22:39 tupone Exp $
+
+ 28 May 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/gnuchess-glibc210.patch, gnuchess-5.07.ebuild:
+ Fix build with glibc-2.10.1 Bug #271224 by Timo Rothenpieler
06 Apr 2009; Michael Sterrett <mr_bones_@gentoo.org> gnuchess-5.07.ebuild:
strip-flags for bug #199097
diff --git a/games-board/gnuchess/files/gnuchess-glibc210.patch b/games-board/gnuchess/files/gnuchess-glibc210.patch
new file mode 100644
index 000000000000..3c191eec95ab
--- /dev/null
+++ b/games-board/gnuchess/files/gnuchess-glibc210.patch
@@ -0,0 +1,39 @@
+--- src/common.h.old 2009-05-28 10:26:58.000000000 +0200
++++ src/common.h 2009-05-28 11:03:31.000000000 +0200
+@@ -745,7 +745,7 @@
+ * Input routine, initialized to one of the specific
+ * input routines. The given argument is the prompt.
+ */
+-void (*getline) (char *);
++void (*mygetline) (char *);
+
+ #define MAXSTR 128
+ extern char inputstr[MAXSTR];
+--- src/input.c.old 2009-05-28 10:27:06.000000000 +0200
++++ src/input.c 2009-05-28 11:04:38.000000000 +0200
+@@ -127,7 +127,7 @@
+ (RealGameCnt+1)/2 + 1 );
+ }
+ pthread_mutex_lock(&input_mutex);
+- getline(prompt);
++ mygetline(prompt);
+ input_status = INPUT_AVAILABLE;
+ pthread_cond_signal(&input_cond);
+ pthread_mutex_unlock(&input_mutex);
+@@ -173,13 +173,13 @@
+ {
+ #ifdef HAVE_LIBREADLINE
+ if (isatty(STDIN_FILENO)) {
+- getline = getline_readline;
++ mygetline = getline_readline;
+ using_history();
+ } else {
+- getline = getline_standard;
++ mygetline = getline_standard;
+ }
+ #else
+- getline = getline_standard;
++ mygetline = getline_standard;
+ #endif
+ /* Start input thread */
+ pthread_create(&input_thread, NULL, input_func, NULL);
diff --git a/games-board/gnuchess/gnuchess-5.07.ebuild b/games-board/gnuchess/gnuchess-5.07.ebuild
index 0d6274cf0a6d..2d82c6ce3eca 100644
--- a/games-board/gnuchess/gnuchess-5.07.ebuild
+++ b/games-board/gnuchess/gnuchess-5.07.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnuchess/gnuchess-5.07.ebuild,v 1.13 2009/04/06 17:35:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnuchess/gnuchess-5.07.ebuild,v 1.14 2009/05/28 09:22:39 tupone Exp $
EAPI=2
inherit flag-o-matic eutils games
@@ -15,8 +15,10 @@ SLOT="0"
IUSE="readline"
DEPEND="readline? ( sys-libs/readline )"
+RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/gnuchess-gcc4.patch )
+PATCHES=( "${FILESDIR}"/gnuchess-gcc4.patch
+ "${FILESDIR}"/gnuchess-glibc210.patch )
src_configure() {
strip-flags # bug #199097