summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-02 18:50:07 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-02 18:50:07 +0000
commit25bd5603fedc477f4a1d06ba39b4c8d55262ef35 (patch)
tree10c6587d205852a79ef4001b9f6786933e3c47ee /games-board
parentBump to 2.22.1.1 (diff)
downloadgentoo-2-25bd5603fedc477f4a1d06ba39b4c8d55262ef35.tar.gz
gentoo-2-25bd5603fedc477f4a1d06ba39b4c8d55262ef35.tar.bz2
gentoo-2-25bd5603fedc477f4a1d06ba39b4c8d55262ef35.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/grhino/ChangeLog6
-rw-r--r--games-board/grhino/files/grhino-0.16.0-gcc43.patch30
-rw-r--r--games-board/grhino/grhino-0.16.0.ebuild3
3 files changed, 37 insertions, 2 deletions
diff --git a/games-board/grhino/ChangeLog b/games-board/grhino/ChangeLog
index a5cf541fc1dd..153f4b9ca630 100644
--- a/games-board/grhino/ChangeLog
+++ b/games-board/grhino/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/grhino
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/grhino/ChangeLog,v 1.6 2008/03/20 11:49:46 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/grhino/ChangeLog,v 1.7 2008/05/02 18:50:06 nyhm Exp $
+
+ 02 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/grhino-0.16.0-gcc43.patch, grhino-0.16.0.ebuild:
+ Fix building with gcc-4.3
20 Mar 2008; Tristan Heaven <nyhm@gentoo.org> grhino-0.16.0.ebuild:
Add ~amd64 keyword
diff --git a/games-board/grhino/files/grhino-0.16.0-gcc43.patch b/games-board/grhino/files/grhino-0.16.0-gcc43.patch
new file mode 100644
index 000000000000..e0477a20337b
--- /dev/null
+++ b/games-board/grhino/files/grhino-0.16.0-gcc43.patch
@@ -0,0 +1,30 @@
+--- book.cc
++++ book.cc
+@@ -28,6 +28,7 @@
+ #include <vector>
+ #include <iostream>
+ #include <stdexcept>
++#include <cstdlib>
+
+ #ifdef _
+ #undef _
+--- game.cc
++++ game.cc
+@@ -37,6 +37,7 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <fcntl.h>
++#include <cstdlib>
+
+ #ifdef _
+ # undef _
+--- log_proc.h
++++ log_proc.h
+@@ -25,6 +25,7 @@
+ #include <string>
+ #include <fstream>
+ #include <iomanip>
++#include <cstdlib>
+
+ #include "board.h"
+ #include "order.h"
diff --git a/games-board/grhino/grhino-0.16.0.ebuild b/games-board/grhino/grhino-0.16.0.ebuild
index bf6e64c2c50c..3a47b3494112 100644
--- a/games-board/grhino/grhino-0.16.0.ebuild
+++ b/games-board/grhino/grhino-0.16.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/grhino/grhino-0.16.0.ebuild,v 1.6 2008/03/20 11:49:46 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/grhino/grhino-0.16.0.ebuild,v 1.7 2008/05/02 18:50:06 nyhm Exp $
inherit eutils games
@@ -21,6 +21,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
sed -i '/^(\|locale\|help\|omf\|icon\|)/s:@datadir@:/usr/share:' \
Makefile.in \
|| die "sed failed"