summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-03 09:11:40 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-03 09:11:40 +0000
commit020beb27d6da6874af594a8a9a433a8017bd7be7 (patch)
tree8ff04213e5c9b3de744494e79f7b7ecb915e8344 /games-board
parentdo dodoc only if file exists (diff)
downloadgentoo-2-020beb27d6da6874af594a8a9a433a8017bd7be7.tar.gz
gentoo-2-020beb27d6da6874af594a8a9a433a8017bd7be7.tar.bz2
gentoo-2-020beb27d6da6874af594a8a9a433a8017bd7be7.zip
Fix --as-needed bug #247336
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/atakks/ChangeLog8
-rw-r--r--games-board/atakks/atakks-1.0.ebuild19
-rw-r--r--games-board/atakks/files/atakks-1.0-as-needed.patch16
3 files changed, 28 insertions, 15 deletions
diff --git a/games-board/atakks/ChangeLog b/games-board/atakks/ChangeLog
index b55d06669b39..b7fa5b3d4f1c 100644
--- a/games-board/atakks/ChangeLog
+++ b/games-board/atakks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/atakks
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/atakks/ChangeLog,v 1.8 2007/03/14 23:25:50 nyhm Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/atakks/ChangeLog,v 1.9 2009/02/03 09:11:40 tupone Exp $
+
+ 03 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/atakks-1.0-as-needed.patch, atakks-1.0.ebuild:
+ Fix --as-needed bug #247336 by flameeyes@gentoo.org
14 Mar 2007; Tristan Heaven <nyhm@gentoo.org> atakks-1.0.ebuild:
Install menu entry, bug #159843
diff --git a/games-board/atakks/atakks-1.0.ebuild b/games-board/atakks/atakks-1.0.ebuild
index dbfd7cc22940..d0c381f63bd2 100644
--- a/games-board/atakks/atakks-1.0.ebuild
+++ b/games-board/atakks/atakks-1.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/atakks/atakks-1.0.ebuild,v 1.8 2007/03/14 23:25:50 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/atakks/atakks-1.0.ebuild,v 1.9 2009/02/03 09:11:40 tupone Exp $
+EAPI=2
inherit eutils games
MY_P=${P/-/_}
@@ -20,22 +21,14 @@ DEPEND="media-libs/libsdl"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Modify game data paths
sed -i \
-e "s:SDL_LoadBMP(\":SDL_LoadBMP(\"${GAMES_DATADIR}/${PN}/:" \
main.c || die "sed failed"
- # Modify Makefile (CFLAGS and language)
- sed -i \
- -e 's:^CFLAGS=:CFLAGS= $(E_CFLAGS) -DUS:' \
- -e "s:^LDFLAGS.*$:LDFLAGS+=$(sdl-config --libs):" \
- Makefile || die "sed failed"
-
- epatch "${FILESDIR}"/${PV}-warnings.patch
+ epatch "${FILESDIR}"/${PV}-warnings.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
}
src_compile() {
diff --git a/games-board/atakks/files/atakks-1.0-as-needed.patch b/games-board/atakks/files/atakks-1.0-as-needed.patch
new file mode 100644
index 000000000000..b02e32002fa9
--- /dev/null
+++ b/games-board/atakks/files/atakks-1.0-as-needed.patch
@@ -0,0 +1,16 @@
+--- Makefile.old 2009-02-03 10:02:08.000000000 +0100
++++ Makefile 2009-02-03 10:04:12.000000000 +0100
+@@ -1,10 +1,10 @@
+-LDFLAGS= -lSDL -lpthread -s
+-CFLAGS= -Wall -ansi # -DDEBUG
++LDLIBS = -lSDL
++CFLAGS= $(E_CFLAGS) -DUS -Wall -ansi # -DDEBUG
+ all: atakks
+ clean:
+ rm atakks *.o
+ atakks: main.o
+- $(CC) $(LDFLAGS) $< -o $@
++ $(CC) $(LDFLAGS) $< -o $@ $(LDLIBS)
+ pkg:
+ mkdir atakks-src
+ cp *.bmp main.c Makefile README atakks-src