summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-01-23 05:33:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-01-23 05:33:57 +0000
commit6d642ca92f69220f6b426f58eb2a26165ea3634c (patch)
tree03072a81cc0be5ef2e13d37f78994ea3c65f89c5 /games-board/pokerth
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-6d642ca92f69220f6b426f58eb2a26165ea3634c.tar.gz
gentoo-2-6d642ca92f69220f6b426f58eb2a26165ea3634c.tar.bz2
gentoo-2-6d642ca92f69220f6b426f58eb2a26165ea3634c.zip
version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-board/pokerth')
-rw-r--r--games-board/pokerth/ChangeLog8
-rw-r--r--games-board/pokerth/pokerth-0.8.3.ebuild76
2 files changed, 83 insertions, 1 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index e1f28a84846a..839fa5383217 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/pokerth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.23 2011/01/11 22:30:58 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.24 2011/01/23 05:33:57 mr_bones_ Exp $
+
+*pokerth-0.8.3 (23 Jan 2011)
+
+ 23 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ +pokerth-0.8.3.ebuild:
+ version bump
11 Jan 2011; Brent Baude <ranger@gentoo.org> pokerth-0.8.1.ebuild:
Marking pokerth-0.8.1 ppc for bug 347089
diff --git a/games-board/pokerth/pokerth-0.8.3.ebuild b/games-board/pokerth/pokerth-0.8.3.ebuild
new file mode 100644
index 000000000000..d6a6f7efc0fc
--- /dev/null
+++ b/games-board/pokerth/pokerth-0.8.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.8.3.ebuild,v 1.1 2011/01/23 05:33:57 mr_bones_ Exp $
+
+EAPI=2
+inherit multilib flag-o-matic eutils qt4 games
+
+MY_P="PokerTH-${PV//_/-}-src"
+DESCRIPTION="Texas Hold'em poker game"
+HOMEPAGE="http://www.pokerth.net/"
+SRC_URI="mirror://sourceforge/pokerth/${MY_P}.tar.bz2"
+
+LICENSE="GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated"
+
+DEPEND=">=dev-libs/boost-1.41
+ >=net-libs/gnutls-2.2.2
+ >=net-misc/curl-7.16
+ x11-libs/qt-core:4
+ >=virtual/gsasl-1.1
+ !dedicated? (
+ media-libs/libsdl
+ media-libs/sdl-mixer[mikmod,vorbis]
+ >=sys-libs/zlib-1.2.3
+ x11-libs/qt-gui:4
+ x11-libs/qt-sql:4
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ local boost_ver
+
+ if use dedicated ; then
+ sed -i \
+ -e 's/pokerth_game.pro//' \
+ pokerth.pro \
+ || die "sed failed"
+ fi
+ sed -i \
+ -e '/no_dead_strip_inits_and_terms/d' \
+ *pro \
+ || die 'sed failed'
+ local boost_ver=$(best_version ">=dev-libs/boost-1.41")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ dogamesbin bin/pokerth_server || die
+ if ! use dedicated ; then
+ dogamesbin ${PN} || die
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data || die
+ domenu ${PN}.desktop
+ doicon ${PN}.png
+ fi
+ dodoc ChangeLog TODO docs/{net_protocol,server_setup_howto}.txt
+ prepgamesdirs
+}