summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-02-24 06:32:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-02-24 06:32:09 +0000
commit7fc88577372b9337fc6f518b0a8286ae3102c857 (patch)
tree8844819d7275ef3cac99951b763822c1f8138139 /games-board/pio/pio-0.9.55.ebuild
parentsome arches need retesting (diff)
downloadgentoo-2-7fc88577372b9337fc6f518b0a8286ae3102c857.tar.gz
gentoo-2-7fc88577372b9337fc6f518b0a8286ae3102c857.tar.bz2
gentoo-2-7fc88577372b9337fc6f518b0a8286ae3102c857.zip
version bump
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'games-board/pio/pio-0.9.55.ebuild')
-rw-r--r--games-board/pio/pio-0.9.55.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-board/pio/pio-0.9.55.ebuild b/games-board/pio/pio-0.9.55.ebuild
new file mode 100644
index 000000000000..4ce6925f0ec9
--- /dev/null
+++ b/games-board/pio/pio-0.9.55.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pio/pio-0.9.55.ebuild,v 1.1 2006/02/24 06:32:09 mr_bones_ Exp $
+
+inherit eutils gnome2
+
+MY_P="pioneers-${PV}"
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://pio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pio/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2.4
+ >=gnome-base/libgnome-2.10
+ >=x11-libs/gtk+-2.4
+ >=app-text/scrollkeeper-0.3"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ export G2CONF="${G2CONF} $(use_enable nls)"
+ gnome2_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README TODO NEWS"
+ USE_DESTDIR=1
+ gnome2_src_install scrollkeeper_localstate_dir="${D}"/var/lib/scrollkeeper/
+}