summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-21 19:00:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-21 19:00:30 +0000
commited7d12b997ff1ae2a53618271f9fb8ceda94df1c (patch)
tree437d1bd1bdabfb7c0a7d2325d9051c88ea53da8a /games-board/mahjongg3d/mahjongg3d-0.96.ebuild
parentFixes #52876. (Manifest recommit) (diff)
downloadgentoo-2-ed7d12b997ff1ae2a53618271f9fb8ceda94df1c.tar.gz
gentoo-2-ed7d12b997ff1ae2a53618271f9fb8ceda94df1c.tar.bz2
gentoo-2-ed7d12b997ff1ae2a53618271f9fb8ceda94df1c.zip
version bump
Diffstat (limited to 'games-board/mahjongg3d/mahjongg3d-0.96.ebuild')
-rw-r--r--games-board/mahjongg3d/mahjongg3d-0.96.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-board/mahjongg3d/mahjongg3d-0.96.ebuild b/games-board/mahjongg3d/mahjongg3d-0.96.ebuild
new file mode 100644
index 000000000000..3ec820285980
--- /dev/null
+++ b/games-board/mahjongg3d/mahjongg3d-0.96.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/mahjongg3d/mahjongg3d-0.96.ebuild,v 1.1 2004/06/21 19:00:30 mr_bones_ Exp $
+
+inherit kde games
+
+DESCRIPTION="An implementation of the classical chinese game Mah Jongg with 3D OpenGL graphics"
+HOMEPAGE="http://www.reto-schoelly.de/mahjongg3d/"
+SRC_URI="http://www.reto-schoelly.de/${PN}/${PN}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND=">=qt-3.2.0
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}.release"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "/GAMEDATA_BASE_PATH/ s:\.:${GAMES_DATADIR}/${PN}:" \
+ src/gamedata_path.h || die "sed src/gamedata_path.h failed"
+}
+
+src_compile() {
+ qmake -o Makefile mahjongg3d.pro
+ kde_src_compile none
+ emake || die "emake failed"
+}
+
+src_install () {
+ dogamesbin bin/{mahjongg3d,mahjongg3d-install-*} || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r bin/{[a-l]*,t*} "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
+ dodoc README Changelog
+ prepgamesdirs
+}