summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-11-21 20:39:58 +0000
committerDon Seiler <rizzo@gentoo.org>2004-11-21 20:39:58 +0000
commit4fa7f05e9d32ddfa159194920af898c6d8bfbd88 (patch)
tree1d2f4855fd5863213afdb5c6f48ea83c80a7754c /games-board/gnocatan
parentremoved DEPEND completely since app-arch/rpm2targz will be inherited from rpm... (diff)
downloadgentoo-2-4fa7f05e9d32ddfa159194920af898c6d8bfbd88.tar.gz
gentoo-2-4fa7f05e9d32ddfa159194920af898c6d8bfbd88.tar.bz2
gentoo-2-4fa7f05e9d32ddfa159194920af898c6d8bfbd88.zip
Version bump
Diffstat (limited to 'games-board/gnocatan')
-rw-r--r--games-board/gnocatan/ChangeLog7
-rw-r--r--games-board/gnocatan/Manifest8
-rw-r--r--games-board/gnocatan/files/digest-gnocatan-0.8.1.431
-rw-r--r--games-board/gnocatan/gnocatan-0.8.1.43.ebuild45
4 files changed, 57 insertions, 4 deletions
diff --git a/games-board/gnocatan/ChangeLog b/games-board/gnocatan/ChangeLog
index 22d940035dea..52a44a11732d 100644
--- a/games-board/gnocatan/ChangeLog
+++ b/games-board/gnocatan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/gnocatan
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/ChangeLog,v 1.22 2004/11/12 21:39:30 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/ChangeLog,v 1.23 2004/11/21 20:39:58 rizzo Exp $
+
+*gnocatan-0.8.1.43 (21 Nov 2004)
+
+ 21 Nov 2004; Don Seiler <rizzo@gentoo.org> +gnocatan-0.8.1.43.ebuild:
+ Version bump
*gnocatan-0.8.1.42 (12 Nov 2004)
diff --git a/games-board/gnocatan/Manifest b/games-board/gnocatan/Manifest
index bb8d5fa90640..4147a71f66d0 100644
--- a/games-board/gnocatan/Manifest
+++ b/games-board/gnocatan/Manifest
@@ -1,6 +1,8 @@
MD5 c0e60ab86a0491893636734d4feda27a ChangeLog 4244
-MD5 eaf3b12b4c06b0f442bd5b2cbd2d9bcc gnocatan-0.8.1.42.ebuild 1065
-MD5 cfd29f58e6f9fb057c83c8eb26c1a101 metadata.xml 315
MD5 084a21f5d1c3f02518347cbf861d24d7 gnocatan-0.8.1.40.ebuild 1064
-MD5 4439665f9974e84f996714ae3c37675c files/digest-gnocatan-0.8.1.42 70
+MD5 cfd29f58e6f9fb057c83c8eb26c1a101 metadata.xml 315
+MD5 eaf3b12b4c06b0f442bd5b2cbd2d9bcc gnocatan-0.8.1.42.ebuild 1065
+MD5 eaf3b12b4c06b0f442bd5b2cbd2d9bcc gnocatan-0.8.1.43.ebuild 1065
MD5 d1fa44b434cf05488027636bb804aa4a files/digest-gnocatan-0.8.1.40 70
+MD5 4439665f9974e84f996714ae3c37675c files/digest-gnocatan-0.8.1.42 70
+MD5 415cec30ed26ddad5a982b2ea47697d4 files/digest-gnocatan-0.8.1.43 70
diff --git a/games-board/gnocatan/files/digest-gnocatan-0.8.1.43 b/games-board/gnocatan/files/digest-gnocatan-0.8.1.43
new file mode 100644
index 000000000000..5a409d18e7c8
--- /dev/null
+++ b/games-board/gnocatan/files/digest-gnocatan-0.8.1.43
@@ -0,0 +1 @@
+MD5 35ce2a71b94287a379a2748fc868e37b gnocatan-0.8.1.43.tar.gz 2059213
diff --git a/games-board/gnocatan/gnocatan-0.8.1.43.ebuild b/games-board/gnocatan/gnocatan-0.8.1.43.ebuild
new file mode 100644
index 000000000000..60d4f10cc077
--- /dev/null
+++ b/games-board/gnocatan/gnocatan-0.8.1.43.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/gnocatan-0.8.1.43.ebuild,v 1.1 2004/11/21 20:39:58 rizzo Exp $
+
+inherit eutils gnome2 debug
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://gnocatan.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnocatan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="nls debug X"
+
+RDEPEND="dev-libs/glib
+ dev-util/pkgconfig
+ X? ( >=gnome-base/libgnomeui-2.6.1.1
+ >=app-text/scrollkeeper-0.3* )"
+
+src_compile() {
+ export G2CONF="${G2CONF} `use_enable nls`"
+ export G2CONF="${G2CONF} `use_enable debug`"
+
+ if use X ; then
+ gnome2_src_compile
+ else
+ einfo
+ einfo "Only building console server"
+ einfo
+
+ econf ${G2CONF} || die "./configure failure"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README COPYING INSTALL TODO NEWS"
+ if use X ; then
+ gnome2_src_install
+ else
+ make DESTDIR=${D} install
+ dodoc ${DOCS}
+ fi
+}