summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-09-21 19:42:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-09-21 19:42:55 +0000
commitad88f5041c83a70241c51945f09eeaf33c0401e7 (patch)
tree9dd66c7d79c354bd15e18c761192e3f2270f20a7 /games-board/freedoko
parentRestrict zlib version, bug 383349 (diff)
downloadgentoo-2-ad88f5041c83a70241c51945f09eeaf33c0401e7.tar.gz
gentoo-2-ad88f5041c83a70241c51945f09eeaf33c0401e7.tar.bz2
gentoo-2-ad88f5041c83a70241c51945f09eeaf33c0401e7.zip
version bump (bug #383681)
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'games-board/freedoko')
-rw-r--r--games-board/freedoko/ChangeLog11
-rw-r--r--games-board/freedoko/files/Fix_Cardset_Make.patch4
-rw-r--r--games-board/freedoko/files/freedoko-0.7.10-gentoo.patch61
-rw-r--r--games-board/freedoko/files/freedoko-0.7.8-gcc45.patch44
-rw-r--r--games-board/freedoko/files/freedoko-0.7.8-gentoo.patch20
-rw-r--r--games-board/freedoko/files/nodoc.patch4
-rw-r--r--games-board/freedoko/files/nonet.patch4
-rw-r--r--games-board/freedoko/files/portage-cxx.patch4
-rw-r--r--games-board/freedoko/freedoko-0.7.10.ebuild85
9 files changed, 194 insertions, 43 deletions
diff --git a/games-board/freedoko/ChangeLog b/games-board/freedoko/ChangeLog
index 03a98c8723bd..a12b2ac2eac9 100644
--- a/games-board/freedoko/ChangeLog
+++ b/games-board/freedoko/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for games-board/freedoko
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/freedoko/ChangeLog,v 1.13 2011/03/29 07:53:22 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/freedoko/ChangeLog,v 1.14 2011/09/21 19:42:55 mr_bones_ Exp $
+
+*freedoko-0.7.10 (21 Sep 2011)
+
+ 21 Sep 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ files/freedoko-0.7.8-gcc45.patch, files/freedoko-0.7.8-gentoo.patch,
+ +freedoko-0.7.10.ebuild, +files/freedoko-0.7.10-gentoo.patch,
+ files/Fix_Cardset_Make.patch, files/nodoc.patch, files/nonet.patch,
+ files/portage-cxx.patch:
+ version bump (bug #383681)
29 Mar 2011; Christoph Mende <angelos@gentoo.org> freedoko-0.7.8.ebuild:
Fixed slot deps
diff --git a/games-board/freedoko/files/Fix_Cardset_Make.patch b/games-board/freedoko/files/Fix_Cardset_Make.patch
index 0f1ddc6bff83..32bdc32885aa 100644
--- a/games-board/freedoko/files/Fix_Cardset_Make.patch
+++ b/games-board/freedoko/files/Fix_Cardset_Make.patch
@@ -1,5 +1,5 @@
---- data/cardsets/Makefile.orig 2006-07-27 10:21:57.000000000 +0200
-+++ data/cardsets/Makefile 2006-07-28 17:30:58.776317496 +0200
+--- data/cardsets/Makefile.orig
++++ data/cardsets/Makefile
@@ -12,8 +12,7 @@
@# In order to add all cardsets to the release
@# uncomment the following line, add a trailing backslash
diff --git a/games-board/freedoko/files/freedoko-0.7.10-gentoo.patch b/games-board/freedoko/files/freedoko-0.7.10-gentoo.patch
new file mode 100644
index 000000000000..fcc47516f50c
--- /dev/null
+++ b/games-board/freedoko/files/freedoko-0.7.10-gentoo.patch
@@ -0,0 +1,61 @@
+--- FreeDoko_0.7.10.orig/src/Makefile
++++ FreeDoko_0.7.10/src/Makefile
+@@ -217,15 +217,7 @@
+ # compile FreeDoko
+ $(PROGRAM) : show_settings objects $(DIRECTORIES)
+ @echo "compiling $(PROGRAM)..."
+-# Gentoo users do want to see the real compile line.
+-# So remove the next five lines (the echo lines)
+-# and remove the '@' in the line after.
+- @echo '$(CXX) $(CXXFLAGS)'
+- @echo ' $$(OBJECTS)'
+- @echo ' $(INCLUDE_ALL)'
+- @echo ' $(LIBS_ALL)'
+- @echo ' -o $@'
+- @$(CXX) $(CXXFLAGS) \
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) \
+ $(OBJECTS_ALL:%.o=$(FREEDOKO_WORKING_DIRECTORY)/%.o) \
+ $(INCLUDE_ALL) \
+ $(LIBS_ALL) \
+--- FreeDoko_0.7.10.orig/src/Makefile.os
++++ FreeDoko_0.7.10/src/Makefile.os
+@@ -1,6 +1,5 @@
+ include $(DEPTH)/../Makefile.os
+
+-include $(DEPTH)/Makefile.local
+ include $(DEPTH)/Makefile.modules
+
+ ifeq ($(OPERATING_SYSTEM), Linux)
+--- FreeDoko_0.7.10.orig/src/Makefile.rules
++++ FreeDoko_0.7.10/src/Makefile.rules
+@@ -80,10 +80,7 @@
+ $(DEPTH)/Makefile.modules \
+ $(DEPTH)/Makefile.local \
+ $(DEPTH)/Makefile.os
+-# Gentoo users do want to see the real compile line.
+-# So remove the next line and remove the '@' in the line after.
+- @echo $(CXX) -c $(SUBDIR)/$<
+- @$(CXX) $(CPPFLAGS) $(CXXFLAGS) $(INCLUDE) $(DEPGEN_FLAGS) -o $@ -c $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(INCLUDE) $(DEPGEN_FLAGS) -o $@ -c $<
+
+
+ -include $(OBJECTS:%.o=$(TARGET_DIR_LOCAL)%.d)
+--- FreeDoko_0.7.10.orig/src/ui/help.cpp
++++ FreeDoko_0.7.10/src/ui/help.cpp
+@@ -152,14 +152,14 @@
+ for (list<string>::const_iterator d = datadir.begin();
+ d != datadir.end();
+ d++)
+- directories.push_back(*d + "/"
++ directories.push_back("/"
+ + ::setting(Setting::MANUAL_DIRECTORY) + "/"
+ + ::translator.token());
+ if (::translator.token() != ::setting(Setting::LANGUAGE))
+ for (list<string>::const_iterator d = datadir.begin();
+ d != datadir.end();
+ d++)
+- directories.push_back(*d + "/"
++ directories.push_back("/"
+ + ::setting(Setting::MANUAL_DIRECTORY) + "/"
+ + ::setting(Setting::LANGUAGE));
+ } // fill the directories list
diff --git a/games-board/freedoko/files/freedoko-0.7.8-gcc45.patch b/games-board/freedoko/files/freedoko-0.7.8-gcc45.patch
index fd7f722c77b3..80bc48a0582e 100644
--- a/games-board/freedoko/files/freedoko-0.7.8-gcc45.patch
+++ b/games-board/freedoko/files/freedoko-0.7.8-gcc45.patch
@@ -1,5 +1,5 @@
---- src/game/gameplay_action.cpp.old 2010-06-01 10:50:55.000000000 +0200
-+++ src/game/gameplay_action.cpp 2010-06-01 10:51:23.000000000 +0200
+--- src/game/gameplay_action.cpp.old
++++ src/game/gameplay_action.cpp
@@ -268,7 +268,7 @@
**
** @version 0.6.8
@@ -9,8 +9,8 @@
GameplayAction::operator=(GameplayAction const& action)
{
this->type = action.type;
---- src/game/gameplay_actions/pure.cpp.old 2010-06-01 10:53:02.000000000 +0200
-+++ src/game/gameplay_actions/pure.cpp 2010-06-01 10:53:54.000000000 +0200
+--- src/game/gameplay_actions/pure.cpp.old
++++ src/game/gameplay_actions/pure.cpp
@@ -90,7 +90,7 @@
**
** @version 0.7.3
@@ -20,8 +20,8 @@
GameplayAction::Pure::operator=(Pure const& action)
{
this->GameplayAction::operator=(action);
---- src/game/gameplay_actions/player1.cpp.old 2010-06-01 10:55:59.000000000 +0200
-+++ src/game/gameplay_actions/player1.cpp 2010-06-01 10:56:10.000000000 +0200
+--- src/game/gameplay_actions/player1.cpp.old
++++ src/game/gameplay_actions/player1.cpp
@@ -103,7 +103,7 @@
**
** @version 0.7.3
@@ -31,8 +31,8 @@
GameplayAction::Player1::operator=(Player1 const& action)
{
this->GameplayAction::operator=(action);
---- src/game/gameplay_actions/base_cards.cpp.old 2010-06-01 10:56:47.000000000 +0200
-+++ src/game/gameplay_actions/base_cards.cpp 2010-06-01 10:56:59.000000000 +0200
+--- src/game/gameplay_actions/base_cards.cpp.old
++++ src/game/gameplay_actions/base_cards.cpp
@@ -142,7 +142,7 @@
**
** @version 0.7.3
@@ -42,8 +42,8 @@
GameplayAction::BaseCards::operator=(BaseCards const& poverty_shift)
{
this->Player1::operator=(poverty_shift);
---- src/game/gameplay_actions/reservation.cpp.old 2010-06-01 10:57:46.000000000 +0200
-+++ src/game/gameplay_actions/reservation.cpp 2010-06-01 10:57:59.000000000 +0200
+--- src/game/gameplay_actions/reservation.cpp.old
++++ src/game/gameplay_actions/reservation.cpp
@@ -110,7 +110,7 @@
**
** @version 0.7.3
@@ -53,8 +53,8 @@
GameplayAction::Reservation::operator=(Reservation const& reservation)
{
this->Player1::operator=(reservation);
---- src/game/gameplay_actions/marriage.cpp.old 2010-06-01 10:58:29.000000000 +0200
-+++ src/game/gameplay_actions/marriage.cpp 2010-06-01 10:58:43.000000000 +0200
+--- src/game/gameplay_actions/marriage.cpp.old
++++ src/game/gameplay_actions/marriage.cpp
@@ -121,7 +121,7 @@
**
** @version 0.7.1
@@ -64,8 +64,8 @@
GameplayAction::Marriage::operator=(Marriage const& marriage)
{
this->Player1::operator=(marriage);
---- src/game/gameplay_actions/genscher.cpp.old 2010-06-01 10:59:12.000000000 +0200
-+++ src/game/gameplay_actions/genscher.cpp 2010-06-01 10:59:22.000000000 +0200
+--- src/game/gameplay_actions/genscher.cpp.old
++++ src/game/gameplay_actions/genscher.cpp
@@ -120,7 +120,7 @@
**
** @version 0.7.1
@@ -75,8 +75,8 @@
GameplayAction::Genscher::operator=(Genscher const& genscher)
{
this->Player1::operator=(genscher);
---- src/game/gameplay_actions/announcement.cpp.old 2010-06-01 10:59:46.000000000 +0200
-+++ src/game/gameplay_actions/announcement.cpp 2010-06-01 10:59:58.000000000 +0200
+--- src/game/gameplay_actions/announcement.cpp.old
++++ src/game/gameplay_actions/announcement.cpp
@@ -132,7 +132,7 @@
**
** @version 0.7.1
@@ -86,8 +86,8 @@
GameplayAction::Announcement::operator=(Announcement const& announcement)
{
this->Player1::operator=(announcement);
---- src/game/gameplay_actions/card_played.cpp.old 2010-06-01 11:00:28.000000000 +0200
-+++ src/game/gameplay_actions/card_played.cpp 2010-06-01 11:00:40.000000000 +0200
+--- src/game/gameplay_actions/card_played.cpp.old
++++ src/game/gameplay_actions/card_played.cpp
@@ -178,7 +178,7 @@
**
** @version 0.7.3
@@ -97,8 +97,8 @@
GameplayAction::CardPlayed::operator=(CardPlayed const& card_played)
{
this->Player1::operator=(card_played);
---- src/game/gameplay_actions/trick_full.cpp.old 2010-06-01 11:01:10.000000000 +0200
-+++ src/game/gameplay_actions/trick_full.cpp 2010-06-01 11:01:20.000000000 +0200
+--- src/game/gameplay_actions/trick_full.cpp.old
++++ src/game/gameplay_actions/trick_full.cpp
@@ -224,7 +224,7 @@
**
** @version 0.7.1
@@ -108,8 +108,8 @@
GameplayAction::TrickFull::operator=(TrickFull const& trick_full)
{
this->GameplayAction::operator=(trick_full);
---- src/game/gameplay_actions/check.cpp.old 2010-06-01 11:01:56.000000000 +0200
-+++ src/game/gameplay_actions/check.cpp 2010-06-01 11:02:07.000000000 +0200
+--- src/game/gameplay_actions/check.cpp.old
++++ src/game/gameplay_actions/check.cpp
@@ -104,7 +104,7 @@
**
** @version 0.7.6
diff --git a/games-board/freedoko/files/freedoko-0.7.8-gentoo.patch b/games-board/freedoko/files/freedoko-0.7.8-gentoo.patch
index cb07df3e7470..98209fdf25ba 100644
--- a/games-board/freedoko/files/freedoko-0.7.8-gentoo.patch
+++ b/games-board/freedoko/files/freedoko-0.7.8-gentoo.patch
@@ -1,6 +1,5 @@
-diff -ru FreeDoko_0.7.8.orig/src/Makefile FreeDoko_0.7.8/src/Makefile
---- FreeDoko_0.7.8.orig/src/Makefile 2010-03-13 14:22:58.000000000 -0500
-+++ FreeDoko_0.7.8/src/Makefile 2010-04-20 12:52:29.294499776 -0400
+--- FreeDoko_0.7.8.orig/src/Makefile
++++ FreeDoko_0.7.8/src/Makefile
@@ -211,15 +211,7 @@
# compile FreeDoko
$(PROGNAME) : show_settings objects $(DIRECTORIES)
@@ -18,9 +17,8 @@ diff -ru FreeDoko_0.7.8.orig/src/Makefile FreeDoko_0.7.8/src/Makefile
$(OBJECTS_ALL:%.o=$(FREEDOKO_WORKING_DIRECTORY)/%.o) \
$(INCLUDE_ALL) \
$(LIBS_ALL) \
-diff -ru FreeDoko_0.7.8.orig/src/Makefile.os FreeDoko_0.7.8/src/Makefile.os
---- FreeDoko_0.7.8.orig/src/Makefile.os 2010-03-13 14:22:58.000000000 -0500
-+++ FreeDoko_0.7.8/src/Makefile.os 2010-04-20 12:52:29.294499776 -0400
+--- FreeDoko_0.7.8.orig/src/Makefile.os
++++ FreeDoko_0.7.8/src/Makefile.os
@@ -1,6 +1,5 @@
include $(DEPTH)/../Makefile.os
@@ -28,9 +26,8 @@ diff -ru FreeDoko_0.7.8.orig/src/Makefile.os FreeDoko_0.7.8/src/Makefile.os
include $(DEPTH)/Makefile.modules
ifeq ($(OPERATING_SYSTEM), Linux)
-diff -ru FreeDoko_0.7.8.orig/src/Makefile.rules FreeDoko_0.7.8/src/Makefile.rules
---- FreeDoko_0.7.8.orig/src/Makefile.rules 2010-03-13 14:22:59.000000000 -0500
-+++ FreeDoko_0.7.8/src/Makefile.rules 2010-04-20 12:52:29.295507223 -0400
+--- FreeDoko_0.7.8.orig/src/Makefile.rules
++++ FreeDoko_0.7.8/src/Makefile.rules
@@ -81,9 +81,7 @@
$(DEPTH)/Makefile.local \
$(DEPTH)/Makefile.os
@@ -42,9 +39,8 @@ diff -ru FreeDoko_0.7.8.orig/src/Makefile.rules FreeDoko_0.7.8/src/Makefile.rule
-include $(OBJECTS:%.o=$(TARGET_DIR_LOCAL)%.d)
-diff -ru FreeDoko_0.7.8.orig/src/ui/help.cpp FreeDoko_0.7.8/src/ui/help.cpp
---- FreeDoko_0.7.8.orig/src/ui/help.cpp 2010-03-13 14:23:02.000000000 -0500
-+++ FreeDoko_0.7.8/src/ui/help.cpp 2010-04-20 13:00:28.862375812 -0400
+--- FreeDoko_0.7.8.orig/src/ui/help.cpp
++++ FreeDoko_0.7.8/src/ui/help.cpp
@@ -142,14 +142,14 @@
for (list<string>::const_iterator d = datadir.begin();
d != datadir.end();
diff --git a/games-board/freedoko/files/nodoc.patch b/games-board/freedoko/files/nodoc.patch
index 3d62d92c6a7d..b3741a3aaf22 100644
--- a/games-board/freedoko/files/nodoc.patch
+++ b/games-board/freedoko/files/nodoc.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2006-08-12 16:26:20.366547794 +0200
-+++ Makefile 2006-08-12 16:26:51.066037961 +0200
+--- Makefile.orig
++++ Makefile
@@ -139,7 +139,6 @@
$(MAKE) Version
cp AUTHORS COPYING ChangeLog README LIESMICH Version release/FreeDoko_$(VERSION)/
diff --git a/games-board/freedoko/files/nonet.patch b/games-board/freedoko/files/nonet.patch
index 4881dc0f68df..1902dd5668bd 100644
--- a/games-board/freedoko/files/nonet.patch
+++ b/games-board/freedoko/files/nonet.patch
@@ -1,5 +1,5 @@
---- src/Makefile.modules.orig 2006-08-12 16:56:49.150314837 +0200
-+++ src/Makefile.modules 2006-08-12 17:15:29.231357349 +0200
+--- src/Makefile.modules.orig
++++ src/Makefile.modules
@@ -11,7 +11,7 @@
# The network code
# It is not necessary for single players
diff --git a/games-board/freedoko/files/portage-cxx.patch b/games-board/freedoko/files/portage-cxx.patch
index 5a3e40e2f084..894b48010e39 100644
--- a/games-board/freedoko/files/portage-cxx.patch
+++ b/games-board/freedoko/files/portage-cxx.patch
@@ -1,5 +1,5 @@
---- src/Makefile.rules.orig 2006-10-05 21:59:41.915041312 +0200
-+++ src/Makefile.rules 2006-10-05 21:59:50.259772720 +0200
+--- src/Makefile.rules.orig
++++ src/Makefile.rules
@@ -5,8 +5,7 @@
$(DEPTH)/Makefile.os
# Gentoo users do want to see the real compile line.
diff --git a/games-board/freedoko/freedoko-0.7.10.ebuild b/games-board/freedoko/freedoko-0.7.10.ebuild
new file mode 100644
index 000000000000..244aed996a8d
--- /dev/null
+++ b/games-board/freedoko/freedoko-0.7.10.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/freedoko/freedoko-0.7.10.ebuild,v 1.1 2011/09/21 19:42:55 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="FreeDoko is a Doppelkopf-game"
+HOMEPAGE="http://free-doko.sourceforge.net"
+SRC_URI="mirror://sourceforge/free-doko/FreeDoko_${PV}.src.zip
+ doc? ( mirror://sourceforge/free-doko/FreeDoko_${PV}.manual.zip )
+ backgrounds? ( mirror://sourceforge/free-doko/backgrounds.zip -> ${PN}-backgrounds.zip )
+ kdecards? ( mirror://sourceforge/free-doko/kdecarddecks.zip )
+ xskatcards? ( mirror://sourceforge/free-doko/xskat.zip )
+ pysolcards? ( mirror://sourceforge/free-doko/pysol.zip )
+ gnomecards? ( mirror://sourceforge/free-doko/gnome-games.zip )
+ openclipartcards? ( mirror://sourceforge/free-doko/openclipart.zip )
+ !xskatcards? (
+ !kdecards? (
+ !gnomecards? (
+ !openclipartcards? (
+ !pysolcards? (
+ mirror://sourceforge/free-doko/xskat.zip ) ) ) ) )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+xskatcards +gnomecards +kdecards +openclipartcards +pysolcards +backgrounds net doc"
+
+RDEPEND="net? ( net-libs/gnet )
+ >=dev-cpp/gtkmm-2.4:2.4"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/FreeDoko_${PV}
+
+src_unpack() {
+ local cards=0
+
+ unpack_cards() {
+ use $1 && { unpack $2 ; cards=$(( $cards + 1 )); };
+ }
+ unpack FreeDoko_${PV}.src.zip
+ use doc && unpack FreeDoko_${PV}.manual.zip
+ cp /dev/null "${S}"/src/Makefile.local
+
+ cd "${S}"/data/cardsets
+
+ unpack_cards xskatcards xskat.zip
+ unpack_cards kdecards kdecarddecks.zip
+ unpack_cards pysolcards pysol.zip
+ unpack_cards gnomecards gnome-games.zip
+ unpack_cards openclipartcards openclipart.zip
+ [ $cards ] || unpack xskat.zip # fall back to xskat
+
+ if use backgrounds ; then
+ cd "${S}"/data/backgrounds
+ unpack ${PN}-backgrounds.zip
+ fi
+}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ export CPPFLAGS="-DPUBLIC_DATA_DIRECTORY_VALUE='\"${GAMES_DATADIR}/${PN}\"'"
+ export CPPFLAGS+=" -DMANUAL_DIRECTORY_VALUE='\"/usr/share/doc/${PF}/html\"'"
+ export OSTYPE=Linux
+ export USE_NETWORK=$(use net && echo true || echo false)
+ export USE_SOUND_ALUT=false # still marked experimental
+ emake Version || die
+ emake -C src FreeDoko || die
+}
+
+src_install() {
+ newgamesbin src/FreeDoko freedoko || die
+ insinto "${GAMES_DATADIR}"/${PN}/
+ doins -r data/{ai,cardsets,backgrounds,rules,sounds,translations,*png} || die
+ find "${D}${GAMES_DATADIR}"/${PN} -name Makefile -delete
+ dodoc AUTHORS README ChangeLog
+ use doc && dohtml -r doc/manual/
+ newicon src/FreeDoko.png ${PN}.png
+ make_desktop_entry ${PN} FreeDoko
+ prepgamesdirs
+}