summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-26 18:30:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-26 18:30:05 +0000
commitde5b2b71201210fdf5f406cf3285f4e6bab41720 (patch)
tree79ab710120de08caf28a06267feb66e868421480 /games-board/crafty
parentTrim old ebuilds and patches. (diff)
downloadgentoo-2-de5b2b71201210fdf5f406cf3285f4e6bab41720.tar.gz
gentoo-2-de5b2b71201210fdf5f406cf3285f4e6bab41720.tar.bz2
gentoo-2-de5b2b71201210fdf5f406cf3285f4e6bab41720.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-board/crafty')
-rw-r--r--games-board/crafty/crafty-20.13.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/games-board/crafty/crafty-20.13.ebuild b/games-board/crafty/crafty-20.13.ebuild
deleted file mode 100644
index f32cd8299447..000000000000
--- a/games-board/crafty/crafty-20.13.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-20.13.ebuild,v 1.4 2008/04/11 15:41:11 wolf31o2 Exp $
-
-inherit flag-o-matic toolchain-funcs games
-
-DESCRIPTION="Bob Hyatt's strong chess engine"
-HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
-SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.zip"
-
-LICENSE="crafty"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE="no-opts"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/-o crafty/s/CC/CXX/' Makefile \
- || die "sed failed"
- sed -i \
- -e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
- || die "sed failed"
-}
-
-src_compile() {
- local makeopts="target=LINUX"
-
- if ! use no-opts ; then
- if [[ $(tc-getCC) = icc ]] ; then
- makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
- append-flags -D_REENTRANT -tpp6 \
- -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
- -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
- -DSMP -DCPUS=4 -DCLONE -DDGT
- append-flags -O2 -fno-alias -fforce-mem \
- -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
- else
- if [[ "${CHOST}" == "i686-pc-linux-gnu" ]] \
- || [[ "${CHOST}" == "i586-pc-linux-gnu" ]] ; then
- append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
- -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
- -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
- append-flags -fforce-mem -fno-gcse \
- -fomit-frame-pointer -mpreferred-stack-boundary=2
- makeopts="${makeopts} CC=gcc CXX=g++ asm=X86.o"
- else
- : # everything else :)
- fi
- fi
- fi
- append-flags -DPOSIX
- emake ${makeopts} crafty-make LDFLAGS="-lpthread" || die "build failed"
-}
-
-src_install() {
- dogamesbin crafty || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}/${PN}"
- doins crafty.hlp || die "doins failed"
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- elog
- elog "Note: No books or tablebases have been installed. If you want them, just"
- elog " download them from ${HOMEPAGE}."
- elog " You will find documentation there too. In most cases you take now "
- elog " your xboard compatible application, (xboard, eboard, knights) and "
- elog " just play chess against computer opponent. Have fun."
- elog
-}