summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-30 06:40:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-30 06:40:38 +0000
commit729306928c9996da49592ebd7b3c306b591ee141 (patch)
treeb654d456663cc6d374d6086361387e06bc242465 /games-board/crafty
parentlook in . first to find db (diff)
downloadgentoo-2-729306928c9996da49592ebd7b3c306b591ee141.tar.gz
gentoo-2-729306928c9996da49592ebd7b3c306b591ee141.tar.bz2
gentoo-2-729306928c9996da49592ebd7b3c306b591ee141.zip
version bump; clean old
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-board/crafty')
-rw-r--r--games-board/crafty/ChangeLog8
-rw-r--r--games-board/crafty/crafty-22.9.ebuild (renamed from games-board/crafty/crafty-22.8.ebuild)6
2 files changed, 9 insertions, 5 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index c27d0ad7671d..c91a5a1b756b 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/crafty
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.32 2009/01/13 01:43:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.33 2009/01/30 06:40:38 mr_bones_ Exp $
+
+*crafty-22.9 (30 Jan 2009)
+
+ 30 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> -crafty-22.8.ebuild,
+ +crafty-22.9.ebuild:
+ version bump; clean old
13 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> crafty-22.8.ebuild:
newer gcc uses -pthread (bug #254689)
diff --git a/games-board/crafty/crafty-22.8.ebuild b/games-board/crafty/crafty-22.9.ebuild
index 3ad39eec541d..3312f8c210ba 100644
--- a/games-board/crafty/crafty-22.8.ebuild
+++ b/games-board/crafty/crafty-22.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-22.8.ebuild,v 1.2 2009/01/13 01:43:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-22.9.ebuild,v 1.1 2009/01/30 06:40:38 mr_bones_ Exp $
inherit flag-o-matic toolchain-funcs games
@@ -37,7 +37,7 @@ src_compile() {
if ! use no-opts ; then
if [[ $(tc-getCC) = icc ]] ; then
- makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
+ makeopts="${makeopts} asm=X86.o"
append-flags -D_REENTRANT -tpp6 \
-DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
-DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
@@ -52,13 +52,11 @@ src_compile() {
-DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
append-flags -fno-gcse \
-fomit-frame-pointer -mpreferred-stack-boundary=2
- makeopts="${makeopts} CC=gcc CXX=g++"
elif [[ "${CHOST}" == "x86_64-pc-linux-gnu" ]] ; then
append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
-DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
-DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
append-flags -fomit-frame-pointer
- makeopts="${makeopts} CC=gcc CXX=g++"
else
: # everything else :)
fi