summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-07-13 22:31:08 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-07-13 22:31:08 +0000
commitb5870d7ce9e92f3d5ece8493260566e6426ad1a3 (patch)
treeec9420e569ee99255f8bd709813f236bd9bf9d41 /games-board/chessdb/chessdb-3.6.18.ebuild
parentAdding games-board/chessdb tb4 use flag (load 4-piece table bases) (diff)
downloadgentoo-2-b5870d7ce9e92f3d5ece8493260566e6426ad1a3.tar.gz
gentoo-2-b5870d7ce9e92f3d5ece8493260566e6426ad1a3.tar.bz2
gentoo-2-b5870d7ce9e92f3d5ece8493260566e6426ad1a3.zip
New package, requested with bug #169841
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-board/chessdb/chessdb-3.6.18.ebuild')
-rw-r--r--games-board/chessdb/chessdb-3.6.18.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/games-board/chessdb/chessdb-3.6.18.ebuild b/games-board/chessdb/chessdb-3.6.18.ebuild
new file mode 100644
index 000000000000..f6b3268da454
--- /dev/null
+++ b/games-board/chessdb/chessdb-3.6.18.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/chessdb/chessdb-3.6.18.ebuild,v 1.1 2007/07/13 22:31:08 tupone Exp $
+
+inherit toolchain-funcs eutils games
+
+MY_PN=ChessDB
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A free Chess Database"
+HOMEPAGE="http://chessdb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
+ tb4? ( mirror://sourceforge/${PN}/4-piece-tablebases.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="tb4"
+
+RDEPEND="dev-lang/tk"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@snack_path@:/usr/lib/snack2.2:" \
+ tcl/start.tcl || die "sed failed"
+}
+
+src_compile() {
+ ./configure BINDIR="${GAMES_BINDIR}" \
+ COMPILE=$(tc-getCXX) \
+ CC=$(tc-getCC) \
+ LINK=$(tc-getCXX) \
+ OPTIMIZE="${CXXFLAGS}" \
+ SHAREDIR="${GAMES_DATADIR}/${PN}" \
+ SOUNDSDIR="${GAMES_DATADIR}/${PN}/sounds" \
+ TBDIR="${GAMES_DATADIR}/${PN}/tablebases" \
+ MANDIR="/usr/share/man" \
+ WARNINGS="" || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use tb4; then
+ insinto "${GAMES_DATADIR}/${PN}"/tablebases
+ doins ../*.emd || die "doins failed"
+ fi
+
+ dodoc BUGS CONTRIBUTORS ChangeLog NEWS README THANKS THANKS.Shane TODO
+ dohtml -r html-help/*
+
+ doicon ${PN}.ico
+ make_desktop_entry ${PN} ChessDB /usr/share/pixmaps/${PN}.ico
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To enable speech, just emerge dev-tcltk/snack"
+}