summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-04-30 22:26:04 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-04-30 22:26:04 +0000
commitc3cad46f161e050b5609919101d94ffc22ec5bbc (patch)
treee8359d90334486863b87eecfbd15d114718448b6 /games-board/blokish
parentstable ppc64, bug 219644 (diff)
downloadgentoo-2-c3cad46f161e050b5609919101d94ffc22ec5bbc.tar.gz
gentoo-2-c3cad46f161e050b5609919101d94ffc22ec5bbc.tar.bz2
gentoo-2-c3cad46f161e050b5609919101d94ffc22ec5bbc.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-board/blokish')
-rw-r--r--games-board/blokish/ChangeLog6
-rw-r--r--games-board/blokish/blokish-0.9.4-r1.ebuild4
-rw-r--r--games-board/blokish/files/blokish-0.9.4-gcc43.patch12
3 files changed, 19 insertions, 3 deletions
diff --git a/games-board/blokish/ChangeLog b/games-board/blokish/ChangeLog
index 44e9a84ab8dd..8dab61e883bf 100644
--- a/games-board/blokish/ChangeLog
+++ b/games-board/blokish/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/blokish
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/ChangeLog,v 1.6 2008/03/18 01:15:38 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/ChangeLog,v 1.7 2008/04/30 22:26:04 nyhm Exp $
+
+ 30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/blokish-0.9.4-gcc43.patch, blokish-0.9.4-r1.ebuild:
+ Fix building with gcc-4.3
*blokish-0.9.4-r1 (18 Mar 2008)
diff --git a/games-board/blokish/blokish-0.9.4-r1.ebuild b/games-board/blokish/blokish-0.9.4-r1.ebuild
index 977e0eea9877..06b1ef13ccc4 100644
--- a/games-board/blokish/blokish-0.9.4-r1.ebuild
+++ b/games-board/blokish/blokish-0.9.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/blokish-0.9.4-r1.ebuild,v 1.1 2008/03/18 01:15:38 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/blokish-0.9.4-r1.ebuild,v 1.2 2008/04/30 22:26:04 nyhm Exp $
inherit eutils wxwidgets games
@@ -27,7 +27,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
-
+ epatch "${FILESDIR}"/${P}-gcc43.patch
sed -i \
-e "s:wx-config:${WX_CONFIG}:" \
configure makefile.in \
diff --git a/games-board/blokish/files/blokish-0.9.4-gcc43.patch b/games-board/blokish/files/blokish-0.9.4-gcc43.patch
new file mode 100644
index 000000000000..3e48bce774d6
--- /dev/null
+++ b/games-board/blokish/files/blokish-0.9.4-gcc43.patch
@@ -0,0 +1,12 @@
+--- src/base.h
++++ src/base.h
+@@ -25,6 +25,9 @@
+ #include <vector>
+ #include <fstream>
+ #include <iostream>
++#include <algorithm>
++#include <cstdlib>
++#include <climits>
+
+ enum BlokishID
+ {