summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-05-06 16:50:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-05-06 16:50:00 +0000
commitd99103b1e28936081248b607e2699ac3237f04ea (patch)
tree416948feb1cb265ec46bc76394fc541094e54a95 /games-board/biloba/biloba-0.9.3.ebuild
parentversion bump (diff)
downloadgentoo-2-d99103b1e28936081248b607e2699ac3237f04ea.tar.gz
gentoo-2-d99103b1e28936081248b607e2699ac3237f04ea.tar.bz2
gentoo-2-d99103b1e28936081248b607e2699ac3237f04ea.zip
version bump
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'games-board/biloba/biloba-0.9.3.ebuild')
-rw-r--r--games-board/biloba/biloba-0.9.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-board/biloba/biloba-0.9.3.ebuild b/games-board/biloba/biloba-0.9.3.ebuild
new file mode 100644
index 000000000000..c97c7420061a
--- /dev/null
+++ b/games-board/biloba/biloba-0.9.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/biloba/biloba-0.9.3.ebuild,v 1.1 2011/05/06 16:50:00 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="a board game, up to 4 players, with AI and network."
+HOMEPAGE="http://biloba.sourceforge.net/"
+SRC_URI="mirror://sourceforge/biloba/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[X,video,audio]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+
+src_prepare() {
+ # X11 headers are checked but not used, everything is done through SDL
+ epatch \
+ "${FILESDIR}"/${P}-not-windows.patch \
+ "${FILESDIR}"/${P}-no-X11-dep.patch
+
+ # "missing" file is old, and warns about --run not being supported
+ rm -f missing
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+ newicon biloba_icon.png ${PN}.png
+ make_desktop_entry biloba Biloba
+ prepgamesdirs
+}