summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-04-25 21:18:45 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-04-25 21:18:45 +0000
commita72cf6b1970e39310f886dbb850f5561289bbe90 (patch)
tree033ce94cefac28d2b1a607ef9c26c8babf14196c /games-board/ace
parentVersion bump, thanks to James in bug #129521 (diff)
downloadgentoo-2-a72cf6b1970e39310f886dbb850f5561289bbe90.tar.gz
gentoo-2-a72cf6b1970e39310f886dbb850f5561289bbe90.tar.bz2
gentoo-2-a72cf6b1970e39310f886dbb850f5561289bbe90.zip
Fix for gcc-4.1
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'games-board/ace')
-rw-r--r--games-board/ace/ChangeLog8
-rw-r--r--games-board/ace/ace-1.2-r1.ebuild7
-rw-r--r--games-board/ace/files/ace-1.2-gcc41.patch73
-rw-r--r--games-board/ace/files/digest-ace-1.2-r12
4 files changed, 85 insertions, 5 deletions
diff --git a/games-board/ace/ChangeLog b/games-board/ace/ChangeLog
index f12ef0704892..12fb37576f6c 100644
--- a/games-board/ace/ChangeLog
+++ b/games-board/ace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/ace
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ChangeLog,v 1.12 2005/12/14 04:10:01 spyderous Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ChangeLog,v 1.13 2006/04/25 21:18:45 tupone Exp $
+
+ 25 Apr 2006; <Tupone@gentoo.org> +files/ace-1.2-gcc41.patch,
+ ace-1.2-r1.ebuild:
+ fix for gcc-4.1
14 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>; ace-1.2-r1.ebuild:
Add modular X dependencies.
diff --git a/games-board/ace/ace-1.2-r1.ebuild b/games-board/ace/ace-1.2-r1.ebuild
index ef4bedcfa924..f9cf3a81966c 100644
--- a/games-board/ace/ace-1.2-r1.ebuild
+++ b/games-board/ace/ace-1.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ace-1.2-r1.ebuild,v 1.15 2005/12/14 04:10:01 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ace-1.2-r1.ebuild,v 1.16 2006/04/25 21:18:45 tupone Exp $
inherit eutils games
@@ -20,7 +20,8 @@ DEPEND="|| ( x11-libs/libXpm virtual/x11 )
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/ace-1.2-check_for_end_of_game.patch
+ epatch "${FILESDIR}/${P}"-check_for_end_of_game.patch \
+ "${FILESDIR}/${P}"-gcc41.patch
# Fix timestamps so we dont run autotools #76473
touch -r aclocal.m4 configure.in
diff --git a/games-board/ace/files/ace-1.2-gcc41.patch b/games-board/ace/files/ace-1.2-gcc41.patch
new file mode 100644
index 000000000000..7d41b67ae067
--- /dev/null
+++ b/games-board/ace/files/ace-1.2-gcc41.patch
@@ -0,0 +1,73 @@
+--- games/golf.c.old 2006-04-25 22:22:15.000000000 +0200
++++ games/golf.c 2006-04-25 22:25:51.000000000 +0200
+@@ -31,7 +31,7 @@
+
+ Stack *deck, *discard, *stacks[7];
+
+-static int table_width, table_height;
++static int _table_width, _table_height;
+
+ int supress_arrows = 0;
+
+@@ -42,10 +42,10 @@
+ {
+ int alt_width = 3*M+2*W+51*R;
+ init_ace(argc, argv);
+- table_width = 8*M+7*W;
+- if (table_width < alt_width) table_width = alt_width;
+- table_height = 3*M+5*CARD_FAN_DOWN+2*H;
+- init_table(table_width, table_height);
++ _table_width = 8*M+7*W;
++ if (_table_width < alt_width) _table_width = alt_width;
++ _table_height = 3*M+5*CARD_FAN_DOWN+2*H;
++ init_table(_table_width, _table_height);
+ table_loop();
+ }
+
+@@ -118,7 +118,7 @@
+ sprintf(s, "%2d", c);
+ else
+ strcpy(s, " ");
+- text(s, M*2, table_height-M-H-2);
++ text(s, M*2, _table_height-M-H-2);
+ }
+
+ void
+@@ -152,9 +152,9 @@
+ {
+ int s, v;
+
+- arrow_offset = (table_width - 7 * W) / 8;
++ arrow_offset = (_table_width - 7 * W) / 8;
+ arrow_delta = arrow_offset + W;
+- arrow_offset = (table_width - 7*W - 6*arrow_offset)/2;
++ arrow_offset = (_table_width - 7*W - 6*arrow_offset)/2;
+
+ stack_load_standard_deck();
+ splash = get_picture("golf");
+@@ -171,8 +171,8 @@
+ stack_set_offset(stacks[s], STACK_OFFSET_DOWN);
+ }
+
+- deck = stack_create(M, table_height-M-H);
+- discard = stack_create(M*2+W, table_height-M-H);
++ deck = stack_create(M, _table_height-M-H);
++ discard = stack_create(M*2+W, _table_height-M-H);
+ stack_set_offset(discard, STACK_OFFSET_TBRIGHT);
+
+ for (s=0; s<4; s++)
+@@ -228,10 +228,10 @@
+ Picture *cp = get_centered_pic();
+
+ if ((cp == youlose || cp == youwin)
+- && (x > table_width/2-cp->w/2
+- && x < table_width/2+cp->w/2
+- && y > table_height/2-cp->h/2
+- && y < table_height/2+cp->h/2))
++ && (x > _table_width/2-cp->w/2
++ && x < _table_width/2+cp->w/2
++ && y > _table_height/2-cp->h/2
++ && y < _table_height/2+cp->h/2))
+ {
+ set_centered_pic(0);
+ start_again();
diff --git a/games-board/ace/files/digest-ace-1.2-r1 b/games-board/ace/files/digest-ace-1.2-r1
index 960427efba6c..dd0d57470b27 100644
--- a/games-board/ace/files/digest-ace-1.2-r1
+++ b/games-board/ace/files/digest-ace-1.2-r1
@@ -1 +1,3 @@
MD5 03e5e7ab8ac3acc59661c6e9c09089b7 ace-1.2.tar.gz 309289
+RMD160 ee3b4c4707dba1eb92d06306157c1188bfba616d ace-1.2.tar.gz 309289
+SHA256 fcda8bca508490bea642c83fcf718565bf4ed4c50f2d7b34761da61fe2e6bc9d ace-1.2.tar.gz 309289