summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-09-24 15:41:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-09-24 15:41:03 +0000
commit5eee431093ff3f21ee0650491255312a5e7c64db (patch)
treec51d02ef4ef5114887cc4e215d746a9991458a25 /games-board/ace
parentVersion bump. (diff)
downloadgentoo-2-5eee431093ff3f21ee0650491255312a5e7c64db.tar.gz
gentoo-2-5eee431093ff3f21ee0650491255312a5e7c64db.tar.bz2
gentoo-2-5eee431093ff3f21ee0650491255312a5e7c64db.zip
version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-board/ace')
-rw-r--r--games-board/ace/ChangeLog10
-rw-r--r--games-board/ace/ace-1.4.ebuild44
-rw-r--r--games-board/ace/files/ace-1.4-libpng15.patch29
-rw-r--r--games-board/ace/files/ace-1.4-no-xpm.patch24
4 files changed, 105 insertions, 2 deletions
diff --git a/games-board/ace/ChangeLog b/games-board/ace/ChangeLog
index 77a91cd460af..f1fc86f56f30 100644
--- a/games-board/ace/ChangeLog
+++ b/games-board/ace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/ace
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ChangeLog,v 1.23 2011/09/15 07:23:31 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ChangeLog,v 1.24 2012/09/24 15:41:03 mr_bones_ Exp $
+
+*ace-1.4 (24 Sep 2012)
+
+ 24 Sep 2012; Michael Sterrett <mr_bones_@gentoo.org> +ace-1.4.ebuild,
+ +files/ace-1.4-libpng15.patch, +files/ace-1.4-no-xpm.patch:
+ version bump
15 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> ace-1.3.ebuild,
+files/ace-1.3-libpng15.patch:
diff --git a/games-board/ace/ace-1.4.ebuild b/games-board/ace/ace-1.4.ebuild
new file mode 100644
index 000000000000..e3f2e0d583be
--- /dev/null
+++ b/games-board/ace/ace-1.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ace-1.4.ebuild,v 1.1 2012/09/24 15:41:03 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="DJ Delorie's Ace of Penguins solitaire games"
+HOMEPAGE="http://www.delorie.com/store/ace/"
+SRC_URI="http://www.delorie.com/store/ace/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ media-libs/libpng"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES=( "${FILESDIR}"/${P}-no-xpm.patch "${FILESDIR}"/${P}-libpng15.patch )
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-static \
+ --program-prefix=ace-
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml docs/*
+ newicon docs/as.gif ${PN}.gif
+ cd "${D}${GAMES_BINDIR}" && {
+ local p
+ for p in *
+ do
+ make_desktop_entry $p "Ace ${p/ace-/}" /usr/share/pixmaps/${PN}.gif
+ done
+ }
+ prepgamesdirs
+}
diff --git a/games-board/ace/files/ace-1.4-libpng15.patch b/games-board/ace/files/ace-1.4-libpng15.patch
new file mode 100644
index 000000000000..f0ec4e9f6359
--- /dev/null
+++ b/games-board/ace/files/ace-1.4-libpng15.patch
@@ -0,0 +1,29 @@
+--- lib/make-imglib.c
++++ lib/make-imglib.c
+@@ -86,7 +86,7 @@
+ png_ptr = png_create_read_struct (PNG_LIBPNG_VER_STRING, 0, 0, 0);
+ info_ptr = png_create_info_struct (png_ptr);
+
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(png_ptr))) {
+ fclose (f);
+ continue;
+ }
+--- lib/xwin.c
++++ lib/xwin.c
+@@ -824,13 +824,13 @@
+ png_ptr = png_create_read_struct (PNG_LIBPNG_VER_STRING, 0, 0, 0);
+ info_ptr = png_create_info_struct (png_ptr);
+
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(png_ptr))) {
+ fprintf(stderr, "Invalid PNG image!\n");
+ return;
+ }
+
+ file_bytes = src->file_data;
+- png_set_read_fn (png_ptr, (voidp)&file_bytes, (png_rw_ptr)png_reader);
++ png_set_read_fn (png_ptr, (png_voidp)&file_bytes, (png_rw_ptr)png_reader);
+
+ png_read_info (png_ptr, info_ptr);
+
diff --git a/games-board/ace/files/ace-1.4-no-xpm.patch b/games-board/ace/files/ace-1.4-no-xpm.patch
new file mode 100644
index 000000000000..25b06754be42
--- /dev/null
+++ b/games-board/ace/files/ace-1.4-no-xpm.patch
@@ -0,0 +1,24 @@
+--- lib/table.c.orig 2008-01-15 15:05:27.000000000 -0500
++++ lib/table.c 2010-09-29 17:34:40.925310980 -0400
+@@ -23,7 +23,6 @@
+ #include <X11/Xutil.h>
+ #include <X11/keysym.h>
+ #include <X11/Xatom.h>
+-#include <X11/xpm.h>
+
+ #define CD printf("%d: %d %d %d %d\n", __LINE__, ex, ey, ew, eh)
+ #undef CD
+@@ -165,13 +164,6 @@
+ xwin_create (width, height);
+ }
+
+-typedef struct PicRec {
+- Pixmap pixmap;
+- Pixmap mask;
+- char **xpm_data;
+- int image_table_index;
+-} PicRec;
+-
+ int get_picture_default_width = CARD_WIDTH;
+ int get_picture_default_height = CARD_HEIGHT;
+