summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-04 20:00:02 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-04 20:00:02 +0000
commit6ea65eaa8c0cd12c61e68f745ca7f4be8e165045 (patch)
tree2742f1d5512535c61d86a179dc64c874333832f6 /games-board/ace/files
parentStable for ia64, wrt bug #449744 (diff)
downloadgentoo-2-6ea65eaa8c0cd12c61e68f745ca7f4be8e165045.tar.gz
gentoo-2-6ea65eaa8c0cd12c61e68f745ca7f4be8e165045.tar.bz2
gentoo-2-6ea65eaa8c0cd12c61e68f745ca7f4be8e165045.zip
fix bug 450164 and bug 450270
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-board/ace/files')
-rw-r--r--games-board/ace/files/ace-1.4-CC.patch17
-rw-r--r--games-board/ace/files/ace-1.4-clang.patch15
2 files changed, 32 insertions, 0 deletions
diff --git a/games-board/ace/files/ace-1.4-CC.patch b/games-board/ace/files/ace-1.4-CC.patch
new file mode 100644
index 000000000000..ec9045d25765
--- /dev/null
+++ b/games-board/ace/files/ace-1.4-CC.patch
@@ -0,0 +1,17 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Jan 4 17:19:04 UTC 2013
+Subject: build system
+
+
+--- ace-1.4/lib/Makefile.am
++++ ace-1.4/lib/Makefile.am
+@@ -25,7 +25,7 @@
+ ./make-imglib -n cards -i $(srcdir)/png -d images.d $(srcdir)/images.in images.c
+
+ make-imglib : make-imglib.c
+- $(BUILD_CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(srcdir)/make-imglib.c -o make-imglib -lpng -lz
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(srcdir)/make-imglib.c -o make-imglib -lpng -lz
+
+ text2c : text2c.c
+- $(BUILD_CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(srcdir)/text2c.c -o text2c -lpng -lz
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(srcdir)/text2c.c -o text2c -lpng -lz
diff --git a/games-board/ace/files/ace-1.4-clang.patch b/games-board/ace/files/ace-1.4-clang.patch
new file mode 100644
index 000000000000..b021efe517de
--- /dev/null
+++ b/games-board/ace/files/ace-1.4-clang.patch
@@ -0,0 +1,15 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Jan 4 17:41:20 UTC 2013
+Subject: fix build with clang
+
+--- ace-1.4/lib/make-imglib.c
++++ ace-1.4/lib/make-imglib.c
+@@ -202,7 +202,7 @@
+ char *rv;
+ if (string) {
+ next = string;
+- return;
++ return 0;
+ }
+ while (*next && !isgraph(*next)) next++;
+ if (!*next) return 0;