summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-05-04 05:10:24 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-05-04 05:10:24 +0000
commiteeea94db52289fadf6576673df949b2a29a745c7 (patch)
tree304f3fe79f1a54e13f60f195ce9e1d6e1c0554a9 /games-arcade
parentForce python2 fixing bug #312233 (diff)
downloadgentoo-2-eeea94db52289fadf6576673df949b2a29a745c7.tar.gz
gentoo-2-eeea94db52289fadf6576673df949b2a29a745c7.tar.bz2
gentoo-2-eeea94db52289fadf6576673df949b2a29a745c7.zip
Force python2 fixing bug #312231
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/bub-n-bros/ChangeLog7
-rw-r--r--games-arcade/bub-n-bros/bub-n-bros-1.6.ebuild28
2 files changed, 21 insertions, 14 deletions
diff --git a/games-arcade/bub-n-bros/ChangeLog b/games-arcade/bub-n-bros/ChangeLog
index fb8b3f3c3991..6c1e577dbe01 100644
--- a/games-arcade/bub-n-bros/ChangeLog
+++ b/games-arcade/bub-n-bros/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/bub-n-bros
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/ChangeLog,v 1.19 2008/06/29 11:03:16 klausman Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/ChangeLog,v 1.20 2010/05/04 05:10:24 tupone Exp $
+
+ 04 May 2010; Tupone Alfredo <tupone@gentoo.org> bub-n-bros-1.6.ebuild:
+ Force python2 fixing bug #312231 by arfrever@gentoo.org
28 Jun 2008; Tobias Klausmann <klausman@gentoo.org> bub-n-bros-1.6.ebuild:
Stable on alpha, bug #227651
diff --git a/games-arcade/bub-n-bros/bub-n-bros-1.6.ebuild b/games-arcade/bub-n-bros/bub-n-bros-1.6.ebuild
index 27f7b6a93fd4..341370dbe2f7 100644
--- a/games-arcade/bub-n-bros/bub-n-bros-1.6.ebuild
+++ b/games-arcade/bub-n-bros/bub-n-bros-1.6.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/bub-n-bros-1.6.ebuild,v 1.5 2008/06/29 11:03:16 klausman Exp $
-
-inherit eutils games
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/bub-n-bros-1.6.ebuild,v 1.6 2010/05/04 05:10:24 tupone Exp $
+EAPI="2"
+PYTHON_DEPEND="2"
+inherit eutils python games
MY_P=${P/-n-}
DESCRIPTION="A multiplayer clone of the famous Bubble Bobble game"
@@ -14,31 +15,35 @@ SLOT="0"
KEYWORDS="alpha amd64 ppc sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND="dev-lang/python"
RDEPEND="dev-python/pygame"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
+src_prepare() {
+ ecvs_clean
epatch \
"${FILESDIR}"/${P}-home.patch \
"${FILESDIR}"/${P}-python25.patch
+ python_convert_shebangs -r 2 .
}
src_compile() {
# Compile the "statesaver" extension module to enable the Clock bonus
cd "${S}"/bubbob
- python setup.py build_ext -i || die
+ $(PYTHON) setup.py build_ext -i || die
# Compile the extension module required for the X Window client
cd "${S}"/display
- python setup.py build_ext -i || die
+ $(PYTHON) setup.py build_ext -i || die
# Build images
cd "${S}"/bubbob/images
- python buildcolors.py || die
+ $(PYTHON) buildcolors.py || die
}
src_install() {
@@ -56,6 +61,5 @@ src_install() {
newicon http2/data/bob.png ${PN}.png
make_desktop_entry bubnbros Bub-n-Bros
- rm -rf $(find "${D}/${dir}" -name CVS -type d)
prepgamesdirs
}