summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-05-04 04:39:17 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-05-04 04:39:17 +0000
commitc016b328d12abdd1f78660d21f5b7f6715c65984 (patch)
tree20e734055814986427e50ed7bc31276f341229f3 /games-arcade
parentold (diff)
downloadgentoo-2-c016b328d12abdd1f78660d21f5b7f6715c65984.tar.gz
gentoo-2-c016b328d12abdd1f78660d21f5b7f6715c65984.tar.bz2
gentoo-2-c016b328d12abdd1f78660d21f5b7f6715c65984.zip
Force python2 fixing bug #312235
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/whichwayisup/ChangeLog7
-rw-r--r--games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild12
2 files changed, 14 insertions, 5 deletions
diff --git a/games-arcade/whichwayisup/ChangeLog b/games-arcade/whichwayisup/ChangeLog
index 3d90a9f4b6a3..55eef362347f 100644
--- a/games-arcade/whichwayisup/ChangeLog
+++ b/games-arcade/whichwayisup/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/whichwayisup
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/ChangeLog,v 1.15 2009/10/26 05:53:21 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/ChangeLog,v 1.16 2010/05/04 04:39:17 tupone Exp $
+
+ 04 May 2010; Tupone Alfredo <tupone@gentoo.org> whichwayisup-0.7.9.ebuild:
+ Force python2 fixing bug #312235 by arfrever@gentoo.org
26 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org>
whichwayisup-0.7.9.ebuild:
diff --git a/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild b/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
index 862bbc1f63f3..b917575113f3 100644
--- a/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
+++ b/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild,v 1.8 2009/10/26 05:53:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild,v 1.9 2010/05/04 04:39:17 tupone Exp $
-NEED_PYTHON="2.4"
+PYTHON_DEPEND="2"
EAPI=2
inherit eutils python games
@@ -22,6 +22,11 @@ RDEPEND=">=dev-python/pygame-1.6"
S=${WORKDIR}/${PN}
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
src_prepare() {
sed -i \
-e "s:libdir\ =\ .*:libdir\ =\ \"$(games_get_libdir)/${PN}\":" \
@@ -32,6 +37,7 @@ src_prepare() {
lib/data.py \
|| die "Changing data path failed"
rm data/pictures/Thumbs.db
+ python_convert_shebangs -r 2 run_game.py
}
src_install() {