summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-03-19 08:11:29 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-03-19 08:11:29 +0000
commit9ce23efadf6965668433d584bb80b77e0c9cd5fd (patch)
tree9ff8685d59ccd06ce39cd98b6fa0607bc4435069 /games-arcade
parentsci-libs/rosetta-db: Version Bump (diff)
downloadgentoo-2-9ce23efadf6965668433d584bb80b77e0c9cd5fd.tar.gz
gentoo-2-9ce23efadf6965668433d584bb80b77e0c9cd5fd.tar.bz2
gentoo-2-9ce23efadf6965668433d584bb80b77e0c9cd5fd.zip
Initial import from lua overlay. Ebuild by Vadim Misbakh-Soloviov <mva AT mva.name>
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/orthorobot/ChangeLog11
-rw-r--r--games-arcade/orthorobot/metadata.xml8
-rw-r--r--games-arcade/orthorobot/orthorobot-0.ebuild50
3 files changed, 69 insertions, 0 deletions
diff --git a/games-arcade/orthorobot/ChangeLog b/games-arcade/orthorobot/ChangeLog
new file mode 100644
index 000000000000..608217c92cd2
--- /dev/null
+++ b/games-arcade/orthorobot/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-arcade/orthorobot
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/orthorobot/ChangeLog,v 1.1 2013/03/19 08:11:29 pinkbyte Exp $
+
+*orthorobot-0 (19 Mar 2013)
+
+ 19 Mar 2013; Sergey Popov <pinkbyte@gentoo.org> +orthorobot-0.ebuild,
+ +metadata.xml:
+ Initial import from lua overlay. Ebuild by Vadim Misbakh-Soloviov <mva AT
+ mva.name>
+
diff --git a/games-arcade/orthorobot/metadata.xml b/games-arcade/orthorobot/metadata.xml
new file mode 100644
index 000000000000..b6b8956cde34
--- /dev/null
+++ b/games-arcade/orthorobot/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-arcade/orthorobot/orthorobot-0.ebuild b/games-arcade/orthorobot/orthorobot-0.ebuild
new file mode 100644
index 000000000000..71e7d78e58c3
--- /dev/null
+++ b/games-arcade/orthorobot/orthorobot-0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/orthorobot/orthorobot-0.ebuild,v 1.1 2013/03/19 08:11:29 pinkbyte Exp $
+
+EAPI="5"
+
+inherit eutils games
+
+DESCRIPTION="Nice perspective based puzzle game, where you flatten the view to move across gaps"
+HOMEPAGE="http://stabyourself.net/orthorobot/"
+SRC_URI="http://stabyourself.net/dl.php?file=${PN}/${PN}-source.zip -> ${P}.zip"
+
+LICENSE="CC-BY-NC-ND-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=games-engines/love-0.8.0"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+ #it is only one .love file (but with crappy name), so we can use asterisk
+ mv *.love "${P}.zip" || die 'mv failed'
+ unpack "./${P}.zip"
+ rm "${P}.zip" || die 'rm failed'
+}
+
+src_prepare() {
+ # fix error on quit
+ sed -i -e 's/love.event.push("q")/love.event.push(fadegoal)/' menu.lua || die 'sed failed'
+
+ epatch_user
+}
+
+src_install() {
+ local dir="${GAMES_DATADIR}/love/${PN}"
+ insinto "${dir}"
+ doins -r .
+ games_make_wrapper "${PN}" "love ${dir}"
+ make_desktop_entry "${PN}"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ elog "${PN} savegames and configurations are stored in:"
+ elog "~/.local/share/love/${PN}/"
+}