summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-13 17:15:44 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-13 17:15:44 +0000
commit9c2ae6877a7f86de42aea51a895b7dbc845190a7 (patch)
treebd6839c9747f8fd44dc27ef530b0d459e382af90 /games-arcade
parentFix building with glibc-2.10, bug #273402 (diff)
downloadgentoo-2-9c2ae6877a7f86de42aea51a895b7dbc845190a7.tar.gz
gentoo-2-9c2ae6877a7f86de42aea51a895b7dbc845190a7.tar.bz2
gentoo-2-9c2ae6877a7f86de42aea51a895b7dbc845190a7.zip
Fix building with glibc-2.10, bug #273409
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/openbubbles/ChangeLog8
-rw-r--r--games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch20
-rw-r--r--games-arcade/openbubbles/openbubbles-1.2.ebuild7
3 files changed, 31 insertions, 4 deletions
diff --git a/games-arcade/openbubbles/ChangeLog b/games-arcade/openbubbles/ChangeLog
index fa514ae9a37c..7bd8fcdb146e 100644
--- a/games-arcade/openbubbles/ChangeLog
+++ b/games-arcade/openbubbles/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/openbubbles
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/openbubbles/ChangeLog,v 1.7 2008/09/16 22:43:52 jer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/openbubbles/ChangeLog,v 1.8 2009/06/13 17:15:44 nyhm Exp $
+
+ 13 Jun 2009; Tristan Heaven <nyhm@gentoo.org> openbubbles-1.2.ebuild,
+ +files/openbubbles-1.2-glibc2.10.patch:
+ Fix building with glibc-2.10, bug #273409
16 Sep 2008; Jeroen Roovers <jer@gentoo.org> openbubbles-1.2.ebuild:
Marked ~hppa too.
diff --git a/games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch b/games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch
new file mode 100644
index 000000000000..d511734da28f
--- /dev/null
+++ b/games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch
@@ -0,0 +1,20 @@
+--- src/BFont.cpp
++++ src/BFont.cpp
+@@ -319,7 +319,7 @@
+ int i = 0;
+
+ /* Calculate the space occupied by the text without spaces */
+- while ((p=strchr(&text[pos+1],SPACE)) != NULL) {
++ while ((p=strchr((char *)&text[pos+1],SPACE)) != NULL) {
+ i++;
+ pos = p - text;
+ }
+@@ -359,7 +359,7 @@
+ xpos=0;
+ pos = -1;
+ while ( spaces > 0 ) {
+- p = strstr(&text[pos+1]," ");
++ p = strstr((char *)&text[pos+1]," ");
+ strtmp = NULL;
+ strtmp = (char *) calloc ((p - &text[pos+1]) + 1,sizeof(char));
+ if (strtmp != NULL)
diff --git a/games-arcade/openbubbles/openbubbles-1.2.ebuild b/games-arcade/openbubbles/openbubbles-1.2.ebuild
index 5c6b45265486..c384cfb33317 100644
--- a/games-arcade/openbubbles/openbubbles-1.2.ebuild
+++ b/games-arcade/openbubbles/openbubbles-1.2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/openbubbles/openbubbles-1.2.ebuild,v 1.6 2008/09/16 22:43:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/openbubbles/openbubbles-1.2.ebuild,v 1.7 2009/06/13 17:15:44 nyhm Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="A clone of Evan Bailey's game Bubbles"
@@ -17,6 +18,8 @@ DEPEND="media-libs/libsdl
media-libs/sdl-image
media-libs/sdl-gfx"
+PATCHES=( "${FILESDIR}"/${P}-glibc2.10.patch )
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README