summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-02 13:26:38 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-02 13:26:38 +0000
commit9a27614493ba362b247b3de759684392fcb26571 (patch)
tree1cfe90c011f645fb783e52282fc1395313b6474b /games-arcade
parentpatch for 2.6.28 thanks to Jérôme Poulin in bug #257335 (diff)
downloadgentoo-2-9a27614493ba362b247b3de759684392fcb26571.tar.gz
gentoo-2-9a27614493ba362b247b3de759684392fcb26571.tar.bz2
gentoo-2-9a27614493ba362b247b3de759684392fcb26571.zip
Fix --as-needed bug #247331
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/xgalaga/ChangeLog8
-rw-r--r--games-arcade/xgalaga/files/xgalaga-2.0.34-as-needed.patch11
-rw-r--r--games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild14
3 files changed, 23 insertions, 10 deletions
diff --git a/games-arcade/xgalaga/ChangeLog b/games-arcade/xgalaga/ChangeLog
index e6f466a8860b..5ee763add74e 100644
--- a/games-arcade/xgalaga/ChangeLog
+++ b/games-arcade/xgalaga/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/xgalaga
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xgalaga/ChangeLog,v 1.12 2008/12/18 21:30:29 darkside Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xgalaga/ChangeLog,v 1.13 2009/02/02 13:26:38 tupone Exp $
+
+ 02 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/xgalaga-2.0.34-as-needed.patch, xgalaga-2.0.34-r6.ebuild:
+ Fix --as-needed bug #247331 by flameeyes@gentoo.org
18 Dec 2008; Jeremy Olexa <darkside@gentoo.org> xgalaga-2.0.34-r6.ebuild:
(non maintainer commit) games-arcade/xgalaga doesn't build with --as-needed,
diff --git a/games-arcade/xgalaga/files/xgalaga-2.0.34-as-needed.patch b/games-arcade/xgalaga/files/xgalaga-2.0.34-as-needed.patch
new file mode 100644
index 000000000000..530cc6711eaf
--- /dev/null
+++ b/games-arcade/xgalaga/files/xgalaga-2.0.34-as-needed.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.old 2009-02-02 14:25:06.000000000 +0100
++++ Makefile.in 2009-02-02 14:25:34.000000000 +0100
+@@ -26,7 +26,7 @@
+ CC = @CC@
+ CFLAGS = -I. @CFLAGS@ @DEFS@ @X_CFLAGS@ -DXGALAGADIR=\"@prefix@/\" $(SOUNDDEFS)
+ LDFLAGS = @LDFLAGS@
+-LIBS = @LIBS@ libsprite/libsprite.a @X_LIBS@
++LIBS = libsprite/libsprite.a @LIBS@ @X_LIBS@
+ INSTALL = @INSTALL@
+
+ OBJS = main.o images.o data.o paths.o pathfile.o title.o explosions.o \
diff --git a/games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild b/games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild
index a2cb7b3ab7c6..a3969781df8e 100644
--- a/games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild
+++ b/games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild,v 1.7 2008/12/18 22:37:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild,v 1.8 2009/02/02 13:26:38 tupone Exp $
-inherit eutils flag-o-matic games
+EAPI=2
+inherit eutils games
DEB_VER=30
DESCRIPTION="A Galaga clone with additional features"
@@ -23,9 +24,7 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-proto/xproto"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-xpaths.patch #79496
epatch "${WORKDIR}"/${PN}_${PV}-${DEB_VER}.diff
sed -i \
@@ -35,11 +34,10 @@ src_unpack() {
sed -i \
-e '/SOUNDDEFS/ s:@prefix@:@prefix@/bin:' Makefile.in \
|| die "sed Makefile.in failed"
- append-ldflags -Wl,--no-as-needed #247331
+ epatch "${FILESDIR}"/${P}-as-needed.patch
}
src_compile() {
- egamesconf || die
emake CPPFLAGS="-D__NO_STRING_INLINES" || die "emake failed"
}