summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-14 17:12:05 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-14 17:12:05 +0000
commit91172095977a195bce02a9939ebc2b01698b6d53 (patch)
tree2703f7b9c458b03f8c40c7dba91c7663bca2098e /games-arcade
parentVersion bumped. (diff)
downloadgentoo-2-91172095977a195bce02a9939ebc2b01698b6d53.tar.gz
gentoo-2-91172095977a195bce02a9939ebc2b01698b6d53.tar.bz2
gentoo-2-91172095977a195bce02a9939ebc2b01698b6d53.zip
initial ebuild
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/gunocide2ex/ChangeLog8
-rw-r--r--games-arcade/gunocide2ex/files/1.0-gcc3.patch10
-rw-r--r--games-arcade/gunocide2ex/files/digest-gunocide2ex-1.02
-rw-r--r--games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild58
4 files changed, 78 insertions, 0 deletions
diff --git a/games-arcade/gunocide2ex/ChangeLog b/games-arcade/gunocide2ex/ChangeLog
new file mode 100644
index 000000000000..bc19f818e67d
--- /dev/null
+++ b/games-arcade/gunocide2ex/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-arcade/gunocide2ex
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/ChangeLog,v 1.1 2003/11/14 17:12:05 vapier Exp $
+
+*gunocide2ex-1.0 (14 Nov 2003)
+
+ 14 Nov 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-arcade/gunocide2ex/files/1.0-gcc3.patch b/games-arcade/gunocide2ex/files/1.0-gcc3.patch
new file mode 100644
index 000000000000..570edbfe9de7
--- /dev/null
+++ b/games-arcade/gunocide2ex/files/1.0-gcc3.patch
@@ -0,0 +1,10 @@
+--- src/mmgr.cpp.orig 2003-11-14 11:19:51.184688368 -0500
++++ src/mmgr.cpp 2003-11-14 11:19:59.107483920 -0500
+@@ -59,6 +59,7 @@
+ #include <time.h>
+ #include <stdarg.h>
+ #include <new>
++using namespace std;
+
+ #ifndef WIN32
+ #include <unistd.h>
diff --git a/games-arcade/gunocide2ex/files/digest-gunocide2ex-1.0 b/games-arcade/gunocide2ex/files/digest-gunocide2ex-1.0
new file mode 100644
index 000000000000..978cbe13a31f
--- /dev/null
+++ b/games-arcade/gunocide2ex/files/digest-gunocide2ex-1.0
@@ -0,0 +1,2 @@
+MD5 bb80de22aa8bf5d8a6a4056249b104c8 g2ex_source.zip 74978
+MD5 f247b651937b090b90e6e6dd748e0e36 g2ex-setup.run 30844481
diff --git a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
new file mode 100644
index 000000000000..6004a80d71be
--- /dev/null
+++ b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.1 2003/11/14 17:12:05 vapier Exp $
+
+inherit games eutils gcc
+
+DESCRIPTION="fast-paced 2D shoot'em'up"
+HOMEPAGE="http://www.polyfrag.com/content/product_gunocide.html"
+SRC_URI="mirror://sourceforge/g2ex/g2ex-setup.run"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself
+ sed -i "s:-g:${CFLAGS}:" makefile
+ mkdir binary
+ epatch ${FILESDIR}/${PV}-gcc3.patch
+ edos2unix config.cfg
+ sed -i \
+ -e "s:/usr/local/games/gunocide2ex/config\.cfg:${GAMES_SYSCONFDIR}/${PN}.cfg:" \
+ -e "s:/usr/local/games/gunocide2ex/hscore\.dat:${GAMES_STATEDIR}/${PN}-hscore.dat:" \
+ src/*.{h,cpp}
+ sed -i \
+ -e "s:/usr/local/games:${GAMES_DATADIR}:" \
+ src/*.{h,cpp} `find gfx -name '*.txt'`
+}
+
+src_compile() {
+ cd src
+ local cc=$(gcc-getCXX)
+ for f in *.cpp ; do
+ echo "${cc} ${CFLAGS} ${f}"
+ ${cc} ${cflags} -c ${f} || die "couldnt compile ${f}"
+ done
+ ${cc} -o ${PN} *.o -lpthread -lSDL -lSDL_ttf -lSDL_mixer || die "couldnt produce binary"
+}
+
+src_install() {
+ dogamesbin src/${PN}
+ dosym ${PN} ${GAMES_BINDIR}/g2ex
+ dodir ${GAMES_DATADIR}/${PN}
+ cp -r gfx sfx lvl credits arial.ttf ${D}/${GAMES_DATADIR}/${PN}/
+ insinto ${GAMES_SYSCONFDIR}
+ newins config.cfg ${PN}.cfg
+ insinto ${GAMES_STATEDIR}
+ newins hscore.dat ${PN}-hscore.dat
+ dodoc README history doc/MANUAL_DE
+ dohtml doc/manual_de.html
+ prepgamesdirs
+}