summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-09-17 23:30:33 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-09-17 23:30:33 +0000
commit70cf767d61edd7c02ac2409578d5466bf95c2aa7 (patch)
tree7ddc33564ad6d38b2181b2a8b5099947723c7449 /games-arcade
parentversion update (Manifest recommit) (diff)
downloadgentoo-2-70cf767d61edd7c02ac2409578d5466bf95c2aa7.tar.gz
gentoo-2-70cf767d61edd7c02ac2409578d5466bf95c2aa7.tar.bz2
gentoo-2-70cf767d61edd7c02ac2409578d5466bf95c2aa7.zip
Initial import. Ebuild submitted to bug #62537 by Lars Diesselberg <larsdiesselberg@gmx.de>. Closing bug #62537.
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/xpilot-ng/ChangeLog10
-rw-r--r--games-arcade/xpilot-ng/files/digest-xpilot-ng-4.6.61
-rw-r--r--games-arcade/xpilot-ng/metadata.xml5
-rw-r--r--games-arcade/xpilot-ng/xpilot-ng-4.6.6.ebuild41
4 files changed, 57 insertions, 0 deletions
diff --git a/games-arcade/xpilot-ng/ChangeLog b/games-arcade/xpilot-ng/ChangeLog
new file mode 100644
index 000000000000..0de80e3f08f1
--- /dev/null
+++ b/games-arcade/xpilot-ng/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-arcade/xpilot-ng
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xpilot-ng/ChangeLog,v 1.1 2004/09/17 23:30:33 wolf31o2 Exp $
+
+*xpilot-ng-4.6.6 (17 Sep 2004)
+
+ 17 Sep 2004; Chris Gianelloni <wolf31o2@gentoo.org> +xpilot-ng-4.6.6.ebuild:
+ Initial import. Ebuild submitted to bug #62537 by Lars Diesselberg
+ <larsdiesselberg@gmx.de>. Closing bug #62537.
+
diff --git a/games-arcade/xpilot-ng/files/digest-xpilot-ng-4.6.6 b/games-arcade/xpilot-ng/files/digest-xpilot-ng-4.6.6
new file mode 100644
index 000000000000..052b530d127d
--- /dev/null
+++ b/games-arcade/xpilot-ng/files/digest-xpilot-ng-4.6.6
@@ -0,0 +1 @@
+MD5 785278551aa85356b44f907be1052bc3 xpilot-ng-4.6.6.tar.gz 2231395
diff --git a/games-arcade/xpilot-ng/metadata.xml b/games-arcade/xpilot-ng/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/xpilot-ng/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/xpilot-ng/xpilot-ng-4.6.6.ebuild b/games-arcade/xpilot-ng/xpilot-ng-4.6.6.ebuild
new file mode 100644
index 000000000000..02ed7b7036ef
--- /dev/null
+++ b/games-arcade/xpilot-ng/xpilot-ng-4.6.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xpilot-ng/xpilot-ng-4.6.6.ebuild,v 1.1 2004/09/17 23:30:33 wolf31o2 Exp $
+
+inherit games
+
+DESCRIPTION="Improvement of the multiplayer space game XPilot"
+HOMEPAGE="http://xpilot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xpilot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="openal sdl"
+
+DEPEND="virtual/x11
+ >=dev-libs/expat-1.1
+ >=sys-libs/zlib-1.1.3
+ openal? ( media-libs/openal )
+ sdl? (
+ virtual/opengl
+ >=media-libs/libsdl-1.2.0
+ >=media-libs/sdl-image-1.0
+ >=media-libs/sdl-ttf-2.0 )"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable sdl sdl-client) \
+ $(use_enable openal sound) \
+ || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+ prepgamesdirs
+}
+