summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-11-30 19:54:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-11-30 19:54:03 +0000
commit70b5fa261ab1874656a2dbca062de028a226d78b (patch)
treed633a6db91a4a501456faade1070c787c7734bf6 /games-arcade
parentDrop mask for no longer existant portage version (diff)
downloadgentoo-2-70b5fa261ab1874656a2dbca062de028a226d78b.tar.gz
gentoo-2-70b5fa261ab1874656a2dbca062de028a226d78b.tar.bz2
gentoo-2-70b5fa261ab1874656a2dbca062de028a226d78b.zip
version bump
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/slimevolley/ChangeLog8
-rw-r--r--games-arcade/slimevolley/files/slimevolley-2.4.2-nodatalocal.patch23
-rw-r--r--games-arcade/slimevolley/slimevolley-2.4.2.ebuild47
3 files changed, 77 insertions, 1 deletions
diff --git a/games-arcade/slimevolley/ChangeLog b/games-arcade/slimevolley/ChangeLog
index be1b00c34060..f85a43820fe9 100644
--- a/games-arcade/slimevolley/ChangeLog
+++ b/games-arcade/slimevolley/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/slimevolley
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/slimevolley/ChangeLog,v 1.6 2010/06/21 20:13:00 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/slimevolley/ChangeLog,v 1.7 2010/11/30 19:54:03 mr_bones_ Exp $
+
+*slimevolley-2.4.2 (30 Nov 2010)
+
+ 30 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +slimevolley-2.4.2.ebuild, +files/slimevolley-2.4.2-nodatalocal.patch:
+ version bump
21 Jun 2010; Markus Meier <maekke@gentoo.org> slimevolley-2.4.1-r1.ebuild:
amd64/x86 stable, bug #322807
diff --git a/games-arcade/slimevolley/files/slimevolley-2.4.2-nodatalocal.patch b/games-arcade/slimevolley/files/slimevolley-2.4.2-nodatalocal.patch
new file mode 100644
index 000000000000..a1ab7616a645
--- /dev/null
+++ b/games-arcade/slimevolley/files/slimevolley-2.4.2-nodatalocal.patch
@@ -0,0 +1,23 @@
+diff -ru slimevolley-2.4.1.orig/src/themes_std.c slimevolley-2.4.1/src/themes_std.c
+--- slimevolley-2.4.1.orig/src/themes_std.c 2008-11-30 04:36:52.000000000 -0500
++++ slimevolley-2.4.1/src/themes_std.c 2010-05-05 13:00:23.875723904 -0400
+@@ -30,7 +30,6 @@
+ #include "audio.h"
+ #include "themes.h"
+
+-#define DATA_LOCAL "data"
+ #define DOSS_THEMES "themes"
+ #define DOSS_SLIMES "slimes"
+ #define SLIME_D_NOM "slimeJD%d.png"
+@@ -74,10 +73,7 @@
+ chemin[0] = '\0';
+
+ if(var_env == NULL) {
+- if(access(DATA_LOCAL, R_OK | X_OK) == 0) {
+- strncpy(chemin, DATA_LOCAL, sizeof(chemin) - 1);
+-
+- } else if(access(DATA_DIR, R_OK | X_OK) == 0) {
++ if(access(DATA_DIR, R_OK | X_OK) == 0) {
+ strncpy(chemin, DATA_DIR, sizeof(chemin) - 1);
+ }
+
diff --git a/games-arcade/slimevolley/slimevolley-2.4.2.ebuild b/games-arcade/slimevolley/slimevolley-2.4.2.ebuild
new file mode 100644
index 000000000000..37df02d2fc20
--- /dev/null
+++ b/games-arcade/slimevolley/slimevolley-2.4.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/slimevolley/slimevolley-2.4.2.ebuild,v 1.1 2010/11/30 19:54:03 mr_bones_ Exp $
+
+EAPI=2
+inherit cmake-utils eutils games
+
+DESCRIPTION="A simple volleyball game"
+HOMEPAGE="http://slime.tuxfamily.org/index.php"
+SRC_URI="http://downloads.tuxfamily.org/slime/v242/${PN}_${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="net"
+
+RDEPEND="media-libs/libsdl[X,audio,video]
+ media-libs/sdl-ttf
+ media-libs/sdl-image[png]
+ net? ( media-libs/sdl-net )
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+DOCS="docs/README docs/TODO"
+
+PATCHES=( "${FILESDIR}"/${P}-nodatalocal.patch ) # bug #318005
+
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ mycmakeargs=(
+ "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
+ "-DBIN_DIR=${GAMES_BINDIR}"
+ $(use net && echo "-DNO_NET=0" || echo "-DNO_NET=1")
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}