summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-09-09 05:59:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-09-09 05:59:14 +0000
commit6cbdc0acb1184de6059e82dbecdb2e7aaaf9db52 (patch)
tree508647905ec11dbeb126af55ad0a81524b0e417f /games-arcade
parentMarked ppc/ppc64 stable for bug #189863. (diff)
downloadgentoo-2-6cbdc0acb1184de6059e82dbecdb2e7aaaf9db52.tar.gz
gentoo-2-6cbdc0acb1184de6059e82dbecdb2e7aaaf9db52.tar.bz2
gentoo-2-6cbdc0acb1184de6059e82dbecdb2e7aaaf9db52.zip
version bump (bug #191714) with patch update from Tomasz Mon
(Portage version: 2.1.2.12)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/bub-n-bros/ChangeLog9
-rw-r--r--games-arcade/bub-n-bros/bub-n-bros-1.6.ebuild61
-rw-r--r--games-arcade/bub-n-bros/files/bub-n-bros-1.6-home.patch51
-rw-r--r--games-arcade/bub-n-bros/files/bub-n-bros-1.6-python25.patch33
-rw-r--r--games-arcade/bub-n-bros/files/digest-bub-n-bros-1.63
5 files changed, 156 insertions, 1 deletions
diff --git a/games-arcade/bub-n-bros/ChangeLog b/games-arcade/bub-n-bros/ChangeLog
index 09ce60dff344..506c196e9adb 100644
--- a/games-arcade/bub-n-bros/ChangeLog
+++ b/games-arcade/bub-n-bros/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-arcade/bub-n-bros
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/ChangeLog,v 1.14 2007/08/13 19:14:10 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/ChangeLog,v 1.15 2007/09/09 05:59:13 mr_bones_ Exp $
+
+*bub-n-bros-1.6 (09 Sep 2007)
+
+ 09 Sep 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/bub-n-bros-1.6-home.patch, +files/bub-n-bros-1.6-python25.patch,
+ +bub-n-bros-1.6.ebuild:
+ version bump (bug #191714) with patch update from Tomasz Mon
13 Aug 2007; Santiago M. Mola <coldwind@gentoo.org>
+files/bub-n-bros-1.5-python25.patch, bub-n-bros-1.5.ebuild:
diff --git a/games-arcade/bub-n-bros/bub-n-bros-1.6.ebuild b/games-arcade/bub-n-bros/bub-n-bros-1.6.ebuild
new file mode 100644
index 000000000000..9cfc33ff292a
--- /dev/null
+++ b/games-arcade/bub-n-bros/bub-n-bros-1.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/bub-n-bros-1.6.ebuild,v 1.1 2007/09/09 05:59:13 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P=${P/-n-}
+DESCRIPTION="A multiplayer clone of the famous Bubble Bobble game"
+HOMEPAGE="http://bub-n-bros.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="dev-python/pygame"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-home.patch \
+ "${FILESDIR}"/${P}-python25.patch
+}
+
+src_compile() {
+ # Compile the "statesaver" extension module to enable the Clock bonus
+ cd "${S}"/bubbob
+ python setup.py build_ext -i || die
+
+ # Compile the extension module required for the X Window client
+ cd "${S}"/display
+ python setup.py build_ext -i || die
+
+ # Build images
+ cd "${S}"/bubbob/images
+ python buildcolors.py || die
+}
+
+src_install() {
+ local dir=$(games_get_libdir)/${PN}
+
+ exeinto "${dir}"
+ doexe *.py || die "doexe failed"
+
+ insinto "${dir}"
+ doins -r bubbob common display java http2 metaserver || die "doins failed"
+
+ dodir "${GAMES_BINDIR}"
+ dosym "${dir}"/BubBob.py "${GAMES_BINDIR}"/bubnbros || die "dosym failed"
+
+ newicon http2/data/bob.png ${PN}.png
+ make_desktop_entry bubnbros Bub-n-Bros
+
+ rm -rf $(find "${D}/${dir}" -name CVS -type d)
+ prepgamesdirs
+}
diff --git a/games-arcade/bub-n-bros/files/bub-n-bros-1.6-home.patch b/games-arcade/bub-n-bros/files/bub-n-bros-1.6-home.patch
new file mode 100644
index 000000000000..4d2cc317aba3
--- /dev/null
+++ b/games-arcade/bub-n-bros/files/bub-n-bros-1.6-home.patch
@@ -0,0 +1,51 @@
+--- bubbob/images.py 2007-09-08 17:03:41.000000000 +0200
++++ bubbob/images.py 2007-09-08 17:57:45.000000000 +0200
+@@ -454,7 +454,6 @@
+ # check and maybe regenerate the colored image files
+ file = os.path.join('images', 'buildcolors.py')
+ g = {'__name__': '__auto__', '__file__': file}
+- execfile(file, g)
+ # replace the entries 'filename_%d.ppm' by a family of entries,
+ # one for each color
+ sprmap = {}
+--- display/pclient.py 2007-09-08 17:03:41.000000000 +0200
++++ display/pclient.py 2007-09-08 17:57:45.000000000 +0200
+@@ -162,8 +162,8 @@
+ if mode[-1].has_key('cfgfile'):
+ self.trackcfgfile = mode[-1]['cfgfile']
+ else:
+- self.trackcfgfile = os.path.join(DataChunk.SOURCEDIR,
+- 'http2', 'config.txt')
++ self.trackcfgfile = os.path.join(os.environ.get('HOME'),
++ '.bubnbros')
+ self.udpsock = None
+ self.udpsock_low = None
+ self.udpsock2 = None
+--- http2/httppages.py 2007-09-08 17:03:41.000000000 +0200
++++ http2/httppages.py 2007-09-08 17:57:45.000000000 +0200
+@@ -38,7 +38,7 @@
+
+
+ class PageServer:
+- CONFIGFILE = 'config.txt'
++ CONFIGFILE = '.bubnbros'
+ localservers = None
+
+ def __init__(self, Game):
+@@ -46,7 +46,7 @@
+ self.seed = hex(random.randrange(0x1000, 0x10000))
+ #self.unique_actions = {}
+ self.localhost = gamesrv.HOSTNAME
+- self.filename = os.path.join(LOCALDIR, self.CONFIGFILE)
++ self.filename = os.path.join(os.environ.get('HOME'), self.CONFIGFILE)
+ data = self.loadoptionfile()
+ self.globaloptions = Options(data.get('*', {}))
+ self.localoptions = Options(data.get(self.localhost, {}))
+@@ -333,7 +333,6 @@
+ 'buildcolors.py')
+ if os.path.exists(file):
+ g = {'__name__': '__auto__', '__file__': file}
+- execfile(file, g)
+
+ if port:
+ address = '%s:%s' % (host, port)
diff --git a/games-arcade/bub-n-bros/files/bub-n-bros-1.6-python25.patch b/games-arcade/bub-n-bros/files/bub-n-bros-1.6-python25.patch
new file mode 100644
index 000000000000..d681f31ae850
--- /dev/null
+++ b/games-arcade/bub-n-bros/files/bub-n-bros-1.6-python25.patch
@@ -0,0 +1,33 @@
+diff -ur bubbros-1.5.orig/bubbob/statesaver.c bubbros-1.5/bubbob/statesaver.c
+--- bubbros-1.5.orig/bubbob/statesaver.c 2007-09-08 17:43:14.000000000 +0200
++++ bubbros-1.5/bubbob/statesaver.c 2007-09-08 17:43:14.000000000 +0200
+@@ -75,7 +75,7 @@
+ Py_INCREF(g); /* exhausted -- can return 'g' itself */
+ return g;
+ }
+- if (f->f_nfreevars || f->f_ncells) {
++ if (PySequence_Length(co->co_freevars) || PySequence_Length(co->co_cellvars)) {
+ PyErr_SetString(PyExc_ValueError, "generator has cell or free vars");
+ goto error;
+ }
+@@ -112,6 +112,8 @@
+ PyFrameObject* f = NULL;
+ PyFrameObject* f2 = NULL;
+ PyCodeObject* co;
++ PyCodeObject* code;
++ PyCodeObject* code2;
+ int i, res;
+
+ if (g != g2)
+@@ -141,9 +143,9 @@
+ Py_DECREF(x);
+ goto error;
+ }
+- f2 = (PyFrameObject*) x;
+
+- if (f2->f_stacksize != f->f_stacksize) {
++ code2 = (PyFrameObject*) x;
++ if (code2->co_stacksize != code->co_stacksize) {
+ PyErr_SetString(PyExc_TypeError, "stack size mismatch");
+ goto error;
+ }
diff --git a/games-arcade/bub-n-bros/files/digest-bub-n-bros-1.6 b/games-arcade/bub-n-bros/files/digest-bub-n-bros-1.6
new file mode 100644
index 000000000000..e3c55d552aa1
--- /dev/null
+++ b/games-arcade/bub-n-bros/files/digest-bub-n-bros-1.6
@@ -0,0 +1,3 @@
+MD5 00aa5e26f5f0ed4c10765e4b33b28a09 bubbros-1.6.tar.bz2 9052959
+RMD160 f4da90058650f07f4c50d33dd9b42be336c660df bubbros-1.6.tar.bz2 9052959
+SHA256 dd197e60a23e09800010f3a5906feb77847e6eeaa7cfd47d803a85daa0bcf255 bubbros-1.6.tar.bz2 9052959