summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-09 18:05:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-09 18:05:33 +0000
commit458a2b3d6c0282c5e6bf64c6e97e171fa8116daf (patch)
tree07bb577a5cd8ddc27872f199fbf01b45cb37b06d /games-arcade
parentStabilize sys-fs/ntfs3g-2010.1.16 on amd64. (diff)
downloadgentoo-2-458a2b3d6c0282c5e6bf64c6e97e171fa8116daf.tar.gz
gentoo-2-458a2b3d6c0282c5e6bf64c6e97e171fa8116daf.tar.bz2
gentoo-2-458a2b3d6c0282c5e6bf64c6e97e171fa8116daf.zip
Use system libcurl and fix building with libpng14 by Locke Shinseiko (Wizzleby).
(Portage version: 2.2_rc66/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/criticalmass/ChangeLog12
-rw-r--r--games-arcade/criticalmass/criticalmass-1.0.0-r1.ebuild41
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.0-libpng14.patch11
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.0-system_curl.patch33
4 files changed, 95 insertions, 2 deletions
diff --git a/games-arcade/criticalmass/ChangeLog b/games-arcade/criticalmass/ChangeLog
index ca474abe30da..193d55ff921c 100644
--- a/games-arcade/criticalmass/ChangeLog
+++ b/games-arcade/criticalmass/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-arcade/criticalmass
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/criticalmass/ChangeLog,v 1.15 2009/01/06 01:38:39 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/criticalmass/ChangeLog,v 1.16 2010/03/09 18:05:33 ssuominen Exp $
+
+*criticalmass-1.0.0-r1 (09 Mar 2010)
+
+ 09 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +criticalmass-1.0.0-r1.ebuild, +files/criticalmass-1.0.0-libpng14.patch,
+ +files/criticalmass-1.0.0-system_curl.patch:
+ Use system libcurl and fix building with libpng14 by Locke Shinseiko
+ (Wizzleby).
06 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
criticalmass-1.0.0.ebuild:
diff --git a/games-arcade/criticalmass/criticalmass-1.0.0-r1.ebuild b/games-arcade/criticalmass/criticalmass-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..18ad80b27750
--- /dev/null
+++ b/games-arcade/criticalmass/criticalmass-1.0.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/criticalmass/criticalmass-1.0.0-r1.ebuild,v 1.1 2010/03/09 18:05:33 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="SDL/OpenGL space shoot'em up game"
+HOMEPAGE="http://criticalmass.sourceforge.net/"
+SRC_URI="mirror://sourceforge/criticalmass/CriticalMass-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/sdl-mixer
+ media-libs/sdl-image[png]
+ media-libs/libpng
+ virtual/opengl
+ net-misc/curl"
+
+S=${WORKDIR}/CriticalMass-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-system_curl.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
+ rm -rf curl
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}${GAMES_BINDIR}/Packer"
+ dohtml Readme.html
+ dodoc TODO
+ newicon critter.png ${PN}.png
+ make_desktop_entry critter "Critical Mass"
+ prepgamesdirs
+}
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.0-libpng14.patch b/games-arcade/criticalmass/files/criticalmass-1.0.0-libpng14.patch
new file mode 100644
index 000000000000..882869b43a14
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.0-libpng14.patch
@@ -0,0 +1,11 @@
+--- configure.in
++++ configure.in
+@@ -99,7 +99,7 @@ if test "x$TARGET" = xWIN32; then
+ else
+ LIBS="-L/usr/local/lib -L/usr/X11R6/lib $LIBS"
+ CXXFLAGS="$CXXFLAGS -I/usr/X11R6/include"
+- AC_CHECK_LIB(png12, main,, AC_MSG_ERROR(libpng is needed))
++ AC_CHECK_LIB(png, main,, AC_MSG_ERROR(libpng is needed))
+ AC_CHECK_LIB(z, main,, AC_MSG_ERROR(libz is needed))
+ if test "x$TARGET" = xUNIX; then
+ if test "x$enable_dyngl" = xoff; then
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.0-system_curl.patch b/games-arcade/criticalmass/files/criticalmass-1.0.0-system_curl.patch
new file mode 100644
index 000000000000..02307ad7d8fc
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.0-system_curl.patch
@@ -0,0 +1,33 @@
+--- configure.in
++++ configure.in
+@@ -115,8 +115,6 @@ fi
+ AC_CHECK_LIB(m, sin,,
+ AC_MSG_ERROR(libm is needed))
+
+-AC_CONFIG_SUBDIRS(curl)
+-
+ AC_OUTPUT(Makefile utils/Makefile utilssdl/Makefile utilsgl/Makefile game/Makefile tools/Makefile data/Makefile data/music/Makefile tinyxml/Makefile)
+
+ echo "Configuration:
+--- game/Makefile.am
++++ game/Makefile.am
+@@ -41,7 +41,7 @@ critter_SOURCES = \
+ main.cpp
+
+ LDADD = \
+- ../curl/lib/libcurl.a \
++ -lcurl \
+ ../utils/libutils.a \
+ ../utilssdl/libutilssdl.a \
+ ../utilsgl/libutilsgl.a \
+--- Makefile.am
++++ Makefile.am
+@@ -4,7 +4,7 @@
+ AUTOMAKE_OPTIONS = 1.4
+
+ ## Any directories that you want built and installed should go here.
+-SUBDIRS = curl tinyxml utils utilssdl utilsgl tools data game
++SUBDIRS = tinyxml utils utilssdl utilsgl tools data game
+
+ ## Any directories you want a part of the distribution should be listed
+ ## here, as well as have a Makefile generated at the end of configure.in