summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-10-01 00:39:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-10-01 00:39:04 +0000
commit40ac23a672dfab2d1db96bb91229266e8461a600 (patch)
treece88412033f0314062085b685110d221fb09889e /games-arcade
parentBUG #53857 solved. (diff)
downloadgentoo-2-40ac23a672dfab2d1db96bb91229266e8461a600.tar.gz
gentoo-2-40ac23a672dfab2d1db96bb91229266e8461a600.tar.bz2
gentoo-2-40ac23a672dfab2d1db96bb91229266e8461a600.zip
fix cfg file support; docs++ (bug #64325 again)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/apricots/ChangeLog5
-rw-r--r--games-arcade/apricots/apricots-0.2.6.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/games-arcade/apricots/ChangeLog b/games-arcade/apricots/ChangeLog
index 2628c94dc4f7..750dd6ec0cd7 100644
--- a/games-arcade/apricots/ChangeLog
+++ b/games-arcade/apricots/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/apricots
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/ChangeLog,v 1.1 2004/09/19 08:32:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/ChangeLog,v 1.2 2004/10/01 00:39:04 mr_bones_ Exp $
+
+ 30 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> apricots-0.2.6.ebuild:
+ fix cfg file support; docs++ (bug #64325 again)
*apricots-0.2.6 (19 Sep 2004)
diff --git a/games-arcade/apricots/apricots-0.2.6.ebuild b/games-arcade/apricots/apricots-0.2.6.ebuild
index 5e54d04aef57..f3e8aaa3eca7 100644
--- a/games-arcade/apricots/apricots-0.2.6.ebuild
+++ b/games-arcade/apricots/apricots-0.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/apricots-0.2.6.ebuild,v 1.1 2004/09/19 08:32:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/apricots-0.2.6.ebuild,v 1.2 2004/10/01 00:39:04 mr_bones_ Exp $
inherit games
@@ -25,13 +25,18 @@ src_unpack() {
|| die "sed failed"
sed -i \
+ -e "s:filename(AP_PATH):filename(\"${GAMES_SYSCONFDIR}/${PN}/\"):" \
+ ${PN}/init.cpp \
+ || die "sed failed"
+ sed -i \
-e "s:apricots.cfg:${GAMES_SYSCONFDIR}/${PN}/apricots.cfg:" \
- ${PN}/init.cpp README apricots.html \
+ README apricots.html \
|| die "sed failed"
}
src_install() {
dodoc AUTHORS INSTALL README TODO ChangeLog
+ dohtml apricots.html
cd ${PN}
dogamesbin apricots || die "dogamesbin failed"
insinto "${GAMES_DATADIR}/${PN}"